aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2003-04-10 22:29:39 +0800
committerfjoe <fjoe@FreeBSD.org>2003-04-10 22:29:39 +0800
commit33454b7b0081892f150d06bd2cb4723210eaf180 (patch)
tree12cec1a56ee20d03ad4a791d6b46f9d229d61efc /x11
parent07985f12b2aa4e5ed8e2d82b8df6c084ffafaf4c (diff)
downloadfreebsd-ports-gnome-33454b7b0081892f150d06bd2cb4723210eaf180.tar.gz
freebsd-ports-gnome-33454b7b0081892f150d06bd2cb4723210eaf180.tar.zst
freebsd-ports-gnome-33454b7b0081892f150d06bd2cb4723210eaf180.zip
New port: cnslock
Cnslock is a dock application (dockapp) which provides a visual indication of the states of the three "lock" buttons (caps, num, and scroll). It should be especially useful for people who own a wireless keyboard with no leds on it, and thus have difficulty keeping track of "lock" states. Submitted by: Alexey Dokuchaev
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/cnslock/Makefile25
-rw-r--r--x11/cnslock/distinfo1
-rw-r--r--x11/cnslock/files/patch-Makefile16
-rw-r--r--x11/cnslock/pkg-descr9
-rw-r--r--x11/cnslock/pkg-plist1
6 files changed, 53 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 40c2bcb83b6f..8f7ac8e84e43 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -17,6 +17,7 @@
SUBDIR += blast
SUBDIR += bricons
SUBDIR += buttonbox
+ SUBDIR += cnslock
SUBDIR += decurs
SUBDIR += deskmenu
SUBDIR += dgs
diff --git a/x11/cnslock/Makefile b/x11/cnslock/Makefile
new file mode 100644
index 000000000000..39b48e6cbf5e
--- /dev/null
+++ b/x11/cnslock/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: cnslock
+# Date created: 10 May 2003
+# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cnslock
+PORTVERSION= 1.02
+CATEGORIES= x11 windowmaker
+MASTER_SITES= http://www.dockapps.com/download.php/id/181/ \
+ ftp://ftp.nsu.ru/tmp/
+
+MAINTAINER= danfe@regency.nsu.ru
+COMMENT= A visual indicator of the states of the three "lock" buttons
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_X_PREFIX= yes
+USE_XPM= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11/cnslock/distinfo b/x11/cnslock/distinfo
new file mode 100644
index 000000000000..79e576c9c096
--- /dev/null
+++ b/x11/cnslock/distinfo
@@ -0,0 +1 @@
+MD5 (cnslock-1.02.tar.gz) = ec17390325d4347f3ced36ffc54d9c31
diff --git a/x11/cnslock/files/patch-Makefile b/x11/cnslock/files/patch-Makefile
new file mode 100644
index 000000000000..5b107b39b842
--- /dev/null
+++ b/x11/cnslock/files/patch-Makefile
@@ -0,0 +1,16 @@
+--- Makefile.orig Thu Apr 10 19:48:41 2003
++++ Makefile Thu Apr 10 20:03:05 2003
+@@ -2,11 +2,11 @@
+ PREFIX = /usr/local
+
+ VERSION = 1.02
+-CFLAGS = -O3 -Wall `gtk-config --cflags` -DVERSION=$(VERSION) ${EXTRA}
++CFLAGS += `gtk12-config --cflags` -DVERSION=$(VERSION) ${EXTRA}
+ CC = gcc
+ OBJS = cnslock.o kleds.o applet.o
+
+-LIBS = `gtk-config --libs | sed "s/-lgtk//g"`
++LIBS = `gtk12-config --libs | sed "s/-lgtk12//g"` -lgnugetopt
+
+ all: cnslock
+
diff --git a/x11/cnslock/pkg-descr b/x11/cnslock/pkg-descr
new file mode 100644
index 000000000000..dbc797911445
--- /dev/null
+++ b/x11/cnslock/pkg-descr
@@ -0,0 +1,9 @@
+Cnslock is a dock application (dockapp) which provides a visual
+indication of the states of the three "lock" buttons (caps, num, and
+scroll).
+
+It should be especially useful for people who own a wireless keyboard
+with no leds on it, and thus have difficulty keeping track of "lock"
+states.
+
+WWW: http://www.dockapps.com/file.php/id/123
diff --git a/x11/cnslock/pkg-plist b/x11/cnslock/pkg-plist
new file mode 100644
index 000000000000..2d2b7b2c8aeb
--- /dev/null
+++ b/x11/cnslock/pkg-plist
@@ -0,0 +1 @@
+bin/cnslock