aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-12-21 05:07:27 +0800
committerpawel <pawel@FreeBSD.org>2011-12-21 05:07:27 +0800
commit3f7e8931ff7e68be6dae8261b65420275175b1d4 (patch)
tree8c853b7a0fe046094d496b0f37e8e86f8f901c40 /x11
parent593b6496bb0c48b1536bb81cb2644b21ac42df8e (diff)
downloadfreebsd-ports-gnome-3f7e8931ff7e68be6dae8261b65420275175b1d4.tar.gz
freebsd-ports-gnome-3f7e8931ff7e68be6dae8261b65420275175b1d4.tar.zst
freebsd-ports-gnome-3f7e8931ff7e68be6dae8261b65420275175b1d4.zip
- Support WITHOUT_NLS knob [1]
- Add INSTALLS_ICONS=yes PR: ports/162378 [1] Submitted by: arrowdodger <6yearold@gmail.com> [1] Approved by: maintainer
Diffstat (limited to 'x11')
-rw-r--r--x11/yakuake-kde4/Makefile15
-rw-r--r--x11/yakuake-kde4/files/patch-CMakeLists.txt12
-rw-r--r--x11/yakuake-kde4/pkg-plist66
3 files changed, 60 insertions, 33 deletions
diff --git a/x11/yakuake-kde4/Makefile b/x11/yakuake-kde4/Makefile
index e7a3085981e3..f8250a9927a1 100644
--- a/x11/yakuake-kde4/Makefile
+++ b/x11/yakuake-kde4/Makefile
@@ -20,9 +20,24 @@ LICENSE= GPLv2
USE_BZIP2= yes
USE_CMAKE= yes
USE_KDE4= kdelibs kdeprefix automoc4
+
+.if defined(WITHOUT_NLS)
+PLIST_SUB+= NLS="@comment "
+.else
+PLIST_SUB+= NLS=""
USE_GETTEXT= yes
+.endif
+
USE_QT_VER= 4
QT_COMPONENTS= corelib qmake_build moc_build rcc_build uic_build
+INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes
+post-patch:
+.if defined(WITHOUT_NLS)
+ @${REINPLACE_CMD} -e 's/^%%NLS%%/# /' ${WRKSRC}/CMakeLists.txt
+.else
+ @${REINPLACE_CMD} -e 's/^%%NLS%%//' ${WRKSRC}/CMakeLists.txt
+.endif
+
.include <bsd.port.mk>
diff --git a/x11/yakuake-kde4/files/patch-CMakeLists.txt b/x11/yakuake-kde4/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..17ea62fffc51
--- /dev/null
+++ b/x11/yakuake-kde4/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists_.txt 2011-11-08 19:31:32.273220945 +0400
++++ CMakeLists.txt 2011-11-08 19:31:10.253224705 +0400
+@@ -8,6 +8,6 @@
+
+ add_subdirectory( app )
+ add_subdirectory( skins )
+-find_package(Msgfmt REQUIRED)
+-find_package(Gettext REQUIRED)
+-add_subdirectory( po )
++%%NLS%%find_package(Msgfmt REQUIRED)
++%%NLS%%find_package(Gettext REQUIRED)
++%%NLS%%add_subdirectory( po )
diff --git a/x11/yakuake-kde4/pkg-plist b/x11/yakuake-kde4/pkg-plist
index 31e7f0502774..bfaa4d3b8184 100644
--- a/x11/yakuake-kde4/pkg-plist
+++ b/x11/yakuake-kde4/pkg-plist
@@ -99,39 +99,39 @@ share/icons/hicolor/32x32/apps/yakuake.png
share/icons/hicolor/48x48/apps/yakuake.png
share/icons/hicolor/64x64/apps/yakuake.png
share/icons/hicolor/scalable/apps/yakuake.svgz
-share/locale/ca/LC_MESSAGES/yakuake.mo
-share/locale/ca@valencia/LC_MESSAGES/yakuake.mo
-share/locale/cs/LC_MESSAGES/yakuake.mo
-share/locale/da/LC_MESSAGES/yakuake.mo
-share/locale/de/LC_MESSAGES/yakuake.mo
-share/locale/el/LC_MESSAGES/yakuake.mo
-share/locale/en_GB/LC_MESSAGES/yakuake.mo
-share/locale/es/LC_MESSAGES/yakuake.mo
-share/locale/et/LC_MESSAGES/yakuake.mo
-share/locale/fr/LC_MESSAGES/yakuake.mo
-share/locale/ga/LC_MESSAGES/yakuake.mo
-share/locale/gl/LC_MESSAGES/yakuake.mo
-share/locale/hr/LC_MESSAGES/yakuake.mo
-share/locale/it/LC_MESSAGES/yakuake.mo
-share/locale/ja/LC_MESSAGES/yakuake.mo
-share/locale/ko/LC_MESSAGES/yakuake.mo
-share/locale/nb/LC_MESSAGES/yakuake.mo
-share/locale/nds/LC_MESSAGES/yakuake.mo
-share/locale/nl/LC_MESSAGES/yakuake.mo
-share/locale/nn/LC_MESSAGES/yakuake.mo
-share/locale/pa/LC_MESSAGES/yakuake.mo
-share/locale/pl/LC_MESSAGES/yakuake.mo
-share/locale/pt/LC_MESSAGES/yakuake.mo
-share/locale/pt_BR/LC_MESSAGES/yakuake.mo
-share/locale/ro/LC_MESSAGES/yakuake.mo
-share/locale/ru/LC_MESSAGES/yakuake.mo
-share/locale/sk/LC_MESSAGES/yakuake.mo
-share/locale/sv/LC_MESSAGES/yakuake.mo
-share/locale/th/LC_MESSAGES/yakuake.mo
-share/locale/tr/LC_MESSAGES/yakuake.mo
-share/locale/uk/LC_MESSAGES/yakuake.mo
-share/locale/wa/LC_MESSAGES/yakuake.mo
-share/locale/zh_CN/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/ca@valencia/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/da/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/de/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/el/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/es/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/et/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/it/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/nds/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/th/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/wa/LC_MESSAGES/yakuake.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/yakuake.mo
@dirrmtry share/icons/hicolor/256x256/apps
@dirrmtry share/icons/hicolor/256x256
@dirrm share/apps/yakuake/skins/plastik_light/title