aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-11-20 21:07:45 +0800
committersobomax <sobomax@FreeBSD.org>2001-11-20 21:07:45 +0800
commit432b366dd5d5b7107967d308ebe548a0c4240677 (patch)
tree0cfba91d14cd63ffed609dcf481c3ac87d767ea4 /x11
parent26a84490bbfcf1caa2da31e0cafd937ccf94e39d (diff)
downloadfreebsd-ports-gnome-432b366dd5d5b7107967d308ebe548a0c4240677.tar.gz
freebsd-ports-gnome-432b366dd5d5b7107967d308ebe548a0c4240677.tar.zst
freebsd-ports-gnome-432b366dd5d5b7107967d308ebe548a0c4240677.zip
Tech gnome-session how to set-up a LD_LIBRARY_PATH, so that mozilla
component of nautilus Just Works[tm], without the need to customize environment. Remove appropriate comment from post-install section of nautilus' Makefile.
Diffstat (limited to 'x11')
-rw-r--r--x11/gnomecore/Makefile2
-rw-r--r--x11/gnomecore/files/patch-ap16
-rw-r--r--x11/gnomecore/files/patch-gsm::ice.c21
3 files changed, 35 insertions, 4 deletions
diff --git a/x11/gnomecore/Makefile b/x11/gnomecore/Makefile
index 61b287eb421b..e407bb51499a 100644
--- a/x11/gnomecore/Makefile
+++ b/x11/gnomecore/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomecore
PORTVERSION= 1.4.0.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-core
diff --git a/x11/gnomecore/files/patch-ap b/x11/gnomecore/files/patch-ap
index 09b57026b387..a3baa630b8d8 100644
--- a/x11/gnomecore/files/patch-ap
+++ b/x11/gnomecore/files/patch-ap
@@ -1,7 +1,17 @@
---- gsm/Makefile.in.orig Tue Aug 1 23:56:19 2000
-+++ gsm/Makefile.in Tue Aug 1 23:59:25 2000
-@@ -143,3 +143,3 @@
+
+$FreeBSD$
+
+--- gsm/Makefile.in.orig Tue Nov 20 12:20:56 2001
++++ gsm/Makefile.in Tue Nov 20 14:56:33 2001
+@@ -157,9 +157,9 @@
+
+ SUBDIRS = help
-defaultdir = $(datadir)/gnome
+defaultdir = $(datadir)
+-INCLUDES = -I$(includedir) $(GNOME_INCLUDEDIR) -I$(top_srcdir)/intl -I$(top_builddir)/intl -DGNOMELOCALEDIR=\""$(prefix)/share/locale\"" -DDEFAULTDIR="\"$(defaultdir)\"" @CANVAS_PIXBUF_CFLAGS@
++INCLUDES = -I$(includedir) $(GNOME_INCLUDEDIR) -I$(top_srcdir)/intl -I$(top_builddir)/intl -DGNOMELOCALEDIR=\""$(prefix)/share/locale\"" -DDEFAULTDIR="\"$(defaultdir)\"" @CANVAS_PIXBUF_CFLAGS@ -DX11BASE="\"$(X11BASE)\""
+
+
+ LDADD = $(GNOME_LIBDIR) $(GNOMEUI_LIBS) $(INTLLIBS)
diff --git a/x11/gnomecore/files/patch-gsm::ice.c b/x11/gnomecore/files/patch-gsm::ice.c
new file mode 100644
index 000000000000..fc2cbb4a0fa7
--- /dev/null
+++ b/x11/gnomecore/files/patch-gsm::ice.c
@@ -0,0 +1,21 @@
+
+$FreeBSD$
+
+--- gsm/ice.c 2001/11/20 12:53:53 1.1
++++ gsm/ice.c 2001/11/20 12:53:56
+@@ -337,6 +337,15 @@
+
+ p = g_strconcat (ENVNAME "=", ids, NULL);
+ putenv (p);
++
++ /* XXX: hack for embedded Mozilla */
++ p = getenv ("LD_LIBRARY_PATH");
++ if (p == NULL)
++ p = "";
++ else
++ p = g_strconcat (p, ":", NULL);
++ p = g_strconcat (p, X11BASE "/lib/mozilla-embedded", NULL);
++ setenv ("LD_LIBRARY_PATH", p, 1);
+ }
+
+ void