aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2009-03-22 00:46:54 +0800
committerpgj <pgj@FreeBSD.org>2009-03-22 00:46:54 +0800
commit6ece00a42424d2f9a8e100d38addabdc308343cf (patch)
tree8dd34e2dcd5baac534bc713e7f382db9f3562ba7 /x11
parent69f727932cae0b71086069b884357cfa21a42cdd (diff)
downloadfreebsd-ports-gnome-6ece00a42424d2f9a8e100d38addabdc308343cf.tar.gz
freebsd-ports-gnome-6ece00a42424d2f9a8e100d38addabdc308343cf.tar.zst
freebsd-ports-gnome-6ece00a42424d2f9a8e100d38addabdc308343cf.zip
- Add support for Xft and UTF-8 (optional)
- Add PORTDOCS - Add PORTEXAMPLES PR: ports/132120 Submitted by: Pavel Plesov <pavel (dot) plesov (at) gmail (dot) com> Approved by: maintainer, tabthorpe
Diffstat (limited to 'x11')
-rw-r--r--x11/hs-xmobar/Makefile46
-rw-r--r--x11/hs-xmobar/pkg-plist4
-rw-r--r--x11/xmobar/Makefile46
-rw-r--r--x11/xmobar/pkg-plist4
4 files changed, 90 insertions, 10 deletions
diff --git a/x11/hs-xmobar/Makefile b/x11/hs-xmobar/Makefile
index 20c751b44229..42b2cb10f666 100644
--- a/x11/hs-xmobar/Makefile
+++ b/x11/hs-xmobar/Makefile
@@ -6,6 +6,7 @@
PORTNAME= xmobar
PORTVERSION= 0.9
+PORTREVISION= 1
CATEGORIES= x11 haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/xmobar/${PORTVERSION}/ \
http://carte.kerneled.org/mirror/
@@ -22,17 +23,56 @@ USE_XORG= x11
CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= *
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${PORTVERSION}
+PORTEXAMPLES= *
+
PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
PORTVERSION=${PORTVERSION} \
SUBDIR=${SUBDIR}
+OPTIONS= XFT "Enable Xft support for fonts" Off \
+ UTF8 "Enable UTF-8 support" Off
+
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX}
+
+.if defined(WITH_XFT)
+CONFIGURE_ARGS+= --flags="with_xft"
+BUILD_DEPENDS+= hs-x11-xft-ghc>=0.2:${PORTSDIR}/x11/hs-x11-xft-ghc
+.elif defined(WITH_UTF8)
+CONFIGURE_ARGS+= --flags="with_utf8"
+BUILD_DEPENDS+= hs-utf8-string-ghc>=0.1:${PORTSDIR}/devel/hs-utf8-string-ghc
+.endif
+
+.if !defined(NOPORTDOCS)
+PLIST_SUB+= RMLIC="@comment "
+.else
+PLIST_SUB+= RMLIC=""
+.endif
+
do-configure:
- cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+ cd ${WRKSRC} && ${CABAL} configure ${CONFIGURE_ARGS}
do-build:
cd ${WRKSRC} && ${CABAL} build
do-install:
- cd ${WRKSRC} && ${CABAL} install
+ cd ${WRKSRC} && ${CABAL} install --verbose=3
+.if !defined(NOPORTDOCS)
+.for d in README
+ ${INSTALL_MAN} ${WRKSRC}/${d} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for f in xmobar.config-sample
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}
+.endfor
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/hs-xmobar/pkg-plist b/x11/hs-xmobar/pkg-plist
index b304c5a56605..81f3b79bf8d4 100644
--- a/x11/hs-xmobar/pkg-plist
+++ b/x11/hs-xmobar/pkg-plist
@@ -1,3 +1,3 @@
bin/xmobar
-share/doc/xmobar-%%PORTVERSION%%/LICENSE
-@dirrm share/doc/xmobar-%%PORTVERSION%%
+%%RMLIC%%%%DOCSDIR%%/LICENSE
+%%RMLIC%%@dirrm %%DOCSDIR%%
diff --git a/x11/xmobar/Makefile b/x11/xmobar/Makefile
index 20c751b44229..42b2cb10f666 100644
--- a/x11/xmobar/Makefile
+++ b/x11/xmobar/Makefile
@@ -6,6 +6,7 @@
PORTNAME= xmobar
PORTVERSION= 0.9
+PORTREVISION= 1
CATEGORIES= x11 haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/xmobar/${PORTVERSION}/ \
http://carte.kerneled.org/mirror/
@@ -22,17 +23,56 @@ USE_XORG= x11
CABAL= ${LOCALBASE}/bin/runghc Setup.lhs
GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
SUBDIR= lib/${PORTNAME}-${PORTVERSION}
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= *
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${PORTVERSION}
+PORTEXAMPLES= *
+
PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
PORTVERSION=${PORTVERSION} \
SUBDIR=${SUBDIR}
+OPTIONS= XFT "Enable Xft support for fonts" Off \
+ UTF8 "Enable UTF-8 support" Off
+
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS= --ghc --prefix=${PREFIX}
+
+.if defined(WITH_XFT)
+CONFIGURE_ARGS+= --flags="with_xft"
+BUILD_DEPENDS+= hs-x11-xft-ghc>=0.2:${PORTSDIR}/x11/hs-x11-xft-ghc
+.elif defined(WITH_UTF8)
+CONFIGURE_ARGS+= --flags="with_utf8"
+BUILD_DEPENDS+= hs-utf8-string-ghc>=0.1:${PORTSDIR}/devel/hs-utf8-string-ghc
+.endif
+
+.if !defined(NOPORTDOCS)
+PLIST_SUB+= RMLIC="@comment "
+.else
+PLIST_SUB+= RMLIC=""
+.endif
+
do-configure:
- cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+ cd ${WRKSRC} && ${CABAL} configure ${CONFIGURE_ARGS}
do-build:
cd ${WRKSRC} && ${CABAL} build
do-install:
- cd ${WRKSRC} && ${CABAL} install
+ cd ${WRKSRC} && ${CABAL} install --verbose=3
+.if !defined(NOPORTDOCS)
+.for d in README
+ ${INSTALL_MAN} ${WRKSRC}/${d} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+.for f in xmobar.config-sample
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}
+.endfor
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/xmobar/pkg-plist b/x11/xmobar/pkg-plist
index b304c5a56605..81f3b79bf8d4 100644
--- a/x11/xmobar/pkg-plist
+++ b/x11/xmobar/pkg-plist
@@ -1,3 +1,3 @@
bin/xmobar
-share/doc/xmobar-%%PORTVERSION%%/LICENSE
-@dirrm share/doc/xmobar-%%PORTVERSION%%
+%%RMLIC%%%%DOCSDIR%%/LICENSE
+%%RMLIC%%@dirrm %%DOCSDIR%%