aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorlesi <lesi@FreeBSD.org>2005-01-19 06:17:29 +0800
committerlesi <lesi@FreeBSD.org>2005-01-19 06:17:29 +0800
commit9a872b94f20b82089ccbd32d162f2c0bb87e997c (patch)
treea4ac5dbc7e793db229296f7f84deb40f81615a4e /x11
parent89565fac9c700a75b34093aabd04c94c23581a43 (diff)
downloadfreebsd-ports-gnome-9a872b94f20b82089ccbd32d162f2c0bb87e997c.tar.gz
freebsd-ports-gnome-9a872b94f20b82089ccbd32d162f2c0bb87e997c.tar.zst
freebsd-ports-gnome-9a872b94f20b82089ccbd32d162f2c0bb87e997c.zip
Don't blindly override DEPENDS_TARGET when making package.
Submitted by: roam
Diffstat (limited to 'x11')
-rw-r--r--x11/XFree86-4/Makefile2
-rw-r--r--x11/xorg/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/x11/XFree86-4/Makefile b/x11/XFree86-4/Makefile
index aba5780232b0..972ac77b18c3 100644
--- a/x11/XFree86-4/Makefile
+++ b/x11/XFree86-4/Makefile
@@ -48,7 +48,7 @@ pre-everything::
@${ECHO_MSG} "upgrade XFree86. If you simply type 'make install' it may use over 2GB to build"
@${ECHO_MSG} "all of the subports. You can install the ports singly if you are low on space."
-.if make(package)
+.if make(package) && empty(DEPENDS_TARGET:Mpackage)
DEPENDS_TARGET="package"
.endif
.undef NOCLEANDEPENDS
diff --git a/x11/xorg/Makefile b/x11/xorg/Makefile
index d6d61aa95422..b898a91abba4 100644
--- a/x11/xorg/Makefile
+++ b/x11/xorg/Makefile
@@ -55,7 +55,7 @@ pre-everything::
@${ECHO_MSG} "upgrade X.Org. If you simply type 'make install' it may use over 2GB to build"
@${ECHO_MSG} "all of the subports. You can install the ports singly if you are low on space."
-.if make(package)
+.if make(package) && empty(DEPENDS_TARGET:Mpackage)
DEPENDS_TARGET="package"
.endif