aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-01-31 10:44:48 +0800
committerjbeich <jbeich@FreeBSD.org>2017-01-31 10:44:48 +0800
commit9b284cfac6813e5183fa08b101f77269284f5d31 (patch)
tree5725b66ab75705156f103b58fb0f43177049b32e /x11
parent75250b712e68a416ec461c498f0ff825802110be (diff)
downloadfreebsd-ports-gnome-9b284cfac6813e5183fa08b101f77269284f5d31.tar.gz
freebsd-ports-gnome-9b284cfac6813e5183fa08b101f77269284f5d31.tar.zst
freebsd-ports-gnome-9b284cfac6813e5183fa08b101f77269284f5d31.zip
x11/slim: unbreak build with clang/libc++ 4.0
PR: 216633 Submitted by: Henry Hu <henry.hu.sh@gmail.com> (maintainer)
Diffstat (limited to 'x11')
-rw-r--r--x11/slim/Makefile2
-rw-r--r--x11/slim/files/patch-panel.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index eb3b0109e231..c19e1317e170 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= slim
PORTVERSION= 1.3.6
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= x11
MASTER_SITES= ftp://ftp.berlios.de/pub/slim/ \
SF/slim.berlios
diff --git a/x11/slim/files/patch-panel.cpp b/x11/slim/files/patch-panel.cpp
new file mode 100644
index 000000000000..5a4da2cf2659
--- /dev/null
+++ b/x11/slim/files/patch-panel.cpp
@@ -0,0 +1,11 @@
+--- panel.cpp.orig 2013-10-01 22:38:05 UTC
++++ panel.cpp
+@@ -48,7 +48,7 @@ Panel::Panel(Display* dpy, int scr, Wind
+ gcm = GCGraphicsExposures;
+ gcv.graphics_exposures = False;
+ WinGC = XCreateGC(Dpy, Win, gcm, &gcv);
+- if (WinGC < 0) {
++ if (WinGC == NULL) {
+ cerr << APPNAME
+ << ": failed to create pixmap\n.";
+ exit(ERR_EXIT);