aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2015-09-05 01:24:08 +0800
committerjkim <jkim@FreeBSD.org>2015-09-05 01:24:08 +0800
commitcb1bd26c93b7f4f76f869a67a7611e3f8df556b1 (patch)
tree85e7469f3bdedf9df16e16df4f8573ab1723524a /x11
parentfd1c125ee7f6a9048a878d7744e0eb757aef71bd (diff)
downloadfreebsd-ports-gnome-cb1bd26c93b7f4f76f869a67a7611e3f8df556b1.tar.gz
freebsd-ports-gnome-cb1bd26c93b7f4f76f869a67a7611e3f8df556b1.tar.zst
freebsd-ports-gnome-cb1bd26c93b7f4f76f869a67a7611e3f8df556b1.zip
- Add an upstream patch for archivers/py-lz4 to export its version number.
- Remove a local hack for x11/xpra to properly detect LZ4 version.
Diffstat (limited to 'x11')
-rw-r--r--x11/xpra/Makefile3
-rw-r--r--x11/xpra/files/patch-xpra_net_compression.py26
2 files changed, 2 insertions, 27 deletions
diff --git a/x11/xpra/Makefile b/x11/xpra/Makefile
index 959d26ea8033..a3eff9df7773 100644
--- a/x11/xpra/Makefile
+++ b/x11/xpra/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xpra
PORTVERSION= 0.15.5
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://xpra.org/src/
@@ -13,7 +14,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython \
${PYTHON_SITELIBDIR}/gtk-2.0/gtk/__init__.py:${PORTSDIR}/x11-toolkits/py-gtk2
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/lz4.so:${PORTSDIR}/archivers/py-lz4 \
+RUN_DEPENDS= py${PYTHON_SUFFIX}-lz4>=0.7.0_1:${PORTSDIR}/archivers/py-lz4 \
pulseaudio:${PORTSDIR}/audio/pulseaudio \
${PYTHON_SITELIBDIR}/rencode/__init__.py:${PORTSDIR}/converters/py-rencode \
${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus \
diff --git a/x11/xpra/files/patch-xpra_net_compression.py b/x11/xpra/files/patch-xpra_net_compression.py
deleted file mode 100644
index 5084886f6fdb..000000000000
--- a/x11/xpra/files/patch-xpra_net_compression.py
+++ /dev/null
@@ -1,26 +0,0 @@
---- xpra/net/compression.py.orig 2015-08-25 09:32:59 UTC
-+++ xpra/net/compression.py
-@@ -23,7 +23,9 @@ try:
- return level | LZ4_FLAG, LZ4_compress(packet)
- #try to figure out the version number:
- if hasattr(lz4, "VERSION"):
-- lz4_version = str(lz4.VERSION)
-+ lz4_version = lz4.VERSION
-+ if hasattr(lz4, "LZ4_VERSION"):
-+ lz4_version.append(lz4.LZ4_VERSION)
- elif hasattr(lz4, "__file__"):
- #hack it..
- import os.path
-@@ -44,10 +46,8 @@ try:
- #we want at least two numbers first:
- if len(tmpv)>=2:
- #ie: (0, 7, 0)
-- lz4_version = ".".join([str(x) for x in tmpv])
-- assert lz4_version>="0.7", "versions older than 0.7.0 are vulnerable and should not be used, see CVE-2014-4715"
-- if hasattr(lz4, "LZ4_VERSION"):
-- lz4_version += "."+str(lz4.LZ4_VERSION)
-+ lz4_version = tuple(tmpv)
-+ assert lz4_version>=(0, 7), "versions older than 0.7.0 are vulnerable and should not be used, see CVE-2014-4715"
- except Exception as e:
- log("lz4 not found: %s", e)
- LZ4_uncompress = None