aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-16 11:34:56 +0800
committeradamw <adamw@FreeBSD.org>2014-07-16 11:34:56 +0800
commite59a4b143e5a81be22c10888ea69fd7b283547b2 (patch)
treefe6e6f1047f8d67869e24a29bf32f5ba72588a1c /x11
parentdd23101ff5718a035365d041a14e0159b16908e9 (diff)
downloadfreebsd-ports-gnome-e59a4b143e5a81be22c10888ea69fd7b283547b2.tar.gz
freebsd-ports-gnome-e59a4b143e5a81be22c10888ea69fd7b283547b2.tar.zst
freebsd-ports-gnome-e59a4b143e5a81be22c10888ea69fd7b283547b2.zip
Add DOCS option to the remaining staged ports where PORTDOCS appears
in the plist.
Diffstat (limited to 'x11')
-rw-r--r--x11/ipager/Makefile2
-rw-r--r--x11/libxcb/Makefile2
-rw-r--r--x11/mrxvt-devel/Makefile2
-rw-r--r--x11/ruby-X11/Makefile2
-rw-r--r--x11/tilda/Makefile2
5 files changed, 9 insertions, 1 deletions
diff --git a/x11/ipager/Makefile b/x11/ipager/Makefile
index a98389868592..0cd05ee28562 100644
--- a/x11/ipager/Makefile
+++ b/x11/ipager/Makefile
@@ -25,6 +25,8 @@ THEMES= atlantis.conf \
light_gray.conf \
light_orange.conf
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e '35,36d;89d;92,94d' \
-e "s/\([^-]pthread'\)/\1, 'X11'/" \
diff --git a/x11/libxcb/Makefile b/x11/libxcb/Makefile
index f36f0fb49ed4..1f6ec6b5118e 100644
--- a/x11/libxcb/Makefile
+++ b/x11/libxcb/Makefile
@@ -26,6 +26,8 @@ USE_GNOME= libxslt:build
USE_XORG= xau xdmcp
USE_PYTHON_BUILD=2
+OPTIONS_DEFINE= DOCS
+
.for f in XPROTO_CFLAGS XPROTO_LIBS XDMCP_CFLAGS XDMCP_LIBS NEEDED_CFLAGS NEEDED_LIBS
CONFIGURE_ARGS+=${f}="${${f}}"
.endfor
diff --git a/x11/mrxvt-devel/Makefile b/x11/mrxvt-devel/Makefile
index 6134c2843f35..c6d28b0263a0 100644
--- a/x11/mrxvt-devel/Makefile
+++ b/x11/mrxvt-devel/Makefile
@@ -28,7 +28,7 @@ DESKTOP_ENTRIES= "mrxvt" "mrxvt terminal emulator" \
false
OPTIONS_DEFINE= XFT BACKGROUND JPEG PNG TRANSPARENCY SWAPSCREEN JAPANESE 24BITS \
- MENUBAR TEXTSHADOW FRILLS
+ MENUBAR TEXTSHADOW FRILLS DOCS
OPTIONS_DEFAULT= BACKGROUND JPEG PNG TRANSPARENCY SWAPSCREEN 24BITS \
MENUBAR XFT JAPANESE FRILLS TEXTSHADOW
BACKGROUND_DESC= Background images
diff --git a/x11/ruby-X11/Makefile b/x11/ruby-X11/Makefile
index 4f5f0c8a2333..ffd9e1d8d499 100644
--- a/x11/ruby-X11/Makefile
+++ b/x11/ruby-X11/Makefile
@@ -19,6 +19,8 @@ NO_BUILD= yes
DOCS= ChangeLog Documentation Overview TODO
EXAMPLES= tests/*
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${RUBY_SITELIBDIR}/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/* ${STAGEDIR}${RUBY_SITELIBDIR}/${PORTNAME}/
diff --git a/x11/tilda/Makefile b/x11/tilda/Makefile
index 8ab9e34e2f77..66d0fe94ed16 100644
--- a/x11/tilda/Makefile
+++ b/x11/tilda/Makefile
@@ -19,6 +19,8 @@ USES= gmake gettext pkgconfig
DOCS= AUTHORS ChangeLog README TODO
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|ps -C tilda -o pid=|pgrep tilda|' \
${WRKSRC}/src/tilda.c