aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2006-04-08 02:58:24 +0800
committerlofi <lofi@FreeBSD.org>2006-04-08 02:58:24 +0800
commitec0d9edb4753d78624cc699fafd85862c58eb12f (patch)
tree659129d061beb171ba55567a76042df90ab1fbdc /x11
parent1859622bc4df27fe8b5fecda2513dc7a6eefc896 (diff)
downloadfreebsd-ports-gnome-ec0d9edb4753d78624cc699fafd85862c58eb12f.tar.gz
freebsd-ports-gnome-ec0d9edb4753d78624cc699fafd85862c58eb12f.tar.zst
freebsd-ports-gnome-ec0d9edb4753d78624cc699fafd85862c58eb12f.zip
Fix KDE bug 124654.
Obtained from: KDE SVN, Alexander Stepanov <sam@comintel.ru>
Diffstat (limited to 'x11')
-rw-r--r--x11/kdelibs3/Makefile1
-rw-r--r--x11/kdelibs3/files/patch-kioslave_http-http.cc19
-rw-r--r--x11/kdelibs4/Makefile1
-rw-r--r--x11/kdelibs4/files/patch-kioslave_http-http.cc19
4 files changed, 40 insertions, 0 deletions
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index f793c673a593..a94d1ae0d82c 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdelibs3/files/patch-kioslave_http-http.cc b/x11/kdelibs3/files/patch-kioslave_http-http.cc
new file mode 100644
index 000000000000..7c2565aa3a87
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kioslave_http-http.cc
@@ -0,0 +1,19 @@
+--- kioslave/http/http.cc.orig Fri Apr 7 06:17:01 2006
++++ kioslave/http/http.cc Fri Apr 7 06:18:00 2006
+@@ -3590,6 +3590,16 @@
+ error(ERR_ACCESS_DENIED, u.url());
+ return false;
+ }
++
++ // preserve #ref: (bug 124654)
++ // if we were at http://host/resource1#ref, we sent a GET for "/resource1"
++ // if we got redirected to http://host/resource2, then we have to re-add
++ // the fragment:
++ if (m_request.url.hasRef() && !u.hasRef() &&
++ (m_request.url.host() == u.host()) &&
++ (m_request.url.protocol() == u.protocol()))
++ u.setRef(m_request.url.ref());
++
+ m_bRedirect = true;
+ m_redirectLocation = u;
+
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index f793c673a593..a94d1ae0d82c 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdelibs4/files/patch-kioslave_http-http.cc b/x11/kdelibs4/files/patch-kioslave_http-http.cc
new file mode 100644
index 000000000000..7c2565aa3a87
--- /dev/null
+++ b/x11/kdelibs4/files/patch-kioslave_http-http.cc
@@ -0,0 +1,19 @@
+--- kioslave/http/http.cc.orig Fri Apr 7 06:17:01 2006
++++ kioslave/http/http.cc Fri Apr 7 06:18:00 2006
+@@ -3590,6 +3590,16 @@
+ error(ERR_ACCESS_DENIED, u.url());
+ return false;
+ }
++
++ // preserve #ref: (bug 124654)
++ // if we were at http://host/resource1#ref, we sent a GET for "/resource1"
++ // if we got redirected to http://host/resource2, then we have to re-add
++ // the fragment:
++ if (m_request.url.hasRef() && !u.hasRef() &&
++ (m_request.url.host() == u.host()) &&
++ (m_request.url.protocol() == u.protocol()))
++ u.setRef(m_request.url.ref());
++
+ m_bRedirect = true;
+ m_redirectLocation = u;
+