aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-04-11 03:44:33 +0800
committertcberner <tcberner@FreeBSD.org>2018-04-11 03:44:33 +0800
commitfd0a0eec8ebee62458277f5fc18dcbaa29f4e7f2 (patch)
tree29f0f300ce31a475574e4aee7fef2f33aee95f6b /x11
parent74f77fb1afdf76f65b58d21863cc4ba75d8b8d97 (diff)
downloadfreebsd-ports-gnome-fd0a0eec8ebee62458277f5fc18dcbaa29f4e7f2.tar.gz
freebsd-ports-gnome-fd0a0eec8ebee62458277f5fc18dcbaa29f4e7f2.tar.zst
freebsd-ports-gnome-fd0a0eec8ebee62458277f5fc18dcbaa29f4e7f2.zip
New ports: x11/konsole
This is the current version of KDE Applications <foo>. Note that users of KDE SC4 should stick with <foo>-kde4.
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/konsole/Makefile24
-rw-r--r--x11/konsole/distinfo3
-rw-r--r--x11/konsole/pkg-descr9
-rw-r--r--x11/konsole/pkg-plist83
5 files changed, 120 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 2691b748a1d7..d52e9ffc15a1 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -145,6 +145,7 @@
SUBDIR += kf5-kwindowsystem
SUBDIR += kf5-plasma-framework
SUBDIR += kgamma-kde4
+ SUBDIR += konsole
SUBDIR += konsole-kde4
SUBDIR += leechcraft
SUBDIR += lemonbar
diff --git a/x11/konsole/Makefile b/x11/konsole/Makefile
new file mode 100644
index 000000000000..9c3d2a95efcb
--- /dev/null
+++ b/x11/konsole/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= konsole
+DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+CATEGORIES= x11 kde kde-applications # kde kde-applications-applications
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE terminal emulator
+
+BUILD_DEPENDS= ${LOCALBASE}/share/xsl/docbook/html/docbook.xsl:textproc/docbook-xsl \
+ docbook-xml>0:textproc/docbook-xml
+RUN_DEPENDS= keditbookmarks:deskutils/keditbookmarks
+
+USES= cmake:outsource gettext pkgconfig kde:5 tar:xz
+USE_KDE= auth bookmarks codecs completion config configwidgets \
+ coreaddons crash dbusaddons ecm emoticons guiaddons i18n \
+ iconthemes init itemmodels jobwidgets kdelibs4support kio \
+ notifications notifyconfig parts pty service sonnet \
+ textwidgets widgetsaddons windowsystem xmlgui
+USE_QT5= core dbus gui network printsupport script scripttools sql \
+ widgets xml \
+ buildtools_build qmake_build
+
+.include <bsd.port.mk>
diff --git a/x11/konsole/distinfo b/x11/konsole/distinfo
new file mode 100644
index 000000000000..6623e3b97cf9
--- /dev/null
+++ b/x11/konsole/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1520519251
+SHA256 (KDE/applications/17.12.3/konsole-17.12.3.tar.xz) = fa0997c14a96252177e4808636ec43509eadb1482d54bb8a86b85810283f6cbc
+SIZE (KDE/applications/17.12.3/konsole-17.12.3.tar.xz) = 1026672
diff --git a/x11/konsole/pkg-descr b/x11/konsole/pkg-descr
new file mode 100644
index 000000000000..8d2e79d96b24
--- /dev/null
+++ b/x11/konsole/pkg-descr
@@ -0,0 +1,9 @@
+Konsole is a terminal program for KDE.
+
+As well as being a standalone program, it is also used by other KDE
+programs such as the Kate editor and KDevelop development environment
+to provide easy access to a terminal window. Konsole's features and
+usage are explained and illustrated in the Konsole handbook, which can
+be accessed by browsing to "help:/konsole" in Konqueror.
+
+WWW: http://konsole.kde.org
diff --git a/x11/konsole/pkg-plist b/x11/konsole/pkg-plist
new file mode 100644
index 000000000000..0b4c53d04adc
--- /dev/null
+++ b/x11/konsole/pkg-plist
@@ -0,0 +1,83 @@
+bin/konsole
+bin/konsoleprofile
+lib/libkdeinit5_konsole.so
+lib/libkonsoleprivate.so.17
+lib/libkonsoleprivate.so.%%KDE_APPLICATIONS_VERSION%%
+%%QT_PLUGINDIR%%/konsolepart.so
+share/applications/org.kde.konsole.desktop
+share/knotifications5/konsole.notifyrc
+%%DATADIR%%/BlackOnLightYellow.colorscheme
+%%DATADIR%%/BlackOnRandomLight.colorscheme
+%%DATADIR%%/BlackOnWhite.colorscheme
+%%DATADIR%%/BlueOnBlack.colorscheme
+%%DATADIR%%/Breeze.colorscheme
+%%DATADIR%%/DarkPastels.colorscheme
+%%DATADIR%%/GreenOnBlack.colorscheme
+%%DATADIR%%/Linux.colorscheme
+%%DATADIR%%/RedOnBlack.colorscheme
+%%DATADIR%%/Solarized.colorscheme
+%%DATADIR%%/SolarizedLight.colorscheme
+%%DATADIR%%/WhiteOnBlack.colorscheme
+%%DATADIR%%/default.keytab
+%%DATADIR%%/linux.keytab
+%%DATADIR%%/solaris.keytab
+share/kservices5/ServiceMenus/konsolehere.desktop
+share/kservices5/ServiceMenus/konsolerun.desktop
+share/kservices5/konsolepart.desktop
+share/kservicetypes5/terminalemulator.desktop
+share/locale/ar/LC_MESSAGES/konsole.mo
+share/locale/ast/LC_MESSAGES/konsole.mo
+share/locale/bg/LC_MESSAGES/konsole.mo
+share/locale/bs/LC_MESSAGES/konsole.mo
+share/locale/ca/LC_MESSAGES/konsole.mo
+share/locale/ca@valencia/LC_MESSAGES/konsole.mo
+share/locale/cs/LC_MESSAGES/konsole.mo
+share/locale/da/LC_MESSAGES/konsole.mo
+share/locale/de/LC_MESSAGES/konsole.mo
+share/locale/el/LC_MESSAGES/konsole.mo
+share/locale/en_GB/LC_MESSAGES/konsole.mo
+share/locale/eo/LC_MESSAGES/konsole.mo
+share/locale/es/LC_MESSAGES/konsole.mo
+share/locale/et/LC_MESSAGES/konsole.mo
+share/locale/eu/LC_MESSAGES/konsole.mo
+share/locale/fa/LC_MESSAGES/konsole.mo
+share/locale/fi/LC_MESSAGES/konsole.mo
+share/locale/fr/LC_MESSAGES/konsole.mo
+share/locale/ga/LC_MESSAGES/konsole.mo
+share/locale/gl/LC_MESSAGES/konsole.mo
+share/locale/he/LC_MESSAGES/konsole.mo
+share/locale/hi/LC_MESSAGES/konsole.mo
+share/locale/hr/LC_MESSAGES/konsole.mo
+share/locale/hu/LC_MESSAGES/konsole.mo
+share/locale/ia/LC_MESSAGES/konsole.mo
+share/locale/id/LC_MESSAGES/konsole.mo
+share/locale/is/LC_MESSAGES/konsole.mo
+share/locale/it/LC_MESSAGES/konsole.mo
+share/locale/ja/LC_MESSAGES/konsole.mo
+share/locale/kk/LC_MESSAGES/konsole.mo
+share/locale/km/LC_MESSAGES/konsole.mo
+share/locale/ko/LC_MESSAGES/konsole.mo
+share/locale/lt/LC_MESSAGES/konsole.mo
+share/locale/lv/LC_MESSAGES/konsole.mo
+share/locale/mr/LC_MESSAGES/konsole.mo
+share/locale/nb/LC_MESSAGES/konsole.mo
+share/locale/nds/LC_MESSAGES/konsole.mo
+share/locale/nl/LC_MESSAGES/konsole.mo
+share/locale/nn/LC_MESSAGES/konsole.mo
+share/locale/pa/LC_MESSAGES/konsole.mo
+share/locale/pl/LC_MESSAGES/konsole.mo
+share/locale/pt/LC_MESSAGES/konsole.mo
+share/locale/pt_BR/LC_MESSAGES/konsole.mo
+share/locale/ro/LC_MESSAGES/konsole.mo
+share/locale/ru/LC_MESSAGES/konsole.mo
+share/locale/sk/LC_MESSAGES/konsole.mo
+share/locale/sl/LC_MESSAGES/konsole.mo
+share/locale/sr/LC_MESSAGES/konsole.mo
+share/locale/sv/LC_MESSAGES/konsole.mo
+share/locale/tr/LC_MESSAGES/konsole.mo
+share/locale/ug/LC_MESSAGES/konsole.mo
+share/locale/uk/LC_MESSAGES/konsole.mo
+share/locale/wa/LC_MESSAGES/konsole.mo
+share/locale/zh_CN/LC_MESSAGES/konsole.mo
+share/locale/zh_TW/LC_MESSAGES/konsole.mo
+share/metainfo/org.kde.konsole.appdata.xml