aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-12-03 03:47:17 +0800
committermakc <makc@FreeBSD.org>2010-12-03 03:47:17 +0800
commit1b9ec1582fbf2b219f611d52fca8410e3cd06973 (patch)
tree42a169743be676e050a1e903ddf771488b5da9bb /x11
parent69e87da3a0f46ad0c31d376913c821cc72c51ecd (diff)
downloadfreebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.tar.gz
freebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.tar.zst
freebsd-ports-gnome-1b9ec1582fbf2b219f611d52fca8410e3cd06973.zip
KDE FreeBSD team is glad to present Qt 4.7.1 in ports.
Along with Qt4 the following ports are updated: PyQt4 ports to 4.8.1 devel/py-sip to 4.11.2 devel/qscintilla2 to 2.4.5 PyKDE3 to 3.16.7 PyQt3 tp 3.18.2-snapshot-20091119 New ports added: devel/qt4-declarative devel/py-qt4-declarative x11/qt4-graphicssystems-opengl This release has been contributed by: Thomas Abthorpe (tabthorpe) Max Brazhnikov (makc) Dima Panov (fluffy) Alberto Villa (avilla) We'd like to thank Martin Wilke (miwi) for exp-run.
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/py-qt4-opengl/distinfo5
-rw-r--r--x11/py-qt4-opengl/pkg-plist1
-rw-r--r--x11/qt4-graphicssystems-opengl/Makefile53
-rw-r--r--x11/qt4-graphicssystems-opengl/pkg-descr11
-rw-r--r--x11/qt4-graphicssystems-opengl/pkg-plist4
-rw-r--r--x11/qt4-inputmethods/Makefile2
-rw-r--r--x11/qt4-opengl/Makefile5
-rw-r--r--x11/qt4-opengl/pkg-plist3
9 files changed, 79 insertions, 6 deletions
diff --git a/x11/Makefile b/x11/Makefile
index de0fdd79570e..440a4bebdb13 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -243,6 +243,7 @@
SUBDIR += props
SUBDIR += py-qt4-opengl
SUBDIR += qimageblitz
+ SUBDIR += qt4-graphicssystems-opengl
SUBDIR += qt4-inputmethods
SUBDIR += qt4-opengl
SUBDIR += randrproto
diff --git a/x11/py-qt4-opengl/distinfo b/x11/py-qt4-opengl/distinfo
index 9a0976bb9c38..6c04995bffe2 100644
--- a/x11/py-qt4-opengl/distinfo
+++ b/x11/py-qt4-opengl/distinfo
@@ -1,3 +1,2 @@
-MD5 (PyQt-x11-gpl-4.7.3.tar.gz) = 42fdda73f07810abba002af8a939ee50
-SHA256 (PyQt-x11-gpl-4.7.3.tar.gz) = 574ad672b4171272028c49d5867087db04287c4dc7be8af17d71542db3a8225c
-SIZE (PyQt-x11-gpl-4.7.3.tar.gz) = 7803557
+SHA256 (PyQt-x11-gpl-4.8.1.tar.gz) = 1feab80dc82dcd451233edeb1cde9cc75fa38b6e8f47780ec6dc317ebe0cf370
+SIZE (PyQt-x11-gpl-4.8.1.tar.gz) = 9409175
diff --git a/x11/py-qt4-opengl/pkg-plist b/x11/py-qt4-opengl/pkg-plist
index 75f10d858998..6ea1eab764c7 100644
--- a/x11/py-qt4-opengl/pkg-plist
+++ b/x11/py-qt4-opengl/pkg-plist
@@ -2,6 +2,7 @@
%%SIP%%share/py-sip/QtOpenGL/QtOpenGLmod.sip
%%SIP%%share/py-sip/QtOpenGL/opengl_types.sip
%%SIP%%share/py-sip/QtOpenGL/qgl.sip
+%%SIP%%share/py-sip/QtOpenGL/qglbuffer.sip
%%SIP%%share/py-sip/QtOpenGL/qglcolormap.sip
%%SIP%%share/py-sip/QtOpenGL/qglframebufferobject.sip
%%SIP%%share/py-sip/QtOpenGL/qglpixelbuffer.sip
diff --git a/x11/qt4-graphicssystems-opengl/Makefile b/x11/qt4-graphicssystems-opengl/Makefile
new file mode 100644
index 000000000000..025f56393b59
--- /dev/null
+++ b/x11/qt4-graphicssystems-opengl/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: qt4-graphicssystems-opengl
+# Date created: 2010-11-07
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= graphicssystems
+DISTVERSION= ${QT4_VERSION}
+CATEGORIES?= x11
+PKGNAMEPREFIX= qt4-
+PKGNAMESUFFIX= -opengl
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= OpenGL rendering engine (experimental)
+
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build opengl
+QT_NONSTANDARD= yes
+QT_DIST= yes
+MAKE_JOBS_SAFE= yes
+
+HAS_CONFIGURE= yes
+USE_GL= glu
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
+ PATH=${WRKSRC}/bin:$$PATH
+
+DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
+ src/activeqt src/dbus src/multimedia src/network src/openvg \
+ src/phonon src/qt3support src/s60installs src/s60main \
+ src/script src/scripttools src/sql src/svg src/testlib \
+ src/tools src/winmain src/xml src/xmlpatterns \
+ src/3rdparty/clucene src/3rdparty/freetype \
+ src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
+ src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+.for dne in ${DO_NOT_EXTRACT}
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
+.endfor
+
+BUILD_WRKSRC= ${WRKSRC}/src/plugins/${PORTNAME}/opengl
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
+
+pre-configure:
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+
+.include <bsd.port.mk>
diff --git a/x11/qt4-graphicssystems-opengl/pkg-descr b/x11/qt4-graphicssystems-opengl/pkg-descr
new file mode 100644
index 000000000000..a319375a7bb9
--- /dev/null
+++ b/x11/qt4-graphicssystems-opengl/pkg-descr
@@ -0,0 +1,11 @@
+Qt provides a platform-independent API to all central platform
+functionality: GUI, database access, networking, file handling,
+etc.
+
+This port provides OpenGL graphics backend, which is used for
+on-screen widgets and QPixmaps. See for details:
+
+http://doc.qt.nokia.com/4.7/qapplication.html#setGraphicsSystem
+http://labs.qt.nokia.com/2008/10/22/so-long-and-thanks-for-the-blit/
+
+WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/x11/qt4-graphicssystems-opengl/pkg-plist b/x11/qt4-graphicssystems-opengl/pkg-plist
new file mode 100644
index 000000000000..b62b95506eaf
--- /dev/null
+++ b/x11/qt4-graphicssystems-opengl/pkg-plist
@@ -0,0 +1,4 @@
+%%QT_PLUGINDIR_REL%%/graphicssystems/libqglgraphicssystem.so
+%%DEBUG%%%%QT_PLUGINDIR_REL%%/graphicssystems/libqglgraphicssystem.so.debug
+@dirrmtry %%QT_PLUGINDIR_REL%%/graphicssystems
+@dirrmtry %%QT_PLUGINDIR_REL%%
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
index 7a76f2835512..ef8f2ff8274e 100644
--- a/x11/qt4-inputmethods/Makefile
+++ b/x11/qt4-inputmethods/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= inputmethods
-PORTVERSION= ${QT4_VERSION}
+DISTVERSION= ${QT4_VERSION}
CATEGORIES?= x11
PKGNAMEPREFIX= qt4-
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index 865fc858521a..4138ca6666f5 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= opengl
-PORTVERSION= ${QT4_VERSION}
+DISTVERSION= ${QT4_VERSION}
CATEGORIES?= x11
PKGNAMEPREFIX= qt4-
@@ -46,7 +46,8 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-CONFIGURE_ARGS+= -I../../include/Qt -I../../include
+CONFIGURE_ARGS+= -I../../include/QtCore -I../../include/QtGui \
+ -I../../include/Qt -I../../include
EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
diff --git a/x11/qt4-opengl/pkg-plist b/x11/qt4-opengl/pkg-plist
index 07a3b0d9bd9e..787b7289bee1 100644
--- a/x11/qt4-opengl/pkg-plist
+++ b/x11/qt4-opengl/pkg-plist
@@ -1,10 +1,12 @@
include/qt4/Qt/QtOpenGL
include/qt4/Qt/qgl.h
+include/qt4/Qt/qglbuffer.h
include/qt4/Qt/qglcolormap.h
include/qt4/Qt/qglframebufferobject.h
include/qt4/Qt/qglpixelbuffer.h
include/qt4/Qt/qglscreen_qws.h
include/qt4/Qt/qglshaderprogram.h
+include/qt4/QtOpenGL/QGLBuffer
include/qt4/QtOpenGL/QGLColormap
include/qt4/QtOpenGL/QGLContext
include/qt4/QtOpenGL/QGLFormat
@@ -22,6 +24,7 @@ include/qt4/QtOpenGL/QMacCompatGLuint
include/qt4/QtOpenGL/QMacGLCompatTypes
include/qt4/QtOpenGL/QtOpenGL
include/qt4/QtOpenGL/qgl.h
+include/qt4/QtOpenGL/qglbuffer.h
include/qt4/QtOpenGL/qglcolormap.h
include/qt4/QtOpenGL/qglframebufferobject.h
include/qt4/QtOpenGL/qglpixelbuffer.h