aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-15 18:08:54 +0800
committersf <sf@FreeBSD.org>2003-07-15 18:08:54 +0800
commit6b5e77b23d95266f88822728cef283dd7c7b4fa7 (patch)
treeb68556d5c5bdce122d69b42f473aadb8b9bf5a92 /x11
parent4edf0d2160128117bec0830994d0d60eb185b2e1 (diff)
downloadfreebsd-ports-gnome-6b5e77b23d95266f88822728cef283dd7c7b4fa7.tar.gz
freebsd-ports-gnome-6b5e77b23d95266f88822728cef283dd7c7b4fa7.tar.zst
freebsd-ports-gnome-6b5e77b23d95266f88822728cef283dd7c7b4fa7.zip
PORTSDIR should be referred after pre.mk.
This fixes make readmes infinite loop. Pointed and Tested by: Melvyn Sopacua <freebsd-ports@webteckies.org>
Diffstat (limited to 'x11')
-rw-r--r--x11/xstroke/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/x11/xstroke/Makefile b/x11/xstroke/Makefile
index 5a2365ee3010..8b6aa61edd05 100644
--- a/x11/xstroke/Makefile
+++ b/x11/xstroke/Makefile
@@ -24,7 +24,10 @@ CFLAGS+= ${PTHREAD_CFLAGS}
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-GETOPTDIR!= cd ${PORTSDIR}/devel/libgnugetopt; make -V WRKSRC
+
+.include <bsd.port.pre.mk>
+
+GETOPTDIR!= cd ${PORTSDIR}/devel/libgnugetopt; ${MAKE} -V WRKSRC
MAN1= xstroke.1
@@ -33,4 +36,4 @@ post-patch:
@${REINPLACE_CMD} -e "s,etc/,${PREFIX}/etc/,g" ${WRKSRC}/args.h
${CP} ${GETOPTDIR}/getopt* ${WRKSRC}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>