aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
committerkwm <kwm@FreeBSD.org>2013-03-08 18:51:34 +0800
commit77aa43669359356c3cab5041fdfcd537e1cabf09 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /x11
parent0fdeab2269ff13fcc43d09958d528d0ce5ec786a (diff)
downloadfreebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.gz
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.tar.zst
freebsd-ports-gnome-77aa43669359356c3cab5041fdfcd537e1cabf09.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Diffstat (limited to 'x11')
-rw-r--r--x11/avant-window-navigator/Makefile6
-rw-r--r--x11/babl/Makefile9
-rw-r--r--x11/gnome-menus/Makefile7
-rw-r--r--x11/gnome-pie/Makefile4
-rw-r--r--x11/startup-notification/Makefile8
-rw-r--r--x11/tilda/Makefile2
6 files changed, 17 insertions, 19 deletions
diff --git a/x11/avant-window-navigator/Makefile b/x11/avant-window-navigator/Makefile
index a3cb2b7003f6..a3ce575a97d8 100644
--- a/x11/avant-window-navigator/Makefile
+++ b/x11/avant-window-navigator/Makefile
@@ -69,5 +69,11 @@ post-patch:
${WRKSRC}/awn-manager/awnManager.py
@${REINPLACE_CMD} -e '1 s|bash|sh|' \
${WRKSRC}/awn-manager/awn-launcher-editor.in
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/libawn/egg/eggchecksum.h \
+ ${WRKSRC}/libawn/awn-config-client-shared.c \
+ ${WRKSRC}/libawn/awn-config-client-gconf.c
+ @${REINPLACE_CMD} -e 's|glib/gutils.h>|glib.h>|g' \
+ ${WRKSRC}/libawn/awn-config-client-gkeyfile.c
.include <bsd.port.post.mk>
diff --git a/x11/babl/Makefile b/x11/babl/Makefile
index caa2c03aaf58..a76ffe6d5516 100644
--- a/x11/babl/Makefile
+++ b/x11/babl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: babl
-# Date created: 2008-04-14
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= babl
PORTVERSION= 0.1.6
@@ -25,7 +21,8 @@ BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
USE_LDCONFIG= yes
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
-USE_GNOME= pkgconfig gnomehack ltverhack
+USE_GNOME= gnomehack ltverhack
+USE_PKGCONFIG= build
USE_GMAKE= yes
MAKE_JOBS_UNSAFE=yes
diff --git a/x11/gnome-menus/Makefile b/x11/gnome-menus/Makefile
index 421bd0f3cf53..ffbe19424391 100644
--- a/x11/gnome-menus/Makefile
+++ b/x11/gnome-menus/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: gnome-menus
-# Date created: 30 November 2004
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/x11/gnome-menus/Makefile,v 1.110 2010/11/17 11:29:19 kwm Exp $
-#
PORTNAME= gnome-menus
PORTVERSION= 2.30.5
@@ -22,6 +18,7 @@ USE_GETTEXT= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack glib20 ltverhack
+USE_PKGCONFIG= build
USE_AUTOTOOLS= libtool
USE_PYTHON= yes
USE_LDCONFIG= yes
diff --git a/x11/gnome-pie/Makefile b/x11/gnome-pie/Makefile
index 41e7a69a62dc..c93af92a348f 100644
--- a/x11/gnome-pie/Makefile
+++ b/x11/gnome-pie/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnome-pie
PORTVERSION= 0.5.2
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= x11
# Waiting for a tag on the GitHub repository https://github.com/Simmesimme/Gnome-Pie...
MASTER_SITES= LOCAL/nivit/${PORTNAME}/
@@ -18,7 +18,7 @@ RUN_DEPENDS= gnome-icons-elementary>=2.5:${PORTSDIR}/x11-themes/gnome-icons-elem
gnome-settings-daemon>=2.32.1_4:${PORTSDIR}/sysutils/gnome-settings-daemon
LIB_DEPENDS= Xtst:${PORTSDIR}/x11/libXtst \
cairo:${PORTSDIR}/graphics/cairo \
- gee:${PORTSDIR}/devel/libgee \
+ gee:${PORTSDIR}/devel/libgee06 \
unique:${PORTSDIR}/x11-toolkits/unique
INSTALLS_ICONS= yes
diff --git a/x11/startup-notification/Makefile b/x11/startup-notification/Makefile
index 168d57aae805..13054f9e35d6 100644
--- a/x11/startup-notification/Makefile
+++ b/x11/startup-notification/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: startup-notification
-# Date created: 14 November 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/x11/startup-notification/Makefile,v 1.10 2010/07/21 18:04:43 mezz Exp $
-#
PORTNAME= startup-notification
PORTVERSION= 0.12
@@ -21,7 +17,7 @@ LIB_DEPENDS= xcb-util:${PORTSDIR}/x11/xcb-util
USE_XORG= x11
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig ltasneededhack
+USE_GNOME= gnomehack ltasneededhack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/x11/tilda/Makefile b/x11/tilda/Makefile
index a7e9eb239a8d..42977c4c2b7c 100644
--- a/x11/tilda/Makefile
+++ b/x11/tilda/Makefile
@@ -25,6 +25,8 @@ DOCS= AUTHORS ChangeLog README TODO
post-patch:
@${REINPLACE_CMD} -e 's|ps -C tilda -o pid=|pgrep tilda|' \
${WRKSRC}/src/tilda.c
+ @${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
+ ${WRKSRC}/src/tomboykeybinder.h
post-install:
.if !defined (NOPORTDOCS)