aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-01-07 00:16:52 +0800
committermakc <makc@FreeBSD.org>2014-01-07 00:16:52 +0800
commit8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5 (patch)
treee9ca925ce8537078366a02e4f615c5847746c0b5 /x11
parent5b251e589961b796d7eafa23de894f129f92bf6d (diff)
downloadfreebsd-ports-gnome-8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5.tar.gz
freebsd-ports-gnome-8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5.tar.zst
freebsd-ports-gnome-8fb80a5f23ee7dd03872809dbd790ea4f90c6ff5.zip
In preparation for Qt 5 ports:
Mk/Uses/qmake.mk: - Add support for out-of-source builds - Add support for Qt 5 ports - Respect WITH_DEBUG Mk/bsd.qt.mk: - Massive rework for Qt 5 ports - Remove '-phonon' from global configure args, thus allow qt4-designer and qt4-qtconfig to be built without Phonon support [1] devel/qmake4: - Improve mkspecs for gcc (mainly sync with linux version) and clang devel/qt4-corelib: - Convert to USES=iconv - Remove ancient patch devel/qt4-designer: - Remove reference to WRKSRC from installed pkgconfig files [2] - Don't build Qt Designer plugin for Phonon from outdated Qt sources. Separate port for plugin will be committed later devel/qt4-assistant-adp, devel/qt4-libqtassistantclient: - Convert to USES=qmake Clean up Qt4 ports: - Update comments - Update description; use common description - Consistently use QT_INCDIR, QT_LIBDIR, etc. - Use options helpers - Convert to new LIB_DEPENDS syntax - Update DESKTOP_ENTRIES to avoid conflicts with Qt 5 ports - Rename/move several ports for unification with Qt 5 ports PR: ports/184620 [1] Reported by: Kevin Zheng <kevinz5000@gmail.com> PR: ports/181141 [2] Reported by: thierry PR: ports/185101 Exp-run by: bdrewery This is mostly solely avilla's work in area51, kudos to him! And a couple commits from myself, so you know who's collecting pointyhats :)
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/qt4-graphicssystems-opengl/Makefile9
-rw-r--r--x11/qt4-graphicssystems-opengl/pkg-descr13
-rw-r--r--x11/qt4-inputmethods/Makefile11
-rw-r--r--x11/qt4-inputmethods/pkg-descr12
-rw-r--r--x11/qt4-opengl/Makefile58
-rw-r--r--x11/qt4-opengl/pkg-descr12
-rw-r--r--x11/qt4-opengl/pkg-plist48
8 files changed, 13 insertions, 151 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 802f034b0e94..d34ada3d8423 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -242,7 +242,6 @@
SUBDIR += qimageblitz
SUBDIR += qt4-graphicssystems-opengl
SUBDIR += qt4-inputmethods
- SUBDIR += qt4-opengl
SUBDIR += qxkb
SUBDIR += randrproto
SUBDIR += recordproto
diff --git a/x11/qt4-graphicssystems-opengl/Makefile b/x11/qt4-graphicssystems-opengl/Makefile
index 7398c1e8937b..1336317dac85 100644
--- a/x11/qt4-graphicssystems-opengl/Makefile
+++ b/x11/qt4-graphicssystems-opengl/Makefile
@@ -2,15 +2,14 @@
PORTNAME= graphicssystems
DISTVERSION= ${QT4_VERSION}
-CATEGORIES?= x11
+CATEGORIES= x11
PKGNAMEPREFIX= qt4-
PKGNAMESUFFIX= -opengl
MAINTAINER= kde@FreeBSD.org
-COMMENT= OpenGL rendering engine (experimental)
+COMMENT= Qt OpenGL rendering engine (experimental)
USE_QT4= qmake_build opengl
-QT_NONSTANDARD= yes
QT_DIST= yes
HAS_CONFIGURE= yes
@@ -36,10 +35,8 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
BUILD_WRKSRC= ${WRKSRC}/src/plugins/${PORTNAME}/opengl
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
-
pre-configure:
${MKDIR} ${WRKSRC}/mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+ ${LN} -sf ${QMAKE} ${WRKSRC}/bin/qmake
.include <bsd.port.mk>
diff --git a/x11/qt4-graphicssystems-opengl/pkg-descr b/x11/qt4-graphicssystems-opengl/pkg-descr
index a319375a7bb9..d67bb18e304d 100644
--- a/x11/qt4-graphicssystems-opengl/pkg-descr
+++ b/x11/qt4-graphicssystems-opengl/pkg-descr
@@ -1,11 +1,10 @@
-Qt provides a platform-independent API to all central platform
-functionality: GUI, database access, networking, file handling,
-etc.
+Qt is a cross-platform application and UI framework for developers
+using C++ or QML, a CSS/JavaScript-like language.
-This port provides OpenGL graphics backend, which is used for
+This port provides the OpenGL graphics backend, which is used for
on-screen widgets and QPixmaps. See for details:
-http://doc.qt.nokia.com/4.7/qapplication.html#setGraphicsSystem
-http://labs.qt.nokia.com/2008/10/22/so-long-and-thanks-for-the-blit/
+http://qt-project.org/doc/qt-4.8/qapplication.html#setGraphicsSystem
+http://blog.qt.digia.com/blog/2008/10/22/so-long-and-thanks-for-the-blit
-WWW: http://qt.nokia.com/products/qt/index.html
+WWW: http://qt-project.org
diff --git a/x11/qt4-inputmethods/Makefile b/x11/qt4-inputmethods/Makefile
index 29559b27beda..332a59eef8fe 100644
--- a/x11/qt4-inputmethods/Makefile
+++ b/x11/qt4-inputmethods/Makefile
@@ -3,14 +3,13 @@
PORTNAME= inputmethods
DISTVERSION= ${QT4_VERSION}
-CATEGORIES?= x11
+CATEGORIES= x11
PKGNAMEPREFIX= qt4-
MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt input method plugins
+COMMENT= Qt input methods
USE_QT4= qmake_build moc_build corelib gui
-QT_NONSTANDARD= yes
QT_DIST= yes
HAS_CONFIGURE= yes
@@ -35,11 +34,9 @@ EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
BUILD_WRKSRC= ${WRKSRC}/src/plugins/${PORTNAME}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
-EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
-
pre-configure:
${MKDIR} ${WRKSRC}/mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
+ ${LN} -sf ${QMAKE} ${WRKSRC}/bin/qmake
+ ${LN} -sf ${MOC} ${WRKSRC}/bin/moc
.include <bsd.port.mk>
diff --git a/x11/qt4-inputmethods/pkg-descr b/x11/qt4-inputmethods/pkg-descr
deleted file mode 100644
index 36bc69717e98..000000000000
--- a/x11/qt4-inputmethods/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-Qt is a C++ toolkit for application development. It lets application
-developers target all major operating systems with a single application
-source code.
-
-Qt provides a platform-independent API to all central platform functionality:
-GUI, database access, networking, file handling, etc. The Qt library
-encapsulates the different APIs of different operating systems, providing
-the application programmer with a single, common API for all operating systems.
-The native C APIs are encapsulated in a set of well-designed, fully
-object-oriented C++ classes.
-
-WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
deleted file mode 100644
index 788da18f3416..000000000000
--- a/x11/qt4-opengl/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# Created by: lofi@FreeBSD.org
-# $FreeBSD$
-
-PORTNAME= opengl
-DISTVERSION= ${QT4_VERSION}
-CATEGORIES?= x11
-PKGNAMEPREFIX= qt4-
-
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Qt OpenGL library
-
-USE_QT4= qmake_build moc_build corelib gui
-QT_NONSTANDARD= yes
-QT_DIST= yes
-
-HAS_CONFIGURE= yes
-USE_LDCONFIG= ${PREFIX}/lib/qt4
-USE_GL= gl
-USE_XORG= x11
-
-ALL_TARGET= first
-CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
-MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
- PATH=${WRKSRC}/bin:$$PATH
-
-DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \
- src/activeqt src/dbus src/multimedia src/network src/openvg \
- src/phonon src/qt3support src/s60installs src/s60main \
- src/script src/scripttools src/sql src/svg src/testlib \
- src/tools src/winmain src/xml src/xmlpatterns \
- src/3rdparty/clucene src/3rdparty/freetype \
- src/3rdparty/libjpeg src/3rdparty/libmng src/3rdparty/libpng \
- src/3rdparty/libtiff src/3rdparty/phonon src/3rdparty/webkit
-.for dne in ${DO_NOT_EXTRACT}
-EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
-.endfor
-
-BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
-INSTALL_WRKSRC= ${BUILD_WRKSRC}
-
-CONFIGURE_ARGS+= -I../../include/QtCore -I../../include/QtGui \
- -I../../include/Qt -I../../include
-
-EXTRA_PATCHES+= ${.CURDIR}/../../devel/qt4/files/patch-configure
-
-pre-configure:
- ${MKDIR} ${WRKSRC}/mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
-
-post-configure:
- ${REINPLACE_CMD} -e 's|${PREFIX}/lib/qt4/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- -e 's|.*$$(QMAKE).*||g' ${BUILD_WRKSRC}/Makefile
- ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
- -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
- ${WRKSRC}/lib/pkgconfig/QtOpenGL.pc
-
-.include <bsd.port.mk>
diff --git a/x11/qt4-opengl/pkg-descr b/x11/qt4-opengl/pkg-descr
deleted file mode 100644
index 36bc69717e98..000000000000
--- a/x11/qt4-opengl/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-Qt is a C++ toolkit for application development. It lets application
-developers target all major operating systems with a single application
-source code.
-
-Qt provides a platform-independent API to all central platform functionality:
-GUI, database access, networking, file handling, etc. The Qt library
-encapsulates the different APIs of different operating systems, providing
-the application programmer with a single, common API for all operating systems.
-The native C APIs are encapsulated in a set of well-designed, fully
-object-oriented C++ classes.
-
-WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/x11/qt4-opengl/pkg-plist b/x11/qt4-opengl/pkg-plist
deleted file mode 100644
index 7b9ad0d35b90..000000000000
--- a/x11/qt4-opengl/pkg-plist
+++ /dev/null
@@ -1,48 +0,0 @@
-include/qt4/Qt/QtOpenGL
-include/qt4/Qt/qgl.h
-include/qt4/Qt/qglbuffer.h
-include/qt4/Qt/qglcolormap.h
-include/qt4/Qt/qglframebufferobject.h
-include/qt4/Qt/qglfunctions.h
-include/qt4/Qt/qglpixelbuffer.h
-include/qt4/Qt/qglscreen_qws.h
-include/qt4/Qt/qglshaderprogram.h
-include/qt4/QtOpenGL/QGLBuffer
-include/qt4/QtOpenGL/QGLColormap
-include/qt4/QtOpenGL/QGLContext
-include/qt4/QtOpenGL/QGLFormat
-include/qt4/QtOpenGL/QGLFramebufferObject
-include/qt4/QtOpenGL/QGLFramebufferObjectFormat
-include/qt4/QtOpenGL/QGLFunctions
-include/qt4/QtOpenGL/QGLFunctionsPrivate
-include/qt4/QtOpenGL/QGLPixelBuffer
-include/qt4/QtOpenGL/QGLScreen
-include/qt4/QtOpenGL/QGLScreenSurfaceFunctions
-include/qt4/QtOpenGL/QGLShader
-include/qt4/QtOpenGL/QGLShaderProgram
-include/qt4/QtOpenGL/QGLWidget
-include/qt4/QtOpenGL/QMacCompatGLenum
-include/qt4/QtOpenGL/QMacCompatGLint
-include/qt4/QtOpenGL/QMacCompatGLuint
-include/qt4/QtOpenGL/QMacGLCompatTypes
-include/qt4/QtOpenGL/QtOpenGL
-include/qt4/QtOpenGL/qgl.h
-include/qt4/QtOpenGL/qglbuffer.h
-include/qt4/QtOpenGL/qglcolormap.h
-include/qt4/QtOpenGL/qglframebufferobject.h
-include/qt4/QtOpenGL/qglfunctions.h
-include/qt4/QtOpenGL/qglpixelbuffer.h
-include/qt4/QtOpenGL/qglscreen_qws.h
-include/qt4/QtOpenGL/qglshaderprogram.h
-lib/qt4/libQtOpenGL.la
-lib/qt4/libQtOpenGL.prl
-lib/qt4/libQtOpenGL.so
-lib/qt4/libQtOpenGL.so.4
-lib/qt4/libQtOpenGL.so.%%SHLIB_SHVER%%
-lib/qt4/libQtOpenGL.so.%%SHLIB_VER%%
-%%DEBUG%%lib/qt4/libQtOpenGL.so.%%SHLIB_VER%%.debug
-libdata/pkgconfig/QtOpenGL.pc
-@dirrmtry lib/qt4
-@dirrm include/qt4/QtOpenGL
-@dirrmtry include/qt4/Qt
-@dirrmtry include/qt4