aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2004-06-23 23:34:52 +0800
committermich <mich@FreeBSD.org>2004-06-23 23:34:52 +0800
commitbe3d11554968eeda04c3751c6d2109207592539d (patch)
tree7a5257cb7feb253e617eecfb13d06e0865333742 /x11
parentc5b54d3256b5a05af24a6fb0993ffd1224df04b0 (diff)
downloadfreebsd-ports-gnome-be3d11554968eeda04c3751c6d2109207592539d.tar.gz
freebsd-ports-gnome-be3d11554968eeda04c3751c6d2109207592539d.tar.zst
freebsd-ports-gnome-be3d11554968eeda04c3751c6d2109207592539d.zip
- Add two knobs:
- WITHOUT_JPEG - WITHOUT_PNG - Tell configure where to look for libs Submitted by: Grigori Goronzy <greg@chown.ath.cx>
Diffstat (limited to 'x11')
-rw-r--r--x11/aterm/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/x11/aterm/Makefile b/x11/aterm/Makefile
index 4508506d41a6..f1dbc27c05a2 100644
--- a/x11/aterm/Makefile
+++ b/x11/aterm/Makefile
@@ -14,9 +14,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mich@FreeBSD.org
COMMENT= A color vt102 terminal emulator with transparency support
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png
-
USE_X_PREFIX= yes
USE_XPM= yes
GNU_CONFIGURE= yes
@@ -25,6 +22,22 @@ CONFIGURE_ARGS+= \
--enable-transparency --enable-background-image \
--enable-fading --enable-utmp --enable-wtmp
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITHOUT_PNG)
+CONFIGURE_ARGS+= --with-png
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+.else
+CONFIGURE_ARGS+= --with-png=no
+.endif
+
+.if !defined(WITHOUT_JPEG)
+CONFIGURE_ARGS+= --with-jpeg
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+.else
+CONFIGURE_ARGS+= --with-jpeg=no
+.endif
+
.if !defined(WITH_BSDEL)
CONFIGURE_ARGS+= --disable-backspace-key --disable-delete-key
.endif