aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2011-08-04 04:21:04 +0800
committercy <cy@FreeBSD.org>2011-08-04 04:21:04 +0800
commitcdaa1fb9e19d2399e2ef70843e0576578b0cbf60 (patch)
tree49c6fec0ab88dd00af4b78b8f565d0eefa652abc /x11
parentecdf4a0300202fbef2cfa1ff8fe845411f3fac5b (diff)
downloadfreebsd-ports-gnome-cdaa1fb9e19d2399e2ef70843e0576578b0cbf60.tar.gz
freebsd-ports-gnome-cdaa1fb9e19d2399e2ef70843e0576578b0cbf60.tar.zst
freebsd-ports-gnome-cdaa1fb9e19d2399e2ef70843e0576578b0cbf60.zip
Gcursor is unmaintained by upline (Ubuntu).
Diffstat (limited to 'x11')
-rw-r--r--x11/gcursor/Makefile39
-rw-r--r--x11/gcursor/distinfo2
-rw-r--r--x11/gcursor/files/patch-data::gcursor.desktop.in18
-rw-r--r--x11/gcursor/files/patch-src::gcursor.c59
-rw-r--r--x11/gcursor/pkg-descr5
-rw-r--r--x11/gcursor/pkg-plist14
6 files changed, 0 insertions, 137 deletions
diff --git a/x11/gcursor/Makefile b/x11/gcursor/Makefile
deleted file mode 100644
index a01a2a1eb5f0..000000000000
--- a/x11/gcursor/Makefile
+++ /dev/null
@@ -1,39 +0,0 @@
-# New ports collection makefile for: gcursor
-# Date created: 08 March 2004
-# Whom: Mezz <mezz7@cox.net>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gcursor
-PORTVERSION= 0.061
-PORTREVISION= 12
-CATEGORIES= x11 gnome
-MASTER_SITES= http://www.sourcefiles.org/Toys/Candy/
-
-MAINTAINER= cy@FreeBSD.org
-COMMENT= A mouse cursor theme selector for GNOME
-
-RUN_DEPENDS= file-roller:${PORTSDIR}/archivers/file-roller
-
-USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui
-USE_GETTEXT= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-DOCS= AUTHORS COPYING ChangeLog INSTALL TODO
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/src/gcursor.c
-
-.ifndef (NOPORTDOCS)
-post-install:
- @${MKDIR} ${DOCSDIR}
-.for i in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.mk>
diff --git a/x11/gcursor/distinfo b/x11/gcursor/distinfo
deleted file mode 100644
index 4c9eebd89e85..000000000000
--- a/x11/gcursor/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (gcursor-0.061.tar.gz) = c4f71ac3ea3c4e18906aa5a8b6c60116e19863ca6404bbfe10d78abb319b5aae
-SIZE (gcursor-0.061.tar.gz) = 143719
diff --git a/x11/gcursor/files/patch-data::gcursor.desktop.in b/x11/gcursor/files/patch-data::gcursor.desktop.in
deleted file mode 100644
index 952a2cc2bf68..000000000000
--- a/x11/gcursor/files/patch-data::gcursor.desktop.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- data/gcursor.desktop.in.orig Sun Feb 20 21:34:50 2005
-+++ data/gcursor.desktop.in Sun Feb 20 21:36:12 2005
-@@ -1,12 +1,11 @@
- [Desktop Entry]
-+Encoding=UTF-8
- _Name=Cursor Selection
- _Comment=Select a different cursor
- Exec=gcursor
- Icon=
- Terminal=false
- Type=Application
--
--Categories=GNOME;Application;Settings;
- StartupNotify=true
--Encoding=UTF-8
--
-+Categories=Application;Settings;AdvancedSettings;
-+OnlyShowIn=GNOME;
diff --git a/x11/gcursor/files/patch-src::gcursor.c b/x11/gcursor/files/patch-src::gcursor.c
deleted file mode 100644
index 5161e1e3b34a..000000000000
--- a/x11/gcursor/files/patch-src::gcursor.c
+++ /dev/null
@@ -1,59 +0,0 @@
---- src/gcursor.c.orig Thu Aug 26 05:35:55 2004
-+++ src/gcursor.c Thu Jul 27 13:25:46 2006
-@@ -32,29 +32,22 @@
-
- #warning move this into gconf
- char *paths[] = {
-- "/usr/share/cursors/xfree/",
-- "/usr/X11R6/lib/X11/icons/",
-- "/usr/Xorg/lib/X11/icons/",
-- "/usr/local/share/icons/",
-- "/usr/share/icons/",
-+ "%%LOCALBASE%%/lib/X11/icons/",
-+ "%%LOCALBASE%%/lib/X11/icons/",
- "%s/.icons/",
- NULL
- };
-
- void open_theme_dir()
- {
-- GError * error = NULL;
-- char * filename;
--
-- filename = g_strdup_printf("file:///%s/.icons/", g_getenv("HOME"));
-- gnome_url_show(filename,&error);
-- g_free(filename);
-+ gchar *path, *command;
-
-- if (error)
-- {
-- gnome_warning_dialog (error->message);
-- g_error_free (error);
-- }
-+ path = g_strdup_printf ("%s/.icons", g_get_home_dir());
-+ command = g_strdup_printf ("nautilus --no-desktop %s", path);
-+
-+ g_free (path);
-+ g_spawn_command_line_async (command, NULL);
-+ g_free (command);
- }
-
-
-@@ -85,7 +78,7 @@
- filename = g_shell_quote(gtk_file_selection_get_filename(GTK_FILE_SELECTION(fs)));
- #endif
-
-- path = g_strdup_printf("file-roller --extract-to=%s/.icons/ %s", g_getenv("HOME"),
-+ path = g_strdup_printf("file-roller --extract-to=%s/.icons/ %s", g_get_home_dir(),
- filename);
- g_free(filename);
-
-@@ -281,7 +274,7 @@
-
- for (iterator = paths; *iterator; iterator++)
- {
-- dirname = g_strdup_printf(*iterator, g_getenv("HOME"));
-+ dirname = g_strdup_printf(*iterator, g_get_home_dir());
- directory = g_dir_open(dirname, 0, NULL);
-
- while(directory != NULL && (name = g_dir_read_name(directory)) != NULL)
diff --git a/x11/gcursor/pkg-descr b/x11/gcursor/pkg-descr
deleted file mode 100644
index 99a2aa152288..000000000000
--- a/x11/gcursor/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-GCursor is a gtk+-2 xcursor selector. It tries to have the same look and feel
-as the theme-selector in the gnome-control-center. Gcursor is a temporary
-solution until a decent selector is included in the gnome-control-center.
-
-WWW: http://qballcow.nl/?s=17
diff --git a/x11/gcursor/pkg-plist b/x11/gcursor/pkg-plist
deleted file mode 100644
index a884872f6e09..000000000000
--- a/x11/gcursor/pkg-plist
+++ /dev/null
@@ -1,14 +0,0 @@
-bin/gcursor
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/INSTALL
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-share/applications/gcursor.desktop
-share/gcursor/gcursor.glade
-share/locale/de/LC_MESSAGES/gcursor.mo
-share/locale/es/LC_MESSAGES/gcursor.mo
-share/locale/sv/LC_MESSAGES/gcursor.mo
-@dirrm share/gcursor
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrmtry share/applications