aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-09-10 02:54:28 +0800
committerantoine <antoine@FreeBSD.org>2013-09-10 02:54:28 +0800
commitf3571dba2484c54162cc61b8abc288c7ec6cca14 (patch)
tree3b969fb0c53d4fb2ae1cc9be5ebaeeab1ed7e2c9 /x11
parent9a21d679f211da2dc3d0c87aa6ee0ed8174b876b (diff)
downloadfreebsd-ports-gnome-f3571dba2484c54162cc61b8abc288c7ec6cca14.tar.gz
freebsd-ports-gnome-f3571dba2484c54162cc61b8abc288c7ec6cca14.tar.zst
freebsd-ports-gnome-f3571dba2484c54162cc61b8abc288c7ec6cca14.zip
Add an explicit dependency on pkgconf
Approved by: portmgr (bapt)
Diffstat (limited to 'x11')
-rw-r--r--x11/bbrun/Makefile8
-rw-r--r--x11/bmpanel2/Makefile2
-rw-r--r--x11/docker/Makefile8
-rw-r--r--x11/eaglemode/Makefile3
-rw-r--r--x11/gdkxft/Makefile2
5 files changed, 8 insertions, 15 deletions
diff --git a/x11/bbrun/Makefile b/x11/bbrun/Makefile
index 09cf7dfa11e7..d3554a8acc9b 100644
--- a/x11/bbrun/Makefile
+++ b/x11/bbrun/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bbrun
-# Date created: 3 August 2001
-# Whom: Adam Weinberger <adam@vectors.cx>
-#
+# Created by: Adam Weinberger <adam@vectors.cx>
# $FreeBSD$
-#
PORTNAME= bbrun
PORTVERSION= 1.6
@@ -18,7 +14,7 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/bbrun
USE_XORG= xpm
USE_GNOME= gtk20
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_CSTD= gnu89
PORTDOCS= README
diff --git a/x11/bmpanel2/Makefile b/x11/bmpanel2/Makefile
index d9b346ebd319..efd3e6c9aca5 100644
--- a/x11/bmpanel2/Makefile
+++ b/x11/bmpanel2/Makefile
@@ -11,7 +11,7 @@ COMMENT= Nice, lightweight NETWM compliant panel for X11
LICENSE= MIT
-USES= cmake
+USES= cmake pkgconfig
USE_GNOME= pango
USE_XORG= x11 xext
diff --git a/x11/docker/Makefile b/x11/docker/Makefile
index 12fd8b9fc373..093125b1a3a7 100644
--- a/x11/docker/Makefile
+++ b/x11/docker/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: docker
-# Date created: March 15, 2003
-# Whom: Samy Al Bahra <samy@kerneled.org>
-#
+# Created by: Samy Al Bahra <samy@kerneled.org>
# $FreeBSD$
-#
PORTNAME= docker
PORTVERSION= 1.5
@@ -20,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_XORG= x11
USE_GNOME= glib20
-USE_GMAKE= yes
+USES= gmake pkgconfig
PLIST_FILES= bin/docker
diff --git a/x11/eaglemode/Makefile b/x11/eaglemode/Makefile
index 198e476f9e60..0df7f6e6fac3 100644
--- a/x11/eaglemode/Makefile
+++ b/x11/eaglemode/Makefile
@@ -14,8 +14,9 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
tiff:${PORTSDIR}/graphics/tiff \
freetype:${PORTSDIR}/print/freetype2
+USES= perl5 pkgconfig
USE_BZIP2= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_XORG= x11 xext xxf86vm
SUB_FILES= eaglemode.sh
diff --git a/x11/gdkxft/Makefile b/x11/gdkxft/Makefile
index 11cb467178a6..8586e41a2c87 100644
--- a/x11/gdkxft/Makefile
+++ b/x11/gdkxft/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
USE_AUTOTOOLS= libtool
USE_GNOME= gtk12
-USES= iconv
+USES= iconv pkgconfig
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib -lgnuregex ${ICONV_LIB}
CFLAGS+= `pkg-config xft --cflags`