aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-08-29 07:23:59 +0800
committerwill <will@FreeBSD.org>2001-08-29 07:23:59 +0800
commit23810892eee63076d2b404f3db3c77437fc56303 (patch)
tree1535dd334fd9b563d71155fa1700419579f7e2a8 /x11
parent64c507c422ddc989a1cfeadb7de4efb98038531c (diff)
downloadfreebsd-ports-gnome-23810892eee63076d2b404f3db3c77437fc56303.tar.gz
freebsd-ports-gnome-23810892eee63076d2b404f3db3c77437fc56303.tar.zst
freebsd-ports-gnome-23810892eee63076d2b404f3db3c77437fc56303.zip
Fix problem where kdelibs.sh isn't chmod 755.. this causes some filters
and other stuff to fail. *sigh*
Diffstat (limited to 'x11')
-rw-r--r--x11/kdelibs2/Makefile1
-rw-r--r--x11/kdelibs3/Makefile1
-rw-r--r--x11/kdelibs4/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/x11/kdelibs2/Makefile b/x11/kdelibs2/Makefile
index 86c4ea87ecc6..eb7c6bcfcda2 100644
--- a/x11/kdelibs2/Makefile
+++ b/x11/kdelibs2/Makefile
@@ -79,6 +79,7 @@ post-configure:
post-install:
${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${FILESDIR}/kdelibs.sh > ${PREFIX}/etc/rc.d/kdelibs.sh
+ ${CHMOD} 755 ${PREFIX}/etc/rc.d/kdelibs.sh
.for LIB in DCOP kab kdecore kdesu kdeui kfile kformula kio kjs \
kparts kspell ksycoca kjava
@${LN} -sf ${PREFIX}/lib/lib${LIB}.so.${SOMAJOR} ${PREFIX}/lib/lib${LIB}.so
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index 86c4ea87ecc6..eb7c6bcfcda2 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -79,6 +79,7 @@ post-configure:
post-install:
${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${FILESDIR}/kdelibs.sh > ${PREFIX}/etc/rc.d/kdelibs.sh
+ ${CHMOD} 755 ${PREFIX}/etc/rc.d/kdelibs.sh
.for LIB in DCOP kab kdecore kdesu kdeui kfile kformula kio kjs \
kparts kspell ksycoca kjava
@${LN} -sf ${PREFIX}/lib/lib${LIB}.so.${SOMAJOR} ${PREFIX}/lib/lib${LIB}.so
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 86c4ea87ecc6..eb7c6bcfcda2 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -79,6 +79,7 @@ post-configure:
post-install:
${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${FILESDIR}/kdelibs.sh > ${PREFIX}/etc/rc.d/kdelibs.sh
+ ${CHMOD} 755 ${PREFIX}/etc/rc.d/kdelibs.sh
.for LIB in DCOP kab kdecore kdesu kdeui kfile kformula kio kjs \
kparts kspell ksycoca kjava
@${LN} -sf ${PREFIX}/lib/lib${LIB}.so.${SOMAJOR} ${PREFIX}/lib/lib${LIB}.so