aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
committerobrien <obrien@FreeBSD.org>2005-04-11 16:04:41 +0800
commit6b02d1b35c173832c085697cf76aa156d04ad843 (patch)
tree195cb55f1eda849521409154920849cf102b91fa /x11
parent93ea51bfc3219265c52c39374430d10201b8f436 (diff)
downloadfreebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.gz
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.tar.zst
freebsd-ports-gnome-6b02d1b35c173832c085697cf76aa156d04ad843.zip
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
Diffstat (limited to 'x11')
-rw-r--r--x11/3ddesktop/Makefile2
-rw-r--r--x11/XFree86-4-libraries/Makefile2
-rw-r--r--x11/XFree86/Makefile2
-rw-r--r--x11/compositeext/Makefile2
-rw-r--r--x11/damageext/Makefile2
-rw-r--r--x11/fixesext/Makefile2
-rw-r--r--x11/kdelibs3/Makefile2
-rw-r--r--x11/kdelibs4/Makefile2
-rw-r--r--x11/libSM/Makefile2
-rw-r--r--x11/libX11/Makefile2
-rw-r--r--x11/libXau/Makefile2
-rw-r--r--x11/libXcomposite/Makefile2
-rw-r--r--x11/libXcursor/Makefile2
-rw-r--r--x11/libXdamage/Makefile2
-rw-r--r--x11/libXdmcp/Makefile2
-rw-r--r--x11/libXext/Makefile2
-rw-r--r--x11/libXfixes/Makefile2
-rw-r--r--x11/libXfont/Makefile2
-rw-r--r--x11/libXi/Makefile2
-rw-r--r--x11/libXinerama/Makefile2
-rw-r--r--x11/libXpm/Makefile2
-rw-r--r--x11/libXrandr/Makefile2
-rw-r--r--x11/libXrender/Makefile2
-rw-r--r--x11/libXres/Makefile2
-rw-r--r--x11/libXtrans/Makefile2
-rw-r--r--x11/libXv/Makefile2
-rw-r--r--x11/linux-gnomelibs/Makefile6
-rw-r--r--x11/multi-aterm/Makefile2
-rw-r--r--x11/panoramixext/Makefile2
-rw-r--r--x11/randrext/Makefile2
-rw-r--r--x11/renderext/Makefile2
-rw-r--r--x11/resourceext/Makefile2
-rw-r--r--x11/rxvt-unicode/Makefile2
-rw-r--r--x11/wdm/Makefile2
-rw-r--r--x11/xautomation/Makefile2
-rw-r--r--x11/xextensions/Makefile2
-rw-r--r--x11/xlockmore/Makefile2
-rw-r--r--x11/xnee/Makefile2
-rw-r--r--x11/xproto/Makefile2
-rw-r--r--x11/xterm/Makefile2
-rw-r--r--x11/xtermcontrol/Makefile2
-rw-r--r--x11/xvattr/Makefile2
42 files changed, 44 insertions, 44 deletions
diff --git a/x11/3ddesktop/Makefile b/x11/3ddesktop/Makefile
index 1eedc75b7578..4af8efec8da9 100644
--- a/x11/3ddesktop/Makefile
+++ b/x11/3ddesktop/Makefile
@@ -23,7 +23,7 @@ USE_GL= yes
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PORTDOCS= README README.windowmanagers
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
index 5af3dc5b1890..8420bd03bddc 100644
--- a/x11/XFree86-4-libraries/Makefile
+++ b/x11/XFree86-4-libraries/Makefile
@@ -119,7 +119,7 @@ PLIST_SUB+= OSMESA:=""
.endif
# sparc64 doesn't have a working libc_r yet, and -current doesn't need libXThrStub.
-.if ${MACHINE_ARCH} == "sparc64" || ${OSVERSION} >= 500043
+.if ${ARCH} == "sparc64" || ${OSVERSION} >= 500043
PLIST_SUB+= XTHRSTUB:="@comment "
.else
PLIST_SUB+= XTHRSTUB:=""
diff --git a/x11/XFree86/Makefile b/x11/XFree86/Makefile
index 6aff6a52f82f..2f50616efd0d 100644
--- a/x11/XFree86/Makefile
+++ b/x11/XFree86/Makefile
@@ -33,7 +33,7 @@ INSTALL_TARGET+= install.linkkit
.endif
DIST_SUBDIR= xc
SCRIPTS_ENV= OSVERSION=${OSVERSION} MACHINE=${MACHINE} \
- MACHINE_ARCH=${MACHINE_ARCH}
+ ARCH=${ARCH}
MAKE_ARGS= WORLDOPTS=
# can't use USE_X_PREFIX here -- it will cause a circular dependency
PREFIX= ${X11BASE}
diff --git a/x11/compositeext/Makefile b/x11/compositeext/Makefile
index 326b32b1af80..5e8563e51098 100644
--- a/x11/compositeext/Makefile
+++ b/x11/compositeext/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${LIB_PC_DEPENDS}
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
NO_BUILD= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/damageext/Makefile b/x11/damageext/Makefile
index 702b4cc237e6..a61ffc029639 100644
--- a/x11/damageext/Makefile
+++ b/x11/damageext/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${LIB_PC_DEPENDS}
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
NO_BUILD= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/fixesext/Makefile b/x11/fixesext/Makefile
index bed51efc8ba6..15f7ea4f5bbc 100644
--- a/x11/fixesext/Makefile
+++ b/x11/fixesext/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${LIB_PC_DEPENDS}
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
NO_BUILD= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index bb24110f77c1..d551133642df 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -59,7 +59,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET=# empty
CONFIGURE_ARGS+=--disable-ltdl-install \
--enable-mt \
- --build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
+ --build=${ARCH}-portbld-freebsd${OSREL} \
--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
CONFIGURE_ENV+= libltdl_cv_shlibext=".so"
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index bb24110f77c1..d551133642df 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -59,7 +59,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET=# empty
CONFIGURE_ARGS+=--disable-ltdl-install \
--enable-mt \
- --build=${MACHINE_ARCH}-portbld-freebsd${OSREL} \
+ --build=${ARCH}-portbld-freebsd${OSREL} \
--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
CONFIGURE_ENV+= libltdl_cv_shlibext=".so"
diff --git a/x11/libSM/Makefile b/x11/libSM/Makefile
index 50fbc75f42a4..7073a1a25e88 100644
--- a/x11/libSM/Makefile
+++ b/x11/libSM/Makefile
@@ -23,7 +23,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
diff --git a/x11/libX11/Makefile b/x11/libX11/Makefile
index e1bf1841430a..cfb14e2c30df 100644
--- a/x11/libX11/Makefile
+++ b/x11/libX11/Makefile
@@ -26,7 +26,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
CONFIGURE_ARGS+= --enable-xdmauth
CFLAGS+= -DMALLOC_0_RETURNS_NULL
diff --git a/x11/libXau/Makefile b/x11/libXau/Makefile
index 7960cd3bfcfa..8dcfca267fc2 100644
--- a/x11/libXau/Makefile
+++ b/x11/libXau/Makefile
@@ -21,7 +21,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_LIBTOOL_VER=13
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libXcomposite/Makefile b/x11/libXcomposite/Makefile
index 3ee1261ccdef..63531e0c4c5f 100644
--- a/x11/libXcomposite/Makefile
+++ b/x11/libXcomposite/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${LIB_PC_DEPENDS}
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_LIBTOOL_VER=13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
diff --git a/x11/libXcursor/Makefile b/x11/libXcursor/Makefile
index 2409ff398345..66de74cb48bf 100644
--- a/x11/libXcursor/Makefile
+++ b/x11/libXcursor/Makefile
@@ -27,7 +27,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_LIBTOOL_VER=13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
diff --git a/x11/libXdamage/Makefile b/x11/libXdamage/Makefile
index 1aa2c98d9fce..3e0ada2afd7f 100644
--- a/x11/libXdamage/Makefile
+++ b/x11/libXdamage/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${LIB_PC_DEPENDS}
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_LIBTOOL_VER=13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
diff --git a/x11/libXdmcp/Makefile b/x11/libXdmcp/Makefile
index 613cac4b4866..de2a863403ad 100644
--- a/x11/libXdmcp/Makefile
+++ b/x11/libXdmcp/Makefile
@@ -27,7 +27,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/libXext/Makefile b/x11/libXext/Makefile
index ca4a84836707..3c7644df680f 100644
--- a/x11/libXext/Makefile
+++ b/x11/libXext/Makefile
@@ -23,7 +23,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_INC_LIBTOOL_VER=13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
diff --git a/x11/libXfixes/Makefile b/x11/libXfixes/Makefile
index 834e5f96ef2b..7aacbc49d16f 100644
--- a/x11/libXfixes/Makefile
+++ b/x11/libXfixes/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${LIB_PC_DEPENDS}
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_LIBTOOL_VER=13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
diff --git a/x11/libXfont/Makefile b/x11/libXfont/Makefile
index f539d17cf1d9..0bc178f03c9f 100644
--- a/x11/libXfont/Makefile
+++ b/x11/libXfont/Makefile
@@ -22,7 +22,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
CONFIGURE_ARGS= --enable-freetype
INSTALLS_SHLIB= yes
diff --git a/x11/libXi/Makefile b/x11/libXi/Makefile
index 643c11ec21ab..b5945eb4538e 100644
--- a/x11/libXi/Makefile
+++ b/x11/libXi/Makefile
@@ -25,7 +25,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_LIBTOOL_VER=13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
diff --git a/x11/libXinerama/Makefile b/x11/libXinerama/Makefile
index b3a1d500e2f7..47106d6cec89 100644
--- a/x11/libXinerama/Makefile
+++ b/x11/libXinerama/Makefile
@@ -23,7 +23,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
diff --git a/x11/libXpm/Makefile b/x11/libXpm/Makefile
index 258d25dcd4a4..6ff9206ba590 100644
--- a/x11/libXpm/Makefile
+++ b/x11/libXpm/Makefile
@@ -25,7 +25,7 @@ USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_INC_LIBTOOL_VER=13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
diff --git a/x11/libXrandr/Makefile b/x11/libXrandr/Makefile
index 0b50160596e0..6e810f3bd4aa 100644
--- a/x11/libXrandr/Makefile
+++ b/x11/libXrandr/Makefile
@@ -27,7 +27,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
diff --git a/x11/libXrender/Makefile b/x11/libXrender/Makefile
index 3e7e282ad082..8b7aec47c8d8 100644
--- a/x11/libXrender/Makefile
+++ b/x11/libXrender/Makefile
@@ -26,7 +26,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_INC_LIBTOOL_VER=13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
diff --git a/x11/libXres/Makefile b/x11/libXres/Makefile
index 469d86022389..5e2364cfc931 100644
--- a/x11/libXres/Makefile
+++ b/x11/libXres/Makefile
@@ -28,7 +28,7 @@ USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_LIBTOOL_VER=13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
INSTALLS_SHLIB= yes
diff --git a/x11/libXtrans/Makefile b/x11/libXtrans/Makefile
index aaf12abdf215..6d264b26783f 100644
--- a/x11/libXtrans/Makefile
+++ b/x11/libXtrans/Makefile
@@ -17,7 +17,7 @@ COMMENT= Network API translation layer for X applications and libraries
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_GNOME= gnomehack
diff --git a/x11/libXv/Makefile b/x11/libXv/Makefile
index 8faacf984e29..ce87a4552b44 100644
--- a/x11/libXv/Makefile
+++ b/x11/libXv/Makefile
@@ -22,7 +22,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_LIBTOOL_VER=13
CFLAGS+= -DMALLOC_0_RETURNS_NULL
diff --git a/x11/linux-gnomelibs/Makefile b/x11/linux-gnomelibs/Makefile
index 2abe16032092..55a2f1bd3bcb 100644
--- a/x11/linux-gnomelibs/Makefile
+++ b/x11/linux-gnomelibs/Makefile
@@ -13,12 +13,12 @@ CATEGORIES= x11 linux
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of gnome-libs
-RPM_SET= gnome-libs-${PORTVERSION}-11.${MACHINE_ARCH}.rpm
+RPM_SET= gnome-libs-${PORTVERSION}-11.${ARCH}.rpm
.include "../../x11-toolkits/linux-gtk/Makefile"
-.if (${MACHINE_ARCH} == "i386")
+.if (${ARCH} == "i386")
MASTER_SITES+= ftp://ftp.redhat.com/pub/redhat/linux/7.1/en/os/i386/RedHat/RPMS/
-.elif (${MACHINE_ARCH} == "alpha")
+.elif (${ARCH} == "alpha")
MASTER_SITES+= ftp://ftp.redhat.com/pub/redhat/linux/7.1/en/os/alpha/RedHat/RPMS/
.endif
diff --git a/x11/multi-aterm/Makefile b/x11/multi-aterm/Makefile
index cac30db984d9..b81997b65f6e 100644
--- a/x11/multi-aterm/Makefile
+++ b/x11/multi-aterm/Makefile
@@ -16,7 +16,7 @@ COMMENT= A multi terminal based on aterm
USE_X_PREFIX= yes
USE_LIBTOOL_VER=13
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
DOCS= AUTHORS ChangeLog INSTALL TODO
MAN1= multi-aterm.1
diff --git a/x11/panoramixext/Makefile b/x11/panoramixext/Makefile
index 70067598b5ac..85e98a41ffa7 100644
--- a/x11/panoramixext/Makefile
+++ b/x11/panoramixext/Makefile
@@ -18,7 +18,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_GNOME= gnomehack
diff --git a/x11/randrext/Makefile b/x11/randrext/Makefile
index 73b4dcd1e0ff..7553e54d8aad 100644
--- a/x11/randrext/Makefile
+++ b/x11/randrext/Makefile
@@ -18,7 +18,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
NO_BUILD= yes
diff --git a/x11/renderext/Makefile b/x11/renderext/Makefile
index 4ef86b0c7e80..4c4b3edc7d06 100644
--- a/x11/renderext/Makefile
+++ b/x11/renderext/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/x11/resourceext/Makefile b/x11/resourceext/Makefile
index c82986ec7468..26599917c8e3 100644
--- a/x11/resourceext/Makefile
+++ b/x11/resourceext/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
NO_BUILD= yes
USE_GNOME= gnomehack
diff --git a/x11/rxvt-unicode/Makefile b/x11/rxvt-unicode/Makefile
index 000c88acbf7f..4aacb8f9b940 100644
--- a/x11/rxvt-unicode/Makefile
+++ b/x11/rxvt-unicode/Makefile
@@ -22,7 +22,7 @@ USE_X_PREFIX= yes
USE_XPM= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --enable-everything --with-term=rxvt
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/x11/wdm/Makefile b/x11/wdm/Makefile
index 64f53904a150..31a5e28f5fbf 100644
--- a/x11/wdm/Makefile
+++ b/x11/wdm/Makefile
@@ -27,7 +27,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
DEF_SERVER="${DEF_SERVER}"
CONFIGURE_ARGS= --with-logdir=/var/log \
diff --git a/x11/xautomation/Makefile b/x11/xautomation/Makefile
index 803be8ad8e52..88395cfa8442 100644
--- a/x11/xautomation/Makefile
+++ b/x11/xautomation/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_XLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
diff --git a/x11/xextensions/Makefile b/x11/xextensions/Makefile
index 10de5b88c80b..b5a3188f8569 100644
--- a/x11/xextensions/Makefile
+++ b/x11/xextensions/Makefile
@@ -21,7 +21,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
NO_BUILD= yes
USE_GNOME= gnomehack
diff --git a/x11/xlockmore/Makefile b/x11/xlockmore/Makefile
index 382a75dad810..82baf1695b62 100644
--- a/x11/xlockmore/Makefile
+++ b/x11/xlockmore/Makefile
@@ -34,7 +34,7 @@ USE_X_PREFIX= yes
USE_XPM= yes
MAN1= xlock.1
-.if ${MACHINE_ARCH} == "amd64"
+.if ${ARCH} == "amd64"
WITH_MESAGL= no
.else
WITH_MESAGL?= yes
diff --git a/x11/xnee/Makefile b/x11/xnee/Makefile
index b1293721f15e..cc752b231aea 100644
--- a/x11/xnee/Makefile
+++ b/x11/xnee/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= texi2html:${PORTSDIR}/textproc/texi2html
USE_X_PREFIX= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= xnee.1
INFO= xnee xnee_develop
diff --git a/x11/xproto/Makefile b/x11/xproto/Makefile
index 9616df522aed..f284f9cdafe5 100644
--- a/x11/xproto/Makefile
+++ b/x11/xproto/Makefile
@@ -18,7 +18,7 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
NO_BUILD= yes
USE_GNOME= gnomehack
diff --git a/x11/xterm/Makefile b/x11/xterm/Makefile
index 9156c91d6661..f8a45f1b71c9 100644
--- a/x11/xterm/Makefile
+++ b/x11/xterm/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LIBS="-L${X11BASE}/lib"
CONFIGURE_ARGS+= --enable-wide-chars --enable-luit --with-utempter
diff --git a/x11/xtermcontrol/Makefile b/x11/xtermcontrol/Makefile
index f8ea7711a7e8..e9072284cefe 100644
--- a/x11/xtermcontrol/Makefile
+++ b/x11/xtermcontrol/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= xterm-static:${PORTSDIR}/x11/xterm
USE_X_PREFIX= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LIBS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
diff --git a/x11/xvattr/Makefile b/x11/xvattr/Makefile
index ce8f27876864..d40396c0b746 100644
--- a/x11/xvattr/Makefile
+++ b/x11/xvattr/Makefile
@@ -20,7 +20,7 @@ USE_PERL5_BUILD= yes
USE_GETOPT_LONG= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= xvattr.1