aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-06-03 03:13:41 +0800
committerantoine <antoine@FreeBSD.org>2013-06-03 03:13:41 +0800
commit7386c78ca6418d2e1e7a5ea5a867397ece65574b (patch)
tree7b8917a6d4526b48583478f1f162a731e2aef3f7 /x11
parent6e319d92bba476a5d758cbfa6a72bfde4ed2e44b (diff)
downloadfreebsd-ports-gnome-7386c78ca6418d2e1e7a5ea5a867397ece65574b.tar.gz
freebsd-ports-gnome-7386c78ca6418d2e1e7a5ea5a867397ece65574b.tar.zst
freebsd-ports-gnome-7386c78ca6418d2e1e7a5ea5a867397ece65574b.zip
- Trim Makefile header
- Unbreak with clang
Diffstat (limited to 'x11')
-rw-r--r--x11/xgrab/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/x11/xgrab/Makefile b/x11/xgrab/Makefile
index a4418b4d64db..862ad2fc99f7 100644
--- a/x11/xgrab/Makefile
+++ b/x11/xgrab/Makefile
@@ -1,21 +1,17 @@
-# New ports collection makefile for: xgrab
-# Date created: 27 February 1995
-# Whom: jmz
-#
+# Created by: jmz
# $FreeBSD$
-#
PORTNAME= xgrab
PORTVERSION= 2.41
PORTREVISION= 3
CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITES= XCONTRIB
MASTER_SITE_SUBDIR= applications
DISTNAME= ${PORTNAME}sc.2_41
EXTRACT_SUFX= .tar.Z
MAINTAINER= ports@FreeBSD.org
-COMMENT= An X11 image grabber
+COMMENT= X11 image grabber
BUILD_DEPENDS= xrdb:${PORTSDIR}/x11/xrdb
@@ -27,6 +23,7 @@ MAKE_FLAGS= BINDIR=${PREFIX}/bin MANDIR=${PREFIX}/man/man1 \
XAPPLOADDIR=${PREFIX}/lib/X11/app-defaults -f
# "make depend" blows up
XMKMF= xmkmf
+CFLAGS+= -Wno-error=return-type
.if (!defined(DISPLAY) || ${DISPLAY} == "") && !defined(PACKAGE_BUILDING)
IGNORE= Requires an active X session (and DISPLAY variable) to run xrdb. Please compile this while running X.