aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-07-10 20:49:20 +0800
committeritetcu <itetcu@FreeBSD.org>2006-07-10 20:49:20 +0800
commit8de0ebf30f3e3adb214f2b16cf23c8a5772e7c1e (patch)
tree38a5a8d7573c843b941145100316d36b51a00c6e /x11
parent7cd252b8e18a6bb450fd32abf8a5183ffbed9d2a (diff)
downloadfreebsd-ports-gnome-8de0ebf30f3e3adb214f2b16cf23c8a5772e7c1e.tar.gz
freebsd-ports-gnome-8de0ebf30f3e3adb214f2b16cf23c8a5772e7c1e.tar.zst
freebsd-ports-gnome-8de0ebf30f3e3adb214f2b16cf23c8a5772e7c1e.zip
An e17 module indicating the system's current uptime, load averages and number
of active users in a configurable interval. Author: Matthew Mullins WWW: http://www.enlightenment.org PR: ports/99368 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/e17-module-uptime/Makefile36
-rw-r--r--x11/e17-module-uptime/distinfo3
-rw-r--r--x11/e17-module-uptime/files/patch-configure11
-rw-r--r--x11/e17-module-uptime/pkg-descr5
-rw-r--r--x11/e17-module-uptime/pkg-plist12
6 files changed, 68 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 1820030c5a1f..0a974836ec96 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -42,6 +42,7 @@
SUBDIR += e17-module-deskshow
SUBDIR += e17-module-mem
SUBDIR += e17-module-moon
+ SUBDIR += e17-module-uptime
SUBDIR += e17-module-weather
SUBDIR += ebuttons
SUBDIR += ecore
diff --git a/x11/e17-module-uptime/Makefile b/x11/e17-module-uptime/Makefile
new file mode 100644
index 000000000000..36d5f8af1395
--- /dev/null
+++ b/x11/e17-module-uptime/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-uptime
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uptime
+PORTVERSION= 20060707
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 uptime and load average indicator module
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/e17-module-uptime/distinfo b/x11/e17-module-uptime/distinfo
new file mode 100644
index 000000000000..851ccb9f799e
--- /dev/null
+++ b/x11/e17-module-uptime/distinfo
@@ -0,0 +1,3 @@
+MD5 (uptime-20060707.tar.bz2) = 83d8f63ee637ddcc3eb8cbff01e1a50d
+SHA256 (uptime-20060707.tar.bz2) = 9a4713e04faa55c309cf03d7f431b81ee6ddc36a238f696b7a132a0099926783
+SIZE (uptime-20060707.tar.bz2) = 275549
diff --git a/x11/e17-module-uptime/files/patch-configure b/x11/e17-module-uptime/files/patch-configure
new file mode 100644
index 000000000000..23658b3b18eb
--- /dev/null
+++ b/x11/e17-module-uptime/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jun 23 17:14:42 2006
++++ configure Fri Jun 23 17:14:53 2006
+@@ -23390,7 +23390,7 @@
+
+
+
+-MODULE_ARCH="$host_os-$host_cpu"
++MODULE_ARCH=""
+
+
+ cat >>confdefs.h <<_ACEOF
diff --git a/x11/e17-module-uptime/pkg-descr b/x11/e17-module-uptime/pkg-descr
new file mode 100644
index 000000000000..fc16d8c5b3b8
--- /dev/null
+++ b/x11/e17-module-uptime/pkg-descr
@@ -0,0 +1,5 @@
+An e17 module indicating the system's current uptime, load averages and number
+of active users in a configurable interval.
+
+Author: Matthew Mullins
+WWW: http://www.enlightenment.org
diff --git a/x11/e17-module-uptime/pkg-plist b/x11/e17-module-uptime/pkg-plist
new file mode 100644
index 000000000000..9e5d90c0caf8
--- /dev/null
+++ b/x11/e17-module-uptime/pkg-plist
@@ -0,0 +1,12 @@
+lib/enlightenment/modules/uptime/module.a
+lib/enlightenment/modules/uptime/module.eap
+lib/enlightenment/modules/uptime/module.la
+lib/enlightenment/modules/uptime/module.so
+lib/enlightenment/modules/uptime/uptime.edj
+%%NLS%%share/locale/bg/LC_MESSAGES/uptime.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/uptime.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/uptime.mo
+%%NLS%%share/locale/it/LC_MESSAGES/uptime.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/uptime.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/uptime.mo
+@dirrm lib/enlightenment/modules/uptime