aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1996-11-09 10:08:56 +0800
committerasami <asami@FreeBSD.org>1996-11-09 10:08:56 +0800
commitaf36cc6f919c5b8171a8127fe6b00063857ecfb9 (patch)
tree1a125c752c914312e3849c985e5f88f87eb83ed1 /x11
parent39c630569125e4b3688ae23093494e52c9836217 (diff)
downloadfreebsd-ports-gnome-af36cc6f919c5b8171a8127fe6b00063857ecfb9.tar.gz
freebsd-ports-gnome-af36cc6f919c5b8171a8127fe6b00063857ecfb9.tar.zst
freebsd-ports-gnome-af36cc6f919c5b8171a8127fe6b00063857ecfb9.zip
Split out contrib part (is now x11/XFree86-contrib port). Make this
Makefile look like one for a regular port. Full PLIST will follow later, I'm doing a recompile now. Reviewed by: jmz
Diffstat (limited to 'x11')
-rw-r--r--x11/XFree86-4-clients/Makefile47
-rw-r--r--x11/XFree86-4-clients/distinfo1
-rw-r--r--x11/XFree86-4-libraries/Makefile47
-rw-r--r--x11/XFree86-4-libraries/distinfo1
-rw-r--r--x11/XFree86-4/Makefile47
-rw-r--r--x11/XFree86-4/distinfo1
-rw-r--r--x11/XFree86/Makefile47
-rw-r--r--x11/XFree86/distinfo1
8 files changed, 80 insertions, 112 deletions
diff --git a/x11/XFree86-4-clients/Makefile b/x11/XFree86-4-clients/Makefile
index 76c72f0540b1..a756219acea1 100644
--- a/x11/XFree86-4-clients/Makefile
+++ b/x11/XFree86-4-clients/Makefile
@@ -3,38 +3,31 @@
# Date created: 5 January 1995
# Whom: jmz
#
-# $Id: Makefile,v 1.17 1996/02/15 00:53:15 jmz Exp $
+# $Id: Makefile,v 1.20 1996/11/06 13:37:54 jmz Exp $
#
-#######################################################################
-# #
-# Configurable Section #
-# #
-#######################################################################
-#
-# Define FORCE_PACKAGE from the command line if you want to override
-# this and build a package
-NO_PACKAGE = yes
-#######################################################################
-DISTNAME = xc
-PKGNAME = XFree86-3.2
-CATEGORIES = x11
-IS_INTERACTIVE = yes
-PREFIX = /usr/X11R6
-MAINTAINER= jmz@FreeBSD.ORG
-
-do-build:
- @(cd ${WRKSRC}; echo Good night...; make World 2>&1 | tee world.log)
- @touch ${WRKDIR}/.build_done
+DISTNAME= xc
+PKGNAME= XFree86-3.2
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.xfree86.org/pub/XFree86/3.2/source/ \
+ ftp://xfree86.cdrom.com/pub/XFree86/source/ \
+ ftp://ftp.ibp.fr/pub/X11/XFree86/XFree86-3.2/source/ \
+ ftp://ftp.uni-stuttgart.de/pub/X11/Xfree86/3.2/source/ \
+ ftp://sunsite.doc.ic.ac.uk/packages/XFree86/3.2/source/
+DISTFILES= X32src-1.tgz X32src-2.tgz
-do-install:
- @(cd ${WRKSRC}; make install; make install.man)
- @touch ${WRKDIR}/.install_done
+MAINTAINER= jmz@FreeBSD.ORG
-.include "Makefile.ftp"
+# Define FORCE_PACKAGE from the command line if you want to override
+# this and build a package
+NO_PACKAGE= yes
+IS_INTERACTIVE= yes # configure script asks questions
+USE_X11= yes
+ALL_TARGET= World
+INSTALL_TARGET= install install.man
+DIST_SUBDIR= xc
post-install:
- ldconfig -m ${PREFIX}/lib
+ /sbin/ldconfig -m ${PREFIX}/lib
.include <bsd.port.mk>
-
diff --git a/x11/XFree86-4-clients/distinfo b/x11/XFree86-4-clients/distinfo
index 16406345895f..208b648471a7 100644
--- a/x11/XFree86-4-clients/distinfo
+++ b/x11/XFree86-4-clients/distinfo
@@ -1,3 +1,2 @@
MD5 (X32src-1.tgz) = 0fe3b4741e31c1ee210b27d5ce987b3e
MD5 (X32src-2.tgz) = 36cdf4ed5d58bbde30f6d95de6a8653a
-MD5 (X32contrib.tgz) = 5145fbc4c28e6dbb14450b36c5f3f56a
diff --git a/x11/XFree86-4-libraries/Makefile b/x11/XFree86-4-libraries/Makefile
index 76c72f0540b1..a756219acea1 100644
--- a/x11/XFree86-4-libraries/Makefile
+++ b/x11/XFree86-4-libraries/Makefile
@@ -3,38 +3,31 @@
# Date created: 5 January 1995
# Whom: jmz
#
-# $Id: Makefile,v 1.17 1996/02/15 00:53:15 jmz Exp $
+# $Id: Makefile,v 1.20 1996/11/06 13:37:54 jmz Exp $
#
-#######################################################################
-# #
-# Configurable Section #
-# #
-#######################################################################
-#
-# Define FORCE_PACKAGE from the command line if you want to override
-# this and build a package
-NO_PACKAGE = yes
-#######################################################################
-DISTNAME = xc
-PKGNAME = XFree86-3.2
-CATEGORIES = x11
-IS_INTERACTIVE = yes
-PREFIX = /usr/X11R6
-MAINTAINER= jmz@FreeBSD.ORG
-
-do-build:
- @(cd ${WRKSRC}; echo Good night...; make World 2>&1 | tee world.log)
- @touch ${WRKDIR}/.build_done
+DISTNAME= xc
+PKGNAME= XFree86-3.2
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.xfree86.org/pub/XFree86/3.2/source/ \
+ ftp://xfree86.cdrom.com/pub/XFree86/source/ \
+ ftp://ftp.ibp.fr/pub/X11/XFree86/XFree86-3.2/source/ \
+ ftp://ftp.uni-stuttgart.de/pub/X11/Xfree86/3.2/source/ \
+ ftp://sunsite.doc.ic.ac.uk/packages/XFree86/3.2/source/
+DISTFILES= X32src-1.tgz X32src-2.tgz
-do-install:
- @(cd ${WRKSRC}; make install; make install.man)
- @touch ${WRKDIR}/.install_done
+MAINTAINER= jmz@FreeBSD.ORG
-.include "Makefile.ftp"
+# Define FORCE_PACKAGE from the command line if you want to override
+# this and build a package
+NO_PACKAGE= yes
+IS_INTERACTIVE= yes # configure script asks questions
+USE_X11= yes
+ALL_TARGET= World
+INSTALL_TARGET= install install.man
+DIST_SUBDIR= xc
post-install:
- ldconfig -m ${PREFIX}/lib
+ /sbin/ldconfig -m ${PREFIX}/lib
.include <bsd.port.mk>
-
diff --git a/x11/XFree86-4-libraries/distinfo b/x11/XFree86-4-libraries/distinfo
index 16406345895f..208b648471a7 100644
--- a/x11/XFree86-4-libraries/distinfo
+++ b/x11/XFree86-4-libraries/distinfo
@@ -1,3 +1,2 @@
MD5 (X32src-1.tgz) = 0fe3b4741e31c1ee210b27d5ce987b3e
MD5 (X32src-2.tgz) = 36cdf4ed5d58bbde30f6d95de6a8653a
-MD5 (X32contrib.tgz) = 5145fbc4c28e6dbb14450b36c5f3f56a
diff --git a/x11/XFree86-4/Makefile b/x11/XFree86-4/Makefile
index 76c72f0540b1..a756219acea1 100644
--- a/x11/XFree86-4/Makefile
+++ b/x11/XFree86-4/Makefile
@@ -3,38 +3,31 @@
# Date created: 5 January 1995
# Whom: jmz
#
-# $Id: Makefile,v 1.17 1996/02/15 00:53:15 jmz Exp $
+# $Id: Makefile,v 1.20 1996/11/06 13:37:54 jmz Exp $
#
-#######################################################################
-# #
-# Configurable Section #
-# #
-#######################################################################
-#
-# Define FORCE_PACKAGE from the command line if you want to override
-# this and build a package
-NO_PACKAGE = yes
-#######################################################################
-DISTNAME = xc
-PKGNAME = XFree86-3.2
-CATEGORIES = x11
-IS_INTERACTIVE = yes
-PREFIX = /usr/X11R6
-MAINTAINER= jmz@FreeBSD.ORG
-
-do-build:
- @(cd ${WRKSRC}; echo Good night...; make World 2>&1 | tee world.log)
- @touch ${WRKDIR}/.build_done
+DISTNAME= xc
+PKGNAME= XFree86-3.2
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.xfree86.org/pub/XFree86/3.2/source/ \
+ ftp://xfree86.cdrom.com/pub/XFree86/source/ \
+ ftp://ftp.ibp.fr/pub/X11/XFree86/XFree86-3.2/source/ \
+ ftp://ftp.uni-stuttgart.de/pub/X11/Xfree86/3.2/source/ \
+ ftp://sunsite.doc.ic.ac.uk/packages/XFree86/3.2/source/
+DISTFILES= X32src-1.tgz X32src-2.tgz
-do-install:
- @(cd ${WRKSRC}; make install; make install.man)
- @touch ${WRKDIR}/.install_done
+MAINTAINER= jmz@FreeBSD.ORG
-.include "Makefile.ftp"
+# Define FORCE_PACKAGE from the command line if you want to override
+# this and build a package
+NO_PACKAGE= yes
+IS_INTERACTIVE= yes # configure script asks questions
+USE_X11= yes
+ALL_TARGET= World
+INSTALL_TARGET= install install.man
+DIST_SUBDIR= xc
post-install:
- ldconfig -m ${PREFIX}/lib
+ /sbin/ldconfig -m ${PREFIX}/lib
.include <bsd.port.mk>
-
diff --git a/x11/XFree86-4/distinfo b/x11/XFree86-4/distinfo
index 16406345895f..208b648471a7 100644
--- a/x11/XFree86-4/distinfo
+++ b/x11/XFree86-4/distinfo
@@ -1,3 +1,2 @@
MD5 (X32src-1.tgz) = 0fe3b4741e31c1ee210b27d5ce987b3e
MD5 (X32src-2.tgz) = 36cdf4ed5d58bbde30f6d95de6a8653a
-MD5 (X32contrib.tgz) = 5145fbc4c28e6dbb14450b36c5f3f56a
diff --git a/x11/XFree86/Makefile b/x11/XFree86/Makefile
index 76c72f0540b1..a756219acea1 100644
--- a/x11/XFree86/Makefile
+++ b/x11/XFree86/Makefile
@@ -3,38 +3,31 @@
# Date created: 5 January 1995
# Whom: jmz
#
-# $Id: Makefile,v 1.17 1996/02/15 00:53:15 jmz Exp $
+# $Id: Makefile,v 1.20 1996/11/06 13:37:54 jmz Exp $
#
-#######################################################################
-# #
-# Configurable Section #
-# #
-#######################################################################
-#
-# Define FORCE_PACKAGE from the command line if you want to override
-# this and build a package
-NO_PACKAGE = yes
-#######################################################################
-DISTNAME = xc
-PKGNAME = XFree86-3.2
-CATEGORIES = x11
-IS_INTERACTIVE = yes
-PREFIX = /usr/X11R6
-MAINTAINER= jmz@FreeBSD.ORG
-
-do-build:
- @(cd ${WRKSRC}; echo Good night...; make World 2>&1 | tee world.log)
- @touch ${WRKDIR}/.build_done
+DISTNAME= xc
+PKGNAME= XFree86-3.2
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.xfree86.org/pub/XFree86/3.2/source/ \
+ ftp://xfree86.cdrom.com/pub/XFree86/source/ \
+ ftp://ftp.ibp.fr/pub/X11/XFree86/XFree86-3.2/source/ \
+ ftp://ftp.uni-stuttgart.de/pub/X11/Xfree86/3.2/source/ \
+ ftp://sunsite.doc.ic.ac.uk/packages/XFree86/3.2/source/
+DISTFILES= X32src-1.tgz X32src-2.tgz
-do-install:
- @(cd ${WRKSRC}; make install; make install.man)
- @touch ${WRKDIR}/.install_done
+MAINTAINER= jmz@FreeBSD.ORG
-.include "Makefile.ftp"
+# Define FORCE_PACKAGE from the command line if you want to override
+# this and build a package
+NO_PACKAGE= yes
+IS_INTERACTIVE= yes # configure script asks questions
+USE_X11= yes
+ALL_TARGET= World
+INSTALL_TARGET= install install.man
+DIST_SUBDIR= xc
post-install:
- ldconfig -m ${PREFIX}/lib
+ /sbin/ldconfig -m ${PREFIX}/lib
.include <bsd.port.mk>
-
diff --git a/x11/XFree86/distinfo b/x11/XFree86/distinfo
index 16406345895f..208b648471a7 100644
--- a/x11/XFree86/distinfo
+++ b/x11/XFree86/distinfo
@@ -1,3 +1,2 @@
MD5 (X32src-1.tgz) = 0fe3b4741e31c1ee210b27d5ce987b3e
MD5 (X32src-2.tgz) = 36cdf4ed5d58bbde30f6d95de6a8653a
-MD5 (X32contrib.tgz) = 5145fbc4c28e6dbb14450b36c5f3f56a