aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-08-04 04:40:40 +0800
committerpawel <pawel@FreeBSD.org>2016-08-04 04:40:40 +0800
commitbbb918e9283b21ce4b50fb54f07846228d98d69d (patch)
tree82f24b6f430e397c4e56d4f0cb05224dcab812e4 /x11
parent06ba1bbd36a5b0e10d2a482a40c3aceeabc5c34f (diff)
downloadfreebsd-ports-gnome-bbb918e9283b21ce4b50fb54f07846228d98d69d.tar.gz
freebsd-ports-gnome-bbb918e9283b21ce4b50fb54f07846228d98d69d.tar.zst
freebsd-ports-gnome-bbb918e9283b21ce4b50fb54f07846228d98d69d.zip
Simplestroke is a simple utility that detects mouse gestures. It
currently detects twelve pre-defined mouse gestures and prints the name of the detected gesture to stdout, if any. The output can then e.g. be used in a simple shell script to execute commands. Example usages could include closing windows in i3 by drawing a Z over them or other window manipulations, or pausing your music player by drawing a left-to-right line. WWW: https://github.com/t6/simplestroke/ PR: 211550 Submitted by: Tobias Kortkamp <t@tobik.me>
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/simplestroke/Makefile24
-rw-r--r--x11/simplestroke/distinfo3
-rw-r--r--x11/simplestroke/pkg-descr10
4 files changed, 38 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 2d00f0e3fb24..9e0b9469e5fd 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -266,6 +266,7 @@
SUBDIR += setlayout
SUBDIR += setxkbmap
SUBDIR += simdock
+ SUBDIR += simplestroke
SUBDIR += sisctrl
SUBDIR += slim
SUBDIR += slock
diff --git a/x11/simplestroke/Makefile b/x11/simplestroke/Makefile
new file mode 100644
index 000000000000..9a02827286bb
--- /dev/null
+++ b/x11/simplestroke/Makefile
@@ -0,0 +1,24 @@
+# Created by: Tobias Kortkamp <t@tobik.me>
+# $FreeBSD$
+
+PORTNAME= simplestroke
+PORTVERSION= 1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= x11
+
+MAINTAINER= t@tobik.me
+COMMENT= Detect mouse gestures
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= t6
+
+USES= pkgconfig
+USE_XORG= x11 xtst
+
+PLIST_FILES= bin/simplestroke \
+ man/man1/simplestroke.1.gz
+
+.include <bsd.port.mk>
diff --git a/x11/simplestroke/distinfo b/x11/simplestroke/distinfo
new file mode 100644
index 000000000000..785e8fbae812
--- /dev/null
+++ b/x11/simplestroke/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470235134
+SHA256 (t6-simplestroke-v1.0_GH0.tar.gz) = 6213e3042ac87693d99d0093269b680f4d8ab1be9150dad887383876627e9c0a
+SIZE (t6-simplestroke-v1.0_GH0.tar.gz) = 7711
diff --git a/x11/simplestroke/pkg-descr b/x11/simplestroke/pkg-descr
new file mode 100644
index 000000000000..13f66b5c1f72
--- /dev/null
+++ b/x11/simplestroke/pkg-descr
@@ -0,0 +1,10 @@
+Simplestroke is a simple utility that detects mouse gestures. It
+currently detects twelve pre-defined mouse gestures and prints the
+name of the detected gesture to stdout, if any. The output can then
+e.g. be used in a simple shell script to execute commands.
+
+Example usages could include closing windows in i3 by drawing a Z over
+them or other window manipulations, or pausing your music player by
+drawing a left-to-right line.
+
+WWW: https://github.com/t6/simplestroke/