aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-05-14 07:38:15 +0800
committermarcus <marcus@FreeBSD.org>2006-05-14 07:38:15 +0800
commitbbfe04d053160603f49998647ac8f68943a08c96 (patch)
tree4d6d222d30a778e1bb4a8bd6bea19f5df03f26ac /x11
parent895a1a41971b3e43bced543944e468f0d29527cb (diff)
downloadfreebsd-ports-gnome-bbfe04d053160603f49998647ac8f68943a08c96.tar.gz
freebsd-ports-gnome-bbfe04d053160603f49998647ac8f68943a08c96.tar.zst
freebsd-ports-gnome-bbfe04d053160603f49998647ac8f68943a08c96.zip
Allow PAM support to be enabled in gnome-screensaver. g-s will use the
"other" PAM service since OpenPAM does not recognize ${X11BASE}/etc/pam.d. Requested by: Sean McNeil <sean@mcneil.com>
Diffstat (limited to 'x11')
-rw-r--r--x11/gnome-screensaver/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/x11/gnome-screensaver/Makefile b/x11/gnome-screensaver/Makefile
index 5b0d5859d48b..0591edb484bb 100644
--- a/x11/gnome-screensaver/Makefile
+++ b/x11/gnome-screensaver/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gnome-screensaver
PORTVERSION= 2.14.1
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -23,8 +24,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui gnomemenus
-CONFIGURE_ARGS= --disable-pam \
- --with-gdm-config=${X11BASE}/etc/gdm/custom.conf \
+CONFIGURE_ARGS= --with-gdm-config=${X11BASE}/etc/gdm/custom.conf \
--with-xscreensaverdir=${XSCREENSAVER_DIR} \
--with-xscreensaverhackdir=${X11BASE}/bin/xscreensaver-hacks
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
@@ -36,12 +36,18 @@ PLIST= ${WRKDIR}/pkg-plist
XSCREENSAVER_DIR= ${X11BASE}/share/xscreensaver/config
+OPTIONS= PAM "Pluggable Authentication Module support" off
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
BROKEN= Does not build on 4.X
.endif
+.if !defined(WITH_PAM)
+CONFIGURE_ARGS+= --without-pam
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/configure