aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2014-08-31 02:47:41 +0800
committerzeising <zeising@FreeBSD.org>2014-08-31 02:47:41 +0800
commitbd84adf6a05ad1ff4481dad2aec17ebcc201e100 (patch)
tree0a2ea9d47b5a0c44fc654d815d46f5edfb794dc2 /x11
parent8eeffdd96cdcdd79c084402ac9bc18214936f35c (diff)
downloadfreebsd-ports-gnome-bd84adf6a05ad1ff4481dad2aec17ebcc201e100.tar.gz
freebsd-ports-gnome-bd84adf6a05ad1ff4481dad2aec17ebcc201e100.tar.zst
freebsd-ports-gnome-bd84adf6a05ad1ff4481dad2aec17ebcc201e100.zip
- Fix shebangs by defining PERL in CONFIGURE_ENV
- Add some missing files to pkg-plist, don't try to remove mtree dirs, and get rid of ugly plist hack from Makefile (it is broken with staging anyways, so add gdkpixbuf2 as dependency to make sure that "bin/xscreensaver-hacks/webcollage-helper" is always installed) - Deal with SETUID_HACK with @mode directive instead of with the configure option so that a regular user can build and then install as root - Move some LIB_DEPENDS to USE_GNOME - Use options helpers - Remove PTHREADS option as there is no longer a configure knob for it - Remove KERBEROS option since it is broken (needs ancient krb4 lib which we don't have anymore) - Simplify post-patch commands. The hacks for the PAM option don't need to be conditional. Staging will handle whether the file is installed or not. - Pet portlint(1) - Bump PORTREVISION PR: 192616 Submitted by: jhale
Diffstat (limited to 'x11')
-rw-r--r--x11/xscreensaver/Makefile135
-rw-r--r--x11/xscreensaver/pkg-plist77
2 files changed, 70 insertions, 142 deletions
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 1f95a7c89b63..9d278dff07c7 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -3,96 +3,69 @@
PORTNAME= xscreensaver
PORTVERSION= 5.29
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= http://www.jwz.org/xscreensaver/
MAINTAINER= zeising@FreeBSD.org
COMMENT= Save your screen while you entertain your cat
-LIB_DEPENDS= libgle.so:${PORTSDIR}/graphics/gle \
- libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libgtk-x11-2.0.so:${PORTSDIR}/x11-toolkits/gtk20 \
- libxml2.so:${PORTSDIR}/textproc/libxml2 \
- libglade-2.0.so:${PORTSDIR}/devel/libglade2
-
RUN_DEPENDS= p5-libwww>0:${PORTSDIR}/www/p5-libwww \
giftopnm:${PORTSDIR}/graphics/netpbm
+LIB_DEPENDS= libgle.so:${PORTSDIR}/graphics/gle \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
DESTDIRNAME= install_prefix
CONFLICTS= xscreensaver-gnome-[0-9]* xscreensaver-gnome-hacks-[0-9]*
-USES= pkgconfig gettext gmake
-USE_XORG= xpm xext xxf86misc
+USES= pkgconfig gettext gmake perl5
+USE_AUTOTOOLS= autoconf
USE_GL= yes
+USE_GNOME= gdkpixbuf2 gtk20 intltool libglade2 libxml2
+USE_PERL5= run
+USE_XORG= xpm xext xxf86misc
+
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf
-USE_GNOME= intltool
-CONFIGURE_ENV+= "CPPFLAGS= -I ${LOCALBASE}/include" "LDFLAGS= -L ${LOCALBASE}/lib"
+CONFIGURE_ENV+= PERL="${PERL}"
CONFIGURE_ARGS= --with-gtk --with-gl --with-gle --with-pixbuf --with-xpm \
--with-jpeg=${LOCALBASE} --with-xshm-ext --with-xdbe-ext \
--with-hackdir=${PREFIX}/bin/xscreensaver-hacks/ \
--with-configdir=${PREFIX}/share/xscreensaver/config/ \
--with-dpms-ext --with-xinerama-ext --with-xf86vmode-ext \
- --with-xf86gamma-ext --with-randr-ext --enable-locking
-
-OPTIONS_DEFINE= KERBEROS PAM PTHREADS SETUID_HACKS FIREF XAOS1 XDALI XURTH \
- XMOUN XPLAN XSNOW
-PTHREADS_DESC= Use pthreads for SMP support
-SETUID_HACKS_DESC= Install sonar hack suid so it can ping
-FIREF_DESC= Add extra port x11/fireflies
-XAOS1_DESC= Add extra port graphics/xaos
-XDALI_DESC= Add extra port x11-clocks/xdaliclock
-XURTH_DESC= Add extra port astro/xearth
-XMOUN_DESC= Add extra port graphics/xmountains
-XPLAN_DESC= Add extra port astro/xplanet
-XSNOW_DESC= Add extra port x11/xsnow
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MKERBEROS}
-CONFIGURE_ARGS+= --with-kerberos
-.else
-CONFIGURE_ARGS+= --without-kerberos
-.endif
-.if ${PORT_OPTIONS:MPAM}
-CONFIGURE_ARGS+= --with-pam
-PLIST_SUB+= PAM=""
-.else
-CONFIGURE_ARGS+= --without-pam
-PLIST_SUB+= PAM="@comment not installed: "
-.endif
-.if ${PORT_OPTIONS:MSETUID_HACKS}
-CONFIGURE_ARGS+= --with-setuid-hacks
-.endif
-.if ${PORT_OPTIONS:MPTHREADS}
-CONFIGURE_ARGS+= --with-pthreads
-.endif
-
-.if ${PORT_OPTIONS:MFIREF}
-RUN_DEPENDS+= ${LOCALBASE}/bin/xscreensaver-hacks/fireflies:${PORTSDIR}/x11/fireflies
-.endif
-.if ${PORT_OPTIONS:MXAOS1}
-RUN_DEPENDS+= xaos:${PORTSDIR}/graphics/xaos
-.endif
-.if ${PORT_OPTIONS:MXDALI}
-RUN_DEPENDS+= xdaliclock:${PORTSDIR}/x11-clocks/xdaliclock
-.endif
-.if ${PORT_OPTIONS:MXURTH}
-RUN_DEPENDS+= xearth:${PORTSDIR}/astro/xearth
-.endif
-.if ${PORT_OPTIONS:MXMOUN}
-RUN_DEPENDS+= xmountains:${PORTSDIR}/graphics/xmountains
-.endif
-.if ${PORT_OPTIONS:MXPLAN}
-RUN_DEPENDS+= xplanet:${PORTSDIR}/astro/xplanet
-.endif
-.if ${PORT_OPTIONS:MXSNOW}
-RUN_DEPENDS+= xsnow:${PORTSDIR}/x11/xsnow
-.endif
-
-.undef HAVE_GNOME
+ --with-xf86gamma-ext --with-randr-ext --without-kerberos \
+ --without-setuid-hacks --enable-locking
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+OPTIONS_DEFINE= PAM SETUID_HACKS FIREF XAOS1 XDALI XEARTH \
+ XMOUN XPLANET XSNOW
+OPTIONS_SUB= yes
+
+PAM_CONFIGURE_WITH= pam
+
+SETUID_HACKS_DESC= Install sonar hack suid so it can ping
+
+FIREF_DESC= Add extra port x11/fireflies
+FIREF_RUN_DEPENDS= ${LOCALBASE}/bin/xscreensaver-hacks/fireflies:${PORTSDIR}/x11/fireflies
+
+XAOS1_DESC= Add extra port graphics/xaos
+XAOS1_RUN_DEPENDS= xaos:${PORTSDIR}/graphics/xaos
+
+XDALI_DESC= Add extra port x11-clocks/xdaliclock
+XDALI_RUN_DEPENDS= xdaliclock:${PORTSDIR}/x11-clocks/xdaliclock
+
+XEARTH_DESC= Add extra port astro/xearth
+XEARTH_RUN_DEPENDS= xearth:${PORTSDIR}/astro/xearth
+
+XMOUN_DESC= Add extra port graphics/xmountains
+XMOUN_RUN_DEPENDS= xmountains:${PORTSDIR}/graphics/xmountains
+
+XPLANET_DESC= Add extra port astro/xplanet
+XPLANET_RUN_DEPENDS= xplanet:${PORTSDIR}/astro/xplanet
+
+XSNOW_DESC= Add extra port x11/xsnow
+XSNOW_RUN_DEPENDS= xsnow:${PORTSDIR}/x11/xsnow
SUB_FILES= xscreensaver-blank.desktop xscreensaver-lock.desktop \
xscreensaver-start.desktop xscreensaver-stop.desktop
@@ -101,26 +74,14 @@ post-patch:
${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' \
-e 's|pkg_config --list-all|pkg_config --help|' \
${WRKSRC}/configure.in
-.if ${PORT_OPTIONS:MPAM}
-.for f in driver/passwd-pam.c driver/xscreensaver.man
- @ ${CP} ${WRKSRC}/${f} ${WRKSRC}/${f}.presed
- @ ${SED} -e "s#/etc/pam.d#${PREFIX}/etc/pam.d#g" \
- ${WRKSRC}/${f}.presed > ${WRKSRC}/${f}
-.endfor
- @ ${CP} ${FILESDIR}/xscreensaver.pam \
- ${WRKSRC}/driver/xscreensaver.pam.in
-.else
- @ ${CP} ${WRKSRC}/driver/Makefile.in ${WRKSRC}/driver/Makefile.in.post
- @ ${SED} -e "s#install-xml install-pam#install-xml#" \
- ${WRKSRC}/driver/Makefile.in.post > ${WRKSRC}/driver/Makefile.in
-.endif
+ ${REINPLACE_CMD} -e "s|/etc/pam.d|${PREFIX}/etc/pam.d|g" \
+ ${WRKSRC}/driver/passwd-pam.c \
+ ${WRKSRC}/driver/xscreensaver.man
+ ${CP} ${FILESDIR}/xscreensaver.pam \
+ ${WRKSRC}/driver/xscreensaver.pam.in
post-install:
${INSTALL_DATA} ${FILESDIR}/x*.xml ${STAGEDIR}${DATADIR}/config/
- @(if test -x ${LOCALBASE}/bin/xscreensaver-hacks/webcollage-helper; then \
- ${ECHO} "bin/xscreensaver-hacks/webcollage-helper" | \
- ${CAT} - ${TMPPLIST} > ${TMPPLIST}.cat && \
- ${MV} ${TMPPLIST}.cat ${TMPPLIST}; fi)
${INSTALL_DATA} ${WRKDIR}/*.desktop ${STAGEDIR}${PREFIX}/share/applications/
.include <bsd.port.mk>
diff --git a/x11/xscreensaver/pkg-plist b/x11/xscreensaver/pkg-plist
index fafa67fc528b..ba30b3d09814 100644
--- a/x11/xscreensaver/pkg-plist
+++ b/x11/xscreensaver/pkg-plist
@@ -76,6 +76,7 @@ bin/xscreensaver-hacks/fontglide
bin/xscreensaver-hacks/fuzzyflakes
bin/xscreensaver-hacks/galaxy
bin/xscreensaver-hacks/gears
+bin/xscreensaver-hacks/geodesic
bin/xscreensaver-hacks/gflux
bin/xscreensaver-hacks/glblur
bin/xscreensaver-hacks/glcells
@@ -108,8 +109,8 @@ bin/xscreensaver-hacks/jigglypuff
bin/xscreensaver-hacks/jigsaw
bin/xscreensaver-hacks/juggler3d
bin/xscreensaver-hacks/julia
-bin/xscreensaver-hacks/kaleidocycle
bin/xscreensaver-hacks/kaleidescope
+bin/xscreensaver-hacks/kaleidocycle
bin/xscreensaver-hacks/klein
bin/xscreensaver-hacks/kumppa
bin/xscreensaver-hacks/lament
@@ -150,6 +151,7 @@ bin/xscreensaver-hacks/polyominoes
bin/xscreensaver-hacks/polytopes
bin/xscreensaver-hacks/pong
bin/xscreensaver-hacks/popsquares
+bin/xscreensaver-hacks/projectiveplane
bin/xscreensaver-hacks/providence
bin/xscreensaver-hacks/pulsar
bin/xscreensaver-hacks/pyro
@@ -170,7 +172,9 @@ bin/xscreensaver-hacks/sierpinski3d
bin/xscreensaver-hacks/skytentacles
bin/xscreensaver-hacks/slidescreen
bin/xscreensaver-hacks/slip
+%%SETUID_HACKS%%@mode 4755
bin/xscreensaver-hacks/sonar
+%%SETUID_HACKS%%@mode
bin/xscreensaver-hacks/speedmine
bin/xscreensaver-hacks/spheremonics
bin/xscreensaver-hacks/spotlight
@@ -186,6 +190,7 @@ bin/xscreensaver-hacks/superquadrics
bin/xscreensaver-hacks/surfaces
bin/xscreensaver-hacks/swirl
bin/xscreensaver-hacks/tangram
+bin/xscreensaver-hacks/tessellimage
bin/xscreensaver-hacks/thornbird
bin/xscreensaver-hacks/timetunnel
bin/xscreensaver-hacks/topblock
@@ -199,6 +204,7 @@ bin/xscreensaver-hacks/vidwhacker
bin/xscreensaver-hacks/voronoi
bin/xscreensaver-hacks/wander
bin/xscreensaver-hacks/webcollage
+bin/xscreensaver-hacks/webcollage-helper
bin/xscreensaver-hacks/whirlwindwarp
bin/xscreensaver-hacks/wormhole
bin/xscreensaver-hacks/xanalogtv
@@ -290,6 +296,7 @@ man/man6/fontglide.6.gz
man/man6/fuzzyflakes.6.gz
man/man6/galaxy.6.gz
man/man6/gears.6.gz
+man/man6/geodesic.6.gz
man/man6/gflux.6.gz
man/man6/glblur.6.gz
man/man6/glcells.6.gz
@@ -362,6 +369,7 @@ man/man6/polyhedra.6.gz
man/man6/polyominoes.6.gz
man/man6/polytopes.6.gz
man/man6/pong.6.gz
+man/man6/projectiveplane.6.gz
man/man6/providence.6.gz
man/man6/pulsar.6.gz
man/man6/pyro.6.gz
@@ -398,6 +406,7 @@ man/man6/superquadrics.6.gz
man/man6/surfaces.6.gz
man/man6/swirl.6.gz
man/man6/tangram.6.gz
+man/man6/tessellimage.6.gz
man/man6/thornbird.6.gz
man/man6/timetunnel.6.gz
man/man6/topblock.6.gz
@@ -483,8 +492,8 @@ share/pixmaps/xscreensaver.xpm
%%DATADIR%%/config/celtic.xml
%%DATADIR%%/config/circuit.xml
%%DATADIR%%/config/cloudlife.xml
-%%DATADIR%%/config/compass.xml
%%DATADIR%%/config/companioncube.xml
+%%DATADIR%%/config/compass.xml
%%DATADIR%%/config/coral.xml
%%DATADIR%%/config/crackberg.xml
%%DATADIR%%/config/crystal.xml
@@ -523,6 +532,7 @@ share/pixmaps/xscreensaver.xpm
%%DATADIR%%/config/fuzzyflakes.xml
%%DATADIR%%/config/galaxy.xml
%%DATADIR%%/config/gears.xml
+%%DATADIR%%/config/geodesic.xml
%%DATADIR%%/config/gflux.xml
%%DATADIR%%/config/glblur.xml
%%DATADIR%%/config/glcells.xml
@@ -555,8 +565,8 @@ share/pixmaps/xscreensaver.xpm
%%DATADIR%%/config/jigsaw.xml
%%DATADIR%%/config/juggler3d.xml
%%DATADIR%%/config/julia.xml
-%%DATADIR%%/config/kaleidocycle.xml
%%DATADIR%%/config/kaleidescope.xml
+%%DATADIR%%/config/kaleidocycle.xml
%%DATADIR%%/config/klein.xml
%%DATADIR%%/config/kumppa.xml
%%DATADIR%%/config/lament.xml
@@ -596,6 +606,7 @@ share/pixmaps/xscreensaver.xpm
%%DATADIR%%/config/polytopes.xml
%%DATADIR%%/config/pong.xml
%%DATADIR%%/config/popsquares.xml
+%%DATADIR%%/config/projectiveplane.xml
%%DATADIR%%/config/providence.xml
%%DATADIR%%/config/pulsar.xml
%%DATADIR%%/config/pyro.xml
@@ -632,6 +643,7 @@ share/pixmaps/xscreensaver.xpm
%%DATADIR%%/config/surfaces.xml
%%DATADIR%%/config/swirl.xml
%%DATADIR%%/config/tangram.xml
+%%DATADIR%%/config/tessellimage.xml
%%DATADIR%%/config/thornbird.xml
%%DATADIR%%/config/timetunnel.xml
%%DATADIR%%/config/topblock.xml
@@ -648,19 +660,19 @@ share/pixmaps/xscreensaver.xpm
%%DATADIR%%/config/whirlwindwarp.xml
%%DATADIR%%/config/wormhole.xml
%%DATADIR%%/config/xanalogtv.xml
+%%DATADIR%%/config/xaos.xml
+%%DATADIR%%/config/xdaliclock.xml
+%%DATADIR%%/config/xearth.xml
%%DATADIR%%/config/xflame.xml
%%DATADIR%%/config/xjack.xml
%%DATADIR%%/config/xlyap.xml
%%DATADIR%%/config/xmatrix.xml
-%%DATADIR%%/config/xrayswarm.xml
-%%DATADIR%%/config/xspirograph.xml
-%%DATADIR%%/config/zoom.xml
-%%DATADIR%%/config/xaos.xml
-%%DATADIR%%/config/xdaliclock.xml
-%%DATADIR%%/config/xearth.xml
%%DATADIR%%/config/xmountains.xml
%%DATADIR%%/config/xplanet.xml
+%%DATADIR%%/config/xrayswarm.xml
%%DATADIR%%/config/xsnow.xml
+%%DATADIR%%/config/xspirograph.xml
+%%DATADIR%%/config/zoom.xml
%%DATADIR%%/glade/screensaver-cmndln.png
%%DATADIR%%/glade/screensaver-colorselector.png
%%DATADIR%%/glade/screensaver-diagnostic.png
@@ -669,51 +681,6 @@ share/pixmaps/xscreensaver.xpm
%%DATADIR%%/glade/screensaver-snap.png
%%DATADIR%%/glade/xscreensaver-demo.glade2
@dirrmtry bin/xscreensaver-hacks
-@dirrmtry share/locale/ca/LC_MESSAGES
-@dirrmtry share/locale/ca
-@dirrmtry share/locale/da/LC_MESSAGES
-@dirrmtry share/locale/da
-@dirrmtry share/locale/de/LC_MESSAGES
-@dirrmtry share/locale/de
-@dirrmtry share/locale/es/LC_MESSAGES
-@dirrmtry share/locale/es
-@dirrmtry share/locale/et/LC_MESSAGES
-@dirrmtry share/locale/et
-@dirrmtry share/locale/fi/LC_MESSAGES
-@dirrmtry share/locale/fi
-@dirrmtry share/locale/fr/LC_MESSAGES
-@dirrmtry share/locale/fr
-@dirrmtry share/locale/hu/LC_MESSAGES
-@dirrmtry share/locale/hu
-@dirrmtry share/locale/it/LC_MESSAGES
-@dirrmtry share/locale/it
-@dirrmtry share/locale/ja/LC_MESSAGES
-@dirrmtry share/locale/ja
-@dirrmtry share/locale/ko/LC_MESSAGES
-@dirrmtry share/locale/ko
-@dirrmtry share/locale/nb/LC_MESSAGES
-@dirrmtry share/locale/nb
-@dirrmtry share/locale/nl/LC_MESSAGES
-@dirrmtry share/locale/nl
-@dirrmtry share/locale/pl/LC_MESSAGES
-@dirrmtry share/locale/pt
-@dirrmtry share/locale/pt_BR/LC_MESSAGES
-@dirrmtry share/locale/pt_BR
-@dirrmtry share/locale/ru/LC_MESSAGES
-@dirrmtry share/locale/ru
-@dirrmtry share/locale/sk/LC_MESSAGES
-@dirrmtry share/locale/sk
-@dirrmtry share/locale/sv/LC_MESSAGES
-@dirrmtry share/locale/sv
-@dirrmtry share/locale/vi/LC_MESSAGES
-@dirrmtry share/locale/vi
-@dirrmtry share/locale/wa/LC_MESSAGES
-@dirrmtry share/locale/wa
-@dirrmtry share/locale/zh_CN/LC_MESSAGES
-@dirrmtry share/locale/zh_CN
-@dirrmtry share/locale/zh_TW/LC_MESSAGES
-@dirrmtry share/locale/zh_TW
-@dirrmtry share/locale
@dirrmtry %%DATADIR%%/config
-@dirrm %%DATADIR%%/glade
+@dirrmtry %%DATADIR%%/glade
@dirrmtry %%DATADIR%%