aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-01-25 14:16:07 +0800
committermarcus <marcus@FreeBSD.org>2004-01-25 14:16:07 +0800
commitc45d7d89267867c6a664eb3731ef4da812f02224 (patch)
tree0f78b2c921f16a1d13a547232603d9178db45d6b /x11
parentb911b285cd50d312617bb0b5e8265255ce23afa9 (diff)
downloadfreebsd-ports-gnome-c45d7d89267867c6a664eb3731ef4da812f02224.tar.gz
freebsd-ports-gnome-c45d7d89267867c6a664eb3731ef4da812f02224.tar.zst
freebsd-ports-gnome-c45d7d89267867c6a664eb3731ef4da812f02224.zip
Add gnome-clipboard-daemon, a clipboard manager for X.
GNOME Clipboard Daemon is a program that keeps the content of your X clipboard in memory, so the clipboard won't get lost even after you close the application you copied from. It's a daemon - it has no GUI. You start it and it'll run inthe background and Just Work(tm). Example: 1. Start AbiWord. 2. Type in 'hello world'. Select everything and click Copy. 3. Close AbiWord. 4. Start gedit. 5. Click Paste. Normally nothing will happen. But if GNOME Clipboard Daemon is running, pasting will work. PR: 61869 Submitted by: Jeremy Messenger <mezz7@cox.net>
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/gnome-clipboard-daemon/Makefile23
-rw-r--r--x11/gnome-clipboard-daemon/distinfo1
-rw-r--r--x11/gnome-clipboard-daemon/files/patch-Makefile32
-rw-r--r--x11/gnome-clipboard-daemon/pkg-descr14
-rw-r--r--x11/gnome-clipboard-daemon/pkg-plist1
6 files changed, 72 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index a8ed3c7a4668..6bd3c87adceb 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -49,6 +49,7 @@
SUBDIR += ggiterm
SUBDIR += gmessage
SUBDIR += gmrun
+ SUBDIR += gnome-clipboard-daemon
SUBDIR += gnome-swallow
SUBDIR += gnome2
SUBDIR += gnome2-fifth-toe
diff --git a/x11/gnome-clipboard-daemon/Makefile b/x11/gnome-clipboard-daemon/Makefile
new file mode 100644
index 000000000000..0df305d34315
--- /dev/null
+++ b/x11/gnome-clipboard-daemon/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: gnome-clipboard-daemon
+# Date created: 24 January 2004
+# Whom: Mezz <mezz7@cox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome-clipboard-daemon
+PORTVERSION= 1.0
+CATEGORIES= x11 gnome
+MASTER_SITES= http://members.chello.nl/~h.lai/gnome-clipboard-daemon/
+
+MAINTAINER= mezz7@cox.net
+COMMENT= A program that keeps the content of your X clipboard in memory
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/x11/gnome-clipboard-daemon/distinfo b/x11/gnome-clipboard-daemon/distinfo
new file mode 100644
index 000000000000..a0a40c9b4636
--- /dev/null
+++ b/x11/gnome-clipboard-daemon/distinfo
@@ -0,0 +1 @@
+MD5 (gnome-clipboard-daemon-1.0.tar.bz2) = 43c290b9ac0f0ace2c5465ca3f2395f3
diff --git a/x11/gnome-clipboard-daemon/files/patch-Makefile b/x11/gnome-clipboard-daemon/files/patch-Makefile
new file mode 100644
index 000000000000..9dd7439e1113
--- /dev/null
+++ b/x11/gnome-clipboard-daemon/files/patch-Makefile
@@ -0,0 +1,32 @@
+--- Makefile.orig Sat Jan 24 02:38:09 2004
++++ Makefile Sat Jan 24 23:52:55 2004
+@@ -1,22 +1,23 @@
+ .PHONY: all distdir dist clean
+
+-CC=gcc
+-CFLAGS=-Wall -O2
++#CC=gcc
++#CFLAGS=-Wall -O2
++PKGCONFIG=${LOCALBASE}/bin/pkg-config
+ VERSION=1.0
+
+ all: gnome-clipboard-daemon
+
+ gnome-clipboard-daemon: main.o gnome-clipboard-daemon.o selection-data-list.o
+- $(CC) $(CFLAGS) main.o gnome-clipboard-daemon.o selection-data-list.o -o gnome-clipboard-daemon `pkg-config --libs gtk+-2.0`
++ $(CC) $(CFLAGS) main.o gnome-clipboard-daemon.o selection-data-list.o -o gnome-clipboard-daemon `$(PKGCONFIG) --libs gtk+-2.0`
+
+ main.o: main.c
+- $(CC) $(CFLAGS) -c main.c -o main.o `pkg-config --cflags gtk+-2.0`
++ $(CC) $(CFLAGS) -c main.c -o main.o `$(PKGCONFIG) --cflags gtk+-2.0`
+
+ gnome-clipboard-daemon.o: gnome-clipboard-daemon.c gnome-clipboard-daemon.h
+- $(CC) $(CFLAGS) -c gnome-clipboard-daemon.c -o gnome-clipboard-daemon.o `pkg-config --cflags gtk+-2.0`
++ $(CC) $(CFLAGS) -c gnome-clipboard-daemon.c -o gnome-clipboard-daemon.o `$(PKGCONFIG) --cflags gtk+-2.0`
+
+ selection-data-list.o: selection-data-list.c selection-data-list.h
+- $(CC) $(CFLAGS) -c selection-data-list.c -o selection-data-list.o `pkg-config --cflags gtk+-2.0`
++ $(CC) $(CFLAGS) -c selection-data-list.c -o selection-data-list.o `$(PKGCONFIG) --cflags gtk+-2.0`
+
+ distdir:
+ rm -rf gnome-clipboard-daemon-$(VERSION)
diff --git a/x11/gnome-clipboard-daemon/pkg-descr b/x11/gnome-clipboard-daemon/pkg-descr
new file mode 100644
index 000000000000..1007926ce079
--- /dev/null
+++ b/x11/gnome-clipboard-daemon/pkg-descr
@@ -0,0 +1,14 @@
+GNOME Clipboard Daemon is a program that keeps the content of your X clipboard
+in memory, so the clipboard will not get lost even after you close the
+application from which you copied. It is a daemon - it has no GUI. You start
+it and it will run in the background and Just Work(tm).
+
+Example:
+ 1. Start AbiWord.
+ 2. Type in 'hello world'. Select everything and click Copy.
+ 3. Close AbiWord.
+ 4. Start gedit.
+ 5. Click Paste. Normally nothing will happen. But if GNOME Clipboard
+ Daemon is running, pasting will work.
+
+WWW: http://members.chello.nl/~h.lai/gnome-clipboard-daemon/
diff --git a/x11/gnome-clipboard-daemon/pkg-plist b/x11/gnome-clipboard-daemon/pkg-plist
new file mode 100644
index 000000000000..68b108d37a84
--- /dev/null
+++ b/x11/gnome-clipboard-daemon/pkg-plist
@@ -0,0 +1 @@
+bin/gnome-clipboard-daemon