aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-08-06 02:08:32 +0800
committermakc <makc@FreeBSD.org>2010-08-06 02:08:32 +0800
commite7ad4a5e3f46b6117bc082416dd090cf6e5c22f8 (patch)
tree1248823fc3afd27c2346c524a1d4405f41312e07 /x11
parent983e8d2d863208fae87de68bb36cf031cded2955 (diff)
downloadfreebsd-ports-gnome-e7ad4a5e3f46b6117bc082416dd090cf6e5c22f8.tar.gz
freebsd-ports-gnome-e7ad4a5e3f46b6117bc082416dd090cf6e5c22f8.tar.zst
freebsd-ports-gnome-e7ad4a5e3f46b6117bc082416dd090cf6e5c22f8.zip
Fix checks for ALSA headers
Diffstat (limited to 'x11')
-rw-r--r--x11/kdelibs4/Makefile1
-rw-r--r--x11/kdelibs4/files/patch-cmake_modules_FindAlsa.cmake10
2 files changed, 11 insertions, 0 deletions
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 3b422e29ce60..2c746a5ac943 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/x11/kdelibs4/files/patch-cmake_modules_FindAlsa.cmake b/x11/kdelibs4/files/patch-cmake_modules_FindAlsa.cmake
new file mode 100644
index 000000000000..943bb096b324
--- /dev/null
+++ b/x11/kdelibs4/files/patch-cmake_modules_FindAlsa.cmake
@@ -0,0 +1,10 @@
+--- ./cmake/modules/FindAlsa.cmake.orig 2010-03-24 16:20:34.000000000 +0300
++++ ./cmake/modules/FindAlsa.cmake 2010-08-05 18:49:30.046930607 +0400
+@@ -55,6 +55,7 @@
+ check_include_files(/usr/src/sys/i386/isa/sound/awe_voice.h HAVE__USR_SRC_SYS_I386_ISA_SOUND_AWE_VOICE_H)
+ check_include_files(/usr/src/sys/gnu/i386/isa/sound/awe_voice.h HAVE__USR_SRC_SYS_GNU_I386_ISA_SOUND_AWE_VOICE_H)
+
++ set(CMAKE_REQUIRED_INCLUDES ${ALSA_INCLUDES})
+ check_include_file_cxx(sys/asoundlib.h HAVE_SYS_ASOUNDLIB_H)
+ check_include_file_cxx(alsa/asoundlib.h HAVE_ALSA_ASOUNDLIB_H)
+