aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-01-15 08:46:22 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-01-15 08:46:22 +0800
commitedbf5c4c883de5a347e5765aaf833e7183d8e773 (patch)
tree5a68d8ad9fecd1dde18acd487d1069eee8f88866 /x11
parentaeea65e218ebd3915b1a50f7f5dae6746a2a6b3d (diff)
downloadfreebsd-ports-gnome-edbf5c4c883de5a347e5765aaf833e7183d8e773.tar.gz
freebsd-ports-gnome-edbf5c4c883de5a347e5765aaf833e7183d8e773.tar.zst
freebsd-ports-gnome-edbf5c4c883de5a347e5765aaf833e7183d8e773.zip
- Allow the user to choose a video driver to use instead of the default vesa driver.
- xinit and xauth are searched at the right place PR: ports/142053 Submitted by: Carlos Santos <unixmania@gmail.com> Approved by: Eitan Adler <eitanadlerlist@gmail.com> (maintainer)
Diffstat (limited to 'x11')
-rw-r--r--x11/xorg-minimal/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/x11/xorg-minimal/Makefile b/x11/xorg-minimal/Makefile
index fc6635cc321a..92648b9f0186 100644
--- a/x11/xorg-minimal/Makefile
+++ b/x11/xorg-minimal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xorg
PORTVERSION= 7.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 x11-servers
MASTER_SITES= # none
PKGNAMESUFFIX= -minimal
@@ -19,12 +19,14 @@ COMMENT= X.Org minimal distribution metaport
NO_BUILD= yes
+VIDEO_DRIVER?= vesa
+
RUN_DEPENDS+= ${LOCALBASE}/bin/Xorg:${PORTSDIR}/x11-servers/xorg-server \
- ${LOCALBASE}/lib/xorg/modules/drivers/vesa_drv.so:${PORTSDIR}/x11-drivers/xf86-video-vesa \
+ ${LOCALBASE}/lib/xorg/modules/drivers/${VIDEO_DRIVER}_drv.so:${PORTSDIR}/x11-drivers/xf86-video-${VIDEO_DRIVER} \
${LOCALBASE}/lib/xorg/modules/input/mouse_drv.so:${PORTSDIR}/x11-drivers/xf86-input-mouse \
${LOCALBASE}/lib/xorg/modules/input/kbd_drv.so:${PORTSDIR}/x11-drivers/xf86-input-keyboard \
- xinit:${PORTSDIR}/x11/xinit \
- xauth:${PORTSDIR}/x11/xauth \
+ ${LOCALBASE}/bin/xinit:${PORTSDIR}/x11/xinit \
+ ${LOCALBASE}/bin/xauth:${PORTSDIR}/x11/xauth \
${LOCALBASE}/lib/X11/fonts/misc/fonts.alias:${PORTSDIR}/x11-fonts/font-alias \
${LOCALBASE}/lib/X11/fonts/misc/cursor.pcf.gz:${PORTSDIR}/x11-fonts/font-cursor-misc \
${LOCALBASE}/lib/X11/fonts/misc/10x20.pcf.gz:${PORTSDIR}/x11-fonts/font-misc-misc
@@ -35,6 +37,10 @@ pre-everything::
@${ECHO_MSG} "This is a meta-port, meaning that it just depends on its subparts of the port."
@${ECHO_MSG} "It won't build and install all the parts until you have typed make install"
@${ECHO_MSG} "This port does not ensure things are upgraded; use portmaster if you want to"
- @${ECHO_MSG} "upgrade X.Org."
+ @${ECHO_MSG} "upgrade X.Org. The \"vesa\" driver is installed by default. You can choose a"
+ @${ECHO_MSG} "different one by means of the VIDEO_DRIVER parameter. For example:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " make install VIDEO_DRIVER=intel"
+ @${ECHO_MSG} ""
.include <bsd.port.mk>