aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2015-02-13 06:44:14 +0800
committernivit <nivit@FreeBSD.org>2015-02-13 06:44:14 +0800
commitef16590c2cb23dd9a60442751f06f56e08df640e (patch)
tree36999feb8e04320f844bf23c0df7411c0b834a3d /x11
parent523e223f8e7caca15167e5ae85683a69425cb2e2 (diff)
downloadfreebsd-ports-gnome-ef16590c2cb23dd9a60442751f06f56e08df640e.tar.gz
freebsd-ports-gnome-ef16590c2cb23dd9a60442751f06f56e08df640e.tar.zst
freebsd-ports-gnome-ef16590c2cb23dd9a60442751f06f56e08df640e.zip
- Update to 0.5.2
- Use GitHub as download site. The old ones no longer have the distribution file - Add devel/gnome-common to build dependencies - Use option helpers - Strip installed library Relnotes: https://github.com/Guake/guake/releases
Diffstat (limited to 'x11')
-rw-r--r--x11/guake/Makefile48
-rw-r--r--x11/guake/distinfo4
-rw-r--r--x11/guake/files/patch-data_Makefile.am10
-rw-r--r--x11/guake/files/patch-data__Makefile.in11
-rw-r--r--x11/guake/files/patch-data__guake-prefs.desktop.in4
-rw-r--r--x11/guake/files/patch-data__guake.desktop.in4
-rw-r--r--x11/guake/pkg-plist56
7 files changed, 83 insertions, 54 deletions
diff --git a/x11/guake/Makefile b/x11/guake/Makefile
index 7c8535ceaf6a..8708224dc9d9 100644
--- a/x11/guake/Makefile
+++ b/x11/guake/Makefile
@@ -1,19 +1,17 @@
# $FreeBSD$
PORTNAME= guake
-PORTVERSION= 0.4.4.0
-PORTREVISION= 3
+PORTVERSION= 0.5.2
+PORTREVISION= 0
CATEGORIES= x11
-MASTER_SITES= http://distfiles.gentoo.org/distfiles/ \
- http://nivit.altervista.org/FreeBSD/ports/distfiles/
-DISTNAME= ${PORTNAME}-${PORTVERSION:R}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Dropdown terminal made for the GNOME desktop
LICENSE= GPLv2
-BUILD_DEPENDS= py${PYTHON_SUFFIX}-dbus>=0.84.0:${PORTSDIR}/devel/py-dbus \
+BUILD_DEPENDS= gnome-common>=3.14.0:${PORTSDIR}/devel/gnome-common \
+ py${PYTHON_SUFFIX}-dbus>=0.84.0:${PORTSDIR}/devel/py-dbus \
py${PYTHON_SUFFIX}-notify>=0.1.1_9:${PORTSDIR}/devel/py-notify \
py${PYTHON_SUFFIX}-vte>=0.26.2_1:${PORTSDIR}/x11-toolkits/py-vte \
py${PYTHON_SUFFIX}-xdg>=0.19:${PORTSDIR}/devel/py-xdg
@@ -23,47 +21,51 @@ RUN_DEPENDS= py${PYTHON_SUFFIX}-dbus>=0.84.0:${PORTSDIR}/devel/py-dbus \
py${PYTHON_SUFFIX}-xdg>=0.19:${PORTSDIR}/devel/py-xdg
CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-#GH_ACCOUNT= Guake
-#GH_TAGNAME= ${PORTVERSION:R}
-#GH_COMMIT= 88af26c
GCONF_SCHEMAS= guake.schemas
+GH_ACCOUNT= Guake
+GH_COMMIT= aaa3e45
+GH_TAGNAME= ${PORTVERSION}
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
+LIBS+= -L${LOCALBASE}/lib
+
+MANPAGES_MAKE_ENV_OFF= man_MANS=""
+
NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext
+#NLS_USES= gettext
OPTIONS_DEFINE= MANPAGES NLS
OPTIONS_DEFAULT= MANPAGES
-OPTIONS_SUB= MANPAGES NLS
+OPTIONS_SUB= NLS
PLIST_SUB+= DESKTOPDIR="${DESKTOPDIR:S,${PREFIX}/,,}"
REINPLACE_ARGS= -e 's,/usr/bin/env python,&${PYTHON_VER},' -i.bak
REINPLACE_FILES= guake guake-prefs prefs.py
-#USE_GITHUB= yes
+USES= desktop-file-utils gettext gmake libtool pkgconfig python:2
+USE_AUTOTOOLS= autoconf:env automake:env libtoolize:env
+USE_GITHUB= yes
USE_GNOME= gtk20 pygnome2
-USES= desktop-file-utils gmake libtool pkgconfig python:2
-
-WRKSRC= ${WRKDIR}/${DISTNAME}
.include <bsd.port.options.mk>
-.if !${PORT_OPTIONS:MMANPAGES}
-MAKE_ENV+= man_MANS=""
-.endif
-
.if ! ${PORT_OPTIONS:MNLS}
REINPLACE_ARGS+= -e 's,\(USE_NLS=\)yes,\1no,'
-REINPLACE_FILES+= ../configure
+REINPLACE_FILES+= ../../configure
.endif
-post-patch:
- @cd ${WRKSRC}/src && ${REINPLACE_CMD} ${REINPLACE_FILES}
+pre-configure:
+ @(cd ${CONFIGURE_WRKSRC} ; ${SETENV} ${CONFIGURE_ENV} ./autogen.sh)
+
+post-configure:
+ @(cd ${WRKSRC}/src/guake ; ${REINPLACE_CMD} ${REINPLACE_FILES})
+
+post-build:
+ @${STRIP_CMD} ${WRKSRC}/src/guake/globalhotkeys/.libs/globalhotkeys.so
.include <bsd.port.pre.mk>
diff --git a/x11/guake/distinfo b/x11/guake/distinfo
index 3602707aa1aa..a19399386c89 100644
--- a/x11/guake/distinfo
+++ b/x11/guake/distinfo
@@ -1,2 +1,2 @@
-SHA256 (guake-0.4.4.tar.gz) = 1e1054ba6bbd79897bda0e1cd2b9df86082f7e794a0e07afc5cb63c0a5e74ca5
-SIZE (guake-0.4.4.tar.gz) = 549189
+SHA256 (guake-0.5.2.tar.gz) = 14546ca6166777ac5de7aaa04de69ceddc9a42efaba38d43a7f2bc02677887a6
+SIZE (guake-0.5.2.tar.gz) = 315525
diff --git a/x11/guake/files/patch-data_Makefile.am b/x11/guake/files/patch-data_Makefile.am
new file mode 100644
index 000000000000..820d79a9bf4e
--- /dev/null
+++ b/x11/guake/files/patch-data_Makefile.am
@@ -0,0 +1,10 @@
+--- data/Makefile.am.orig 2015-02-12 00:32:38 UTC
++++ data/Makefile.am
+@@ -1,6 +1,6 @@
+ SUBDIRS = pixmaps icons
+
+-man_MANS = guake.1
++man_MANS ?= guake.1
+
+ uidir = $(datadir)/guake
+ ui_DATA = \
diff --git a/x11/guake/files/patch-data__Makefile.in b/x11/guake/files/patch-data__Makefile.in
deleted file mode 100644
index 663dd2e43eb9..000000000000
--- a/x11/guake/files/patch-data__Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./data/Makefile.in.orig 2013-01-18 23:09:28.000000000 +0100
-+++ ./data/Makefile.in 2013-01-18 23:10:25.000000000 +0100
-@@ -316,7 +316,7 @@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
- SUBDIRS = pixmaps icons
--man_MANS = guake.1
-+man_MANS ?= guake.1
- uidir = $(datadir)/guake
- ui_DATA = \
- about.glade \
diff --git a/x11/guake/files/patch-data__guake-prefs.desktop.in b/x11/guake/files/patch-data__guake-prefs.desktop.in
index dc92dd95fbf1..ac85f257bfcc 100644
--- a/x11/guake/files/patch-data__guake-prefs.desktop.in
+++ b/x11/guake/files/patch-data__guake-prefs.desktop.in
@@ -1,5 +1,5 @@
---- ./data/guake-prefs.desktop.in.orig 2013-01-18 16:01:54.000000000 +0100
-+++ ./data/guake-prefs.desktop.in 2013-01-18 16:01:57.000000000 +0100
+--- data/guake-prefs.desktop.in.orig 2015-02-12 00:33:23 UTC
++++ data/guake-prefs.desktop.in
@@ -1,5 +1,4 @@
[Desktop Entry]
-Encoding=UTF-8
diff --git a/x11/guake/files/patch-data__guake.desktop.in b/x11/guake/files/patch-data__guake.desktop.in
index 3edd0dc39792..1fd1294ea013 100644
--- a/x11/guake/files/patch-data__guake.desktop.in
+++ b/x11/guake/files/patch-data__guake.desktop.in
@@ -1,5 +1,5 @@
---- ./data/guake.desktop.in.orig 2013-01-18 15:09:46.000000000 +0100
-+++ ./data/guake.desktop.in 2013-01-18 15:09:51.000000000 +0100
+--- data/guake.desktop.in.orig 2015-02-12 00:33:06 UTC
++++ data/guake.desktop.in
@@ -1,5 +1,4 @@
[Desktop Entry]
-Encoding=UTF-8
diff --git a/x11/guake/pkg-plist b/x11/guake/pkg-plist
index 486eb1d21427..254f2ef8fe07 100644
--- a/x11/guake/pkg-plist
+++ b/x11/guake/pkg-plist
@@ -1,39 +1,43 @@
bin/guake
bin/guake-prefs
-%%MANPAGES%%man/man1/guake.1.gz
-%%NLS%%share/locale/de/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/el/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/es/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/fa/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/it/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/no/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/guake.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/guake.mo
%%PYTHON_SITELIBDIR%%/guake/__init__.py
%%PYTHON_SITELIBDIR%%/guake/__init__.pyc
%%PYTHON_SITELIBDIR%%/guake/__init__.pyo
+%%PYTHON_SITELIBDIR%%/guake/about.py
+%%PYTHON_SITELIBDIR%%/guake/about.pyc
+%%PYTHON_SITELIBDIR%%/guake/about.pyo
%%PYTHON_SITELIBDIR%%/guake/common.py
%%PYTHON_SITELIBDIR%%/guake/common.pyc
%%PYTHON_SITELIBDIR%%/guake/common.pyo
%%PYTHON_SITELIBDIR%%/guake/dbusiface.py
%%PYTHON_SITELIBDIR%%/guake/dbusiface.pyc
%%PYTHON_SITELIBDIR%%/guake/dbusiface.pyo
+%%PYTHON_SITELIBDIR%%/guake/gconfhandler.py
+%%PYTHON_SITELIBDIR%%/guake/gconfhandler.pyc
+%%PYTHON_SITELIBDIR%%/guake/gconfhandler.pyo
%%PYTHON_SITELIBDIR%%/guake/globalhotkeys.a
%%PYTHON_SITELIBDIR%%/guake/globalhotkeys.so
%%PYTHON_SITELIBDIR%%/guake/globals.py
%%PYTHON_SITELIBDIR%%/guake/globals.pyc
%%PYTHON_SITELIBDIR%%/guake/globals.pyo
+%%PYTHON_SITELIBDIR%%/guake/guake_app.py
+%%PYTHON_SITELIBDIR%%/guake/guake_app.pyc
+%%PYTHON_SITELIBDIR%%/guake/guake_app.pyo
+%%PYTHON_SITELIBDIR%%/guake/main.py
+%%PYTHON_SITELIBDIR%%/guake/main.pyc
+%%PYTHON_SITELIBDIR%%/guake/main.pyo
+%%PYTHON_SITELIBDIR%%/guake/notifier.py
+%%PYTHON_SITELIBDIR%%/guake/notifier.pyc
+%%PYTHON_SITELIBDIR%%/guake/notifier.pyo
%%PYTHON_SITELIBDIR%%/guake/prefs.py
%%PYTHON_SITELIBDIR%%/guake/prefs.pyc
%%PYTHON_SITELIBDIR%%/guake/prefs.pyo
%%PYTHON_SITELIBDIR%%/guake/simplegladeapp.py
%%PYTHON_SITELIBDIR%%/guake/simplegladeapp.pyc
%%PYTHON_SITELIBDIR%%/guake/simplegladeapp.pyo
+%%PYTHON_SITELIBDIR%%/guake/terminal.py
+%%PYTHON_SITELIBDIR%%/guake/terminal.pyc
+%%PYTHON_SITELIBDIR%%/guake/terminal.pyo
%%DESKTOPDIR%%/guake-prefs.desktop
%%DESKTOPDIR%%/guake.desktop
share/dbus-1/services/org.guake.Guake.service
@@ -52,7 +56,31 @@ share/icons/hicolor/32x32/apps/guake-prefs.png
share/icons/hicolor/32x32/apps/guake.png
share/icons/hicolor/48x48/apps/guake-prefs.png
share/icons/hicolor/48x48/apps/guake.png
+%%NLS%%share/locale/ca/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/cs_CZ/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/de/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/el/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/es/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/id/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/it/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/nb_NO/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/uk_UA/LC_MESSAGES/guake.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/guake.mo
share/pixmaps/guake/add_tab.png
share/pixmaps/guake/guake-notification.png
share/pixmaps/guake/guake-tray.png
share/pixmaps/guake/guake.png
+share/pixmaps/guake/quick-open.png