aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2018-10-06 21:06:42 +0800
committerdes <des@FreeBSD.org>2018-10-06 21:06:42 +0800
commit091caf4661b26a5f70d9b8e0409821418f5afdbb (patch)
tree0721b637b4bcfc0a8ff2a945bdcb7e68f8993680 /x11
parenteb79e9b6a267227492e837fea536cf5c224c7a2d (diff)
downloadfreebsd-ports-gnome-091caf4661b26a5f70d9b8e0409821418f5afdbb.tar.gz
freebsd-ports-gnome-091caf4661b26a5f70d9b8e0409821418f5afdbb.tar.zst
freebsd-ports-gnome-091caf4661b26a5f70d9b8e0409821418f5afdbb.zip
Fix every instance of RUN_DEPENDS:=${BUILD_DEPENDS} in p5 ports, except
for where it resulted in a change in output from build-depends-list or run-depends-list. Approved by: portmgr (adamw)
Diffstat (limited to 'x11')
-rw-r--r--x11/p5-X11-IdleTime/Makefile4
-rw-r--r--x11/p5-X11-Protocol-Other/Makefile4
-rw-r--r--x11/p5-X11-XCB/Makefile4
-rw-r--r--x11/p5-X11-Xlib/Makefile4
-rw-r--r--x11/p5-XTerm-Conf/Makefile4
5 files changed, 10 insertions, 10 deletions
diff --git a/x11/p5-X11-IdleTime/Makefile b/x11/p5-X11-IdleTime/Makefile
index ca2935b04585..537cb295ddf4 100644
--- a/x11/p5-X11-IdleTime/Makefile
+++ b/x11/p5-X11-IdleTime/Makefile
@@ -13,9 +13,9 @@ COMMENT= Perl module that reports number of seconds that X11 has been idle
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Inline>=0.44:devel/p5-Inline \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Inline>=0.44:devel/p5-Inline \
p5-Inline-C>=0.44:devel/p5-Inline-C
-RUN_DEPENDS:= ${BUILD_DEPENDS}
MAKE_JOBS_UNSAFE= yes
USES= perl5
diff --git a/x11/p5-X11-Protocol-Other/Makefile b/x11/p5-X11-Protocol-Other/Makefile
index d2bb7c2e5286..9e4973e25846 100644
--- a/x11/p5-X11-Protocol-Other/Makefile
+++ b/x11/p5-X11-Protocol-Other/Makefile
@@ -13,8 +13,8 @@ COMMENT= Module for window manager related functions for use by client programs
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= p5-X11-Protocol>=0:x11/p5-X11-Protocol
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-X11-Protocol>=0:x11/p5-X11-Protocol
USES= perl5 shebangfix
USE_PERL5= configure
diff --git a/x11/p5-X11-XCB/Makefile b/x11/p5-X11-XCB/Makefile
index 48913f8b7dc0..96f4926ddebe 100644
--- a/x11/p5-X11-XCB/Makefile
+++ b/x11/p5-X11-XCB/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
LIB_DEPENDS= libxcb.so:x11/libxcb \
libxcb-util.so:x11/xcb-util \
libxcb-icccm.so:x11/xcb-util-wm
-BUILD_DEPENDS= \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= \
${LOCALBASE}/share/xcb/xcb.xsd:x11/xcb-proto \
p5-Data-Dump>=0:devel/p5-Data-Dump \
p5-Mouse>=0:devel/p5-Mouse \
@@ -29,7 +30,6 @@ BUILD_DEPENDS= \
p5-XML-Descent>=0:textproc/p5-XML-Descent \
p5-XML-Simple>=0:textproc/p5-XML-Simple \
p5-XS-Object-Magic>=0:devel/p5-XS-Object-Magic
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= localbase perl5
USE_PERL5= configure
diff --git a/x11/p5-X11-Xlib/Makefile b/x11/p5-X11-Xlib/Makefile
index b8482849bb63..67fd9de911d0 100644
--- a/x11/p5-X11-Xlib/Makefile
+++ b/x11/p5-X11-Xlib/Makefile
@@ -13,11 +13,11 @@ COMMENT= Low-level access to the X11 library
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Devel-CheckLib>=0:devel/p5-Devel-CheckLib \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Devel-CheckLib>=0:devel/p5-Devel-CheckLib \
p5-ExtUtils-Depends>=0:devel/p5-ExtUtils-Depends \
p5-Try-Tiny>=0:lang/p5-Try-Tiny
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_XORG= x11 xcomposite xext xfixes xinerama xorgproto xrender xtst
diff --git a/x11/p5-XTerm-Conf/Makefile b/x11/p5-XTerm-Conf/Makefile
index 93f653e37595..fbd369e3f398 100644
--- a/x11/p5-XTerm-Conf/Makefile
+++ b/x11/p5-XTerm-Conf/Makefile
@@ -13,8 +13,8 @@ COMMENT= Perl module that changes configuration of a running xterm
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Term-ReadKey>=2.32:devel/p5-Term-ReadKey
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Term-ReadKey>=2.32:devel/p5-Term-ReadKey
USES= perl5
USE_PERL5= configure