aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-10-10 22:03:00 +0800
committertijl <tijl@FreeBSD.org>2015-10-10 22:03:00 +0800
commit922a618b417843c8900f4076fc4d95620eefb493 (patch)
tree4ac25229c12e49e974a92ecd82e01b92eea15c00 /x11
parent8e2211c86ac31d36abaf0b6dbaadf26adb36f654 (diff)
downloadfreebsd-ports-gnome-922a618b417843c8900f4076fc4d95620eefb493.tar.gz
freebsd-ports-gnome-922a618b417843c8900f4076fc4d95620eefb493.tar.zst
freebsd-ports-gnome-922a618b417843c8900f4076fc4d95620eefb493.zip
Remove iconv(), iconv_open() and iconv_close() symbols from libiconv.
These were FreeBSD specific aliases for libiconv(), libiconv_open() and libiconv_close() that are now also provided by libc which complicates writing configure tests that work correctly when both libc iconv and libiconv are available. Also, because the libiconv iconv.h header redefines iconv* to libiconv* correct use of the header implies that the aliases aren't used. The following ports needed fixes because there was something wrong with the way they tried to detect or use iconv: audio/deadbeef: Remove LIBICONV_PLUG from a source file. It's a compile-time option and should not be set in source code. comms/hidapi: Use standard AM_ICONV configure macro to look for iconv. deskutils/fbreader: Let ports framework deal with LIBICONV_PLUG. deskutils/ljclive: Override configure test for iconv. deskutils/owncloudclient: Add USES=iconv and patch test for iconv. devel/aegis: Bump PORTREVISION because it no longer uses libiconv. devel/libexplain: Add USES=iconv and override test for iconv. devel/sdl20: Override configure test for iconv. emulators/vmw: Replace OSVERSION checks with ICONV_LIB checks and include <iconv.h> instead of <sys/iconv.h>. irc/scrollz: Override configure test for iconv. japanese/chasen-base: Override configure test for iconv and patch configure so it no longer adds -liconv to linker flags just because it happens to be installed. japanses/eb: Patch configure test for iconv. japanses/eblook: Override configure test for iconv. java/jikes: Override configure test for iconv. multimedia/transcode: Bump PORTREVISION because only one plugin links with libiconv now. net/c3270: Override configure test for iconv. net/samba4*: Bump PORTREVISION because it no longer uses libiconv. The configure script will always add -liconv to the linker flags when it happens to be installed which would be wrong but later on binaries are linked with -Wl,--as-needed and the linker discards -liconv because it finds iconv*() functions in libc now and no longer in libiconv. net-mgmt/icinga-*: Remove dependency on iconv. net-mgmt/netxms: Patch configure so it no longer adds -liconv to linker flags just because it happens to be installed. net/asterisk11: Patch configure so it no longer adds -liconv to linker flags just because it happens to be installed. net-p2p/transmission-*: Override configure test for iconv. www/htmlcxx: Override configure test for iconv. www/httrack: Override configure test for iconv. www/xapian-omega: Override configure test for iconv. x11/mrxvt(-devel): Add USES=iconv and override configure test for iconv. x11/x3270: Override configure test for iconv. x11-wm/jwm: Override configure test for iconv. PR: 202838 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'x11')
-rw-r--r--x11/mrxvt-devel/Makefile16
-rw-r--r--x11/mrxvt/Makefile25
-rw-r--r--x11/x3270/Makefile2
3 files changed, 32 insertions, 11 deletions
diff --git a/x11/mrxvt-devel/Makefile b/x11/mrxvt-devel/Makefile
index 6f66cbc5a854..fe7418742b17 100644
--- a/x11/mrxvt-devel/Makefile
+++ b/x11/mrxvt-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mrxvt-devel
PORTVERSION= 0.5.4
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= x11
MASTER_SITES= SF/materm/mrxvt%20source/${PORTVERSION}
DISTNAME= mrxvt-${PORTVERSION}
@@ -54,6 +54,10 @@ USE_XORG+= xft
CONFIGURE_ARGS+= --enable-xft
.endif
+.if ${PORT_OPTIONS:MXFT} && ${PORT_OPTIONS:MJAPANESE}
+USES+= iconv
+.endif
+
.if ${PORT_OPTIONS:M24BITS}
CONFIGURE_ARGS+= --enable-24bits
.endif
@@ -120,6 +124,14 @@ CONFIGURE_ARGS+= --with-atab-extra=${EXTRA_ATAB_HEIGHT:M[0-9]*}
CONFIGURE_ARGS+= --with-tab-radius=${TAB_RADIUS:M[0-9]*}
.endif
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=no
+.else
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=yes
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/mrxvt ${STAGEDIR}${PREFIX}/bin
@for pixmap in ${WRKSRC}/share/pixmaps/* ; \
@@ -137,4 +149,4 @@ do-install:
${CP} ${WRKSRC}/doc/*.bz2 ${STAGEDIR}${DOCSDIR}
${BZIP2_CMD} -d ${STAGEDIR}${DOCSDIR}/*.bz2
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/mrxvt/Makefile b/x11/mrxvt/Makefile
index 189bbb58be58..dd6d987d5d6f 100644
--- a/x11/mrxvt/Makefile
+++ b/x11/mrxvt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mrxvt
PORTVERSION= 0.4.2
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= x11
MASTER_SITES= SF/materm/${PORTNAME}%20source/${PORTVERSION}
@@ -16,6 +16,8 @@ CONFLICTS= mrxvt-0.5.*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-lastlog --disable-wtmp
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
USES= jpeg tar:tgz
USE_XORG= x11
@@ -25,9 +27,6 @@ JAPANESE_CONFIGURE_ON= --enable-xim --enable-cjk --with-encoding=eucj
XFT_LIB_DEPENDS= libXft.so:${PORTSDIR}/x11-fonts/libXft
XFT_CONFIGURE_ENABLE= xft
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-
PORTDOCS= TIPS \
README.greek \
README.menu \
@@ -37,11 +36,21 @@ PORTDOCS= TIPS \
mrxvt.vbs \
mrxvtset.pl
-post-patch-DOCS-off:
- @${REINPLACE_CMD} -e '/^\(install-data-am:\).*/ \
- s/install-docDATA //' ${WRKSRC}/doc/Makefile.in
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MXFT} && ${PORT_OPTIONS:MJAPANESE}
+USES+= iconv
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if empty(ICONV_LIB)
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=no
+.else
+CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=yes
+.endif
post-install:
${CHMOD} 4511 ${STAGEDIR}${PREFIX}/bin/mrxvt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/x3270/Makefile b/x11/x3270/Makefile
index 07355b23161d..0c95b27e9781 100644
--- a/x11/x3270/Makefile
+++ b/x11/x3270/Makefile
@@ -23,7 +23,7 @@ USE_XORG= ice sm x11 xaw xext xmu xt
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-fontdir=${FONTSDIR} \
--disable-dbcs \
- ac_cv_search_libiconv=no
+ ac_cv_search_libiconv=${ICONV_LIB}
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
.if defined(WITHOUT_OPENSSL)