aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-05-24 23:42:43 +0800
committerdanfe <danfe@FreeBSD.org>2005-05-24 23:42:43 +0800
commit960227b53b614122a7fbe8a2179cc46bdf9568bc (patch)
tree54008f26050b3a0e6920f97840700212bdbd2d79 /x11
parent535bdf6a020c7db54636f77720ce6a45d12b78c7 (diff)
downloadfreebsd-ports-gnome-960227b53b614122a7fbe8a2179cc46bdf9568bc.tar.gz
freebsd-ports-gnome-960227b53b614122a7fbe8a2179cc46bdf9568bc.tar.zst
freebsd-ports-gnome-960227b53b614122a7fbe8a2179cc46bdf9568bc.zip
- Convert to OPTIONS
- Fix 6113-case of extra patching
Diffstat (limited to 'x11')
-rw-r--r--x11/nvidia-driver/Makefile21
1 files changed, 6 insertions, 15 deletions
diff --git a/x11/nvidia-driver/Makefile b/x11/nvidia-driver/Makefile
index 8089efc9d830..f2576c875f19 100644
--- a/x11/nvidia-driver/Makefile
+++ b/x11/nvidia-driver/Makefile
@@ -24,6 +24,11 @@ USE_X_PREFIX= yes
NO_PACKAGE= should be recompiled for a particular FreeBSD kernel
INSTALLS_SHLIB= yes
+OPTIONS= FREEBSD_AGP "Use FreeBSD AGP GART driver" off \
+ VM86_INT10CALL "Use VM86 interface for video BIOS calls" off \
+ ACPI "Enable support for ACPI Power Management" off \
+ LINUX "Build with support for Linux compatibility" on
+
.include <bsd.port.pre.mk>
# Newer releases from NVidia do not play nicely with FreeBSD prior to 5.3.
@@ -34,7 +39,7 @@ INSTALLS_SHLIB= yes
.if ${OSVERSION} < 503000
NVVERSION= 6113
PORTREVISION= 4
-EXTRA_PATCHES+= 6113-patch-src::nvidia_pci.c
+EXTRA_PATCHES+= ${FILESDIR}/6113-patch-src::nvidia_pci.c
PLIST_SUB+= DIFFS=""
.else
NVVERSION= 7174
@@ -67,20 +72,6 @@ PLIST_SUB+= FREEBSD5="@comment " FREEBSD4=""
PLIST_SUB+= FREEBSD5="" FREEBSD4="@comment "
.endif
-pre-everything::
-.if !defined(WITH_FREEBSD_AGP)
- @${ECHO_MSG} "Define WITH_FREEBSD_AGP to use FreeBSD AGP GART driver"
-.endif
-.if !defined(WITH_VM86_INT10CALL)
- @${ECHO_MSG} "Define WITH_VM86_INT10CALL to use VM86 interface for INT10 calls (video BIOS)"
-.endif
-.if !defined(WITH_ACPI)
- @${ECHO_MSG} "Define WITH_ACPI to enable support for ACPI Power Management (5.x/6.x only!)"
-.endif
-.if !defined(WITHOUT_LINUX)
- @${ECHO_MSG} "Define WITHOUT_LINUX to build without support for Linux compatibility"
-.endif
-
post-patch: .SILENT
# We should support -CURRENT: kill the check
.if ${NVVERSION} == 7174