aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/addrwatch/Makefile28
-rw-r--r--net/addrwatch/distinfo3
-rw-r--r--net/addrwatch/pkg-descr11
4 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 9043af582e6d..3dc6c23b2409 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -10,6 +10,7 @@
SUBDIR += Sockets
SUBDIR += activemq
SUBDIR += adasockets
+ SUBDIR += addrwatch
SUBDIR += afpfs-ng
SUBDIR += aget
SUBDIR += akonadi-calendar
diff --git a/net/addrwatch/Makefile b/net/addrwatch/Makefile
new file mode 100644
index 000000000000..cf579660cba0
--- /dev/null
+++ b/net/addrwatch/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= addrwatch
+DISTVERSIONPREFIX=v
+DISTVERSION= 1.0.2
+CATEGORIES= net
+
+MAINTAINER= m.muenz@gmail.com
+COMMENT= Supports IP/Ethernet pairing for IPv4 and IPv6
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libevent.so:devel/libevent \
+ libpcap.so:net/libpcap \
+ libargp.so:devel/argp-standalone
+
+USES= autoreconf gmake pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_GITHUB= yes
+GH_ACCOUNT= fln
+
+PLIST_FILES= bin/addrwatch \
+ bin/addrwatch_stdout \
+ bin/addrwatch_syslog \
+ man/man8/addrwatch.8.gz
+
+.include <bsd.port.mk>
diff --git a/net/addrwatch/distinfo b/net/addrwatch/distinfo
new file mode 100644
index 000000000000..6d1bc7101cde
--- /dev/null
+++ b/net/addrwatch/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1582621254
+SHA256 (fln-addrwatch-v1.0.2_GH0.tar.gz) = 56a2180305e95adde584bd9502771269b9a216419b49631046b368502d5d5fba
+SIZE (fln-addrwatch-v1.0.2_GH0.tar.gz) = 44584
diff --git a/net/addrwatch/pkg-descr b/net/addrwatch/pkg-descr
new file mode 100644
index 000000000000..449d7168cb14
--- /dev/null
+++ b/net/addrwatch/pkg-descr
@@ -0,0 +1,11 @@
+addrwatch is a similar software to arpwatch. It main purpose is to
+monitor network and log ethernet/ip pairings.
+
+To simply try out addrwatch start it without any arguments. When
+started without arguments it will open first non loopback interface and
+start logging events to the console without writing anything to disk.
+All discovered ethernet/ip address pairings will be printed to stdout.
+All debug, warning, and err messages will be sent to syslog and printed
+to stderr.
+
+WWW: https://github.com/fln/addrwatch