aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-net-ssh-gateway1/Makefile22
-rw-r--r--security/rubygem-net-ssh-gateway1/distinfo2
-rw-r--r--security/rubygem-net-ssh-gateway1/pkg-descr10
4 files changed, 35 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 078546aa8bd0..d0bd1fbc357c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1021,6 +1021,7 @@
SUBDIR += rubygem-net-sftp
SUBDIR += rubygem-net-ssh
SUBDIR += rubygem-net-ssh-gateway
+ SUBDIR += rubygem-net-ssh-gateway1
SUBDIR += rubygem-net-ssh-multi
SUBDIR += rubygem-net-telnet
SUBDIR += rubygem-nexpose
diff --git a/security/rubygem-net-ssh-gateway1/Makefile b/security/rubygem-net-ssh-gateway1/Makefile
new file mode 100644
index 000000000000..ddb0a420f654
--- /dev/null
+++ b/security/rubygem-net-ssh-gateway1/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= net-ssh-gateway
+PORTVERSION= 1.2.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 1
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Establish Net::SSH connections through firewalls
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-net-ssh>=2.6.5:security/rubygem-net-ssh
+
+PORTSCOUT= limit:^1\.
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-net-ssh-gateway1/distinfo b/security/rubygem-net-ssh-gateway1/distinfo
new file mode 100644
index 000000000000..42f32eaeb647
--- /dev/null
+++ b/security/rubygem-net-ssh-gateway1/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/net-ssh-gateway-1.2.0.gem) = 3e5ab1f9d20e44c838ee890d1ae5c756b4b9cec492bc717340d90869399113db
+SIZE (rubygem/net-ssh-gateway-1.2.0.gem) = 23552
diff --git a/security/rubygem-net-ssh-gateway1/pkg-descr b/security/rubygem-net-ssh-gateway1/pkg-descr
new file mode 100644
index 000000000000..714b605d5015
--- /dev/null
+++ b/security/rubygem-net-ssh-gateway1/pkg-descr
@@ -0,0 +1,10 @@
+Net::SSH::Gateway is a library for programmatically tunneling connections to
+servers via a single "gateway" host. It is useful for establishing Net::SSH
+connections to servers behind firewalls, but can also be used to forward ports
+and establish connections of other types, like HTTP, to servers with i
+restricted access.
+
+* Easily manage forwarded ports
+* Establish Net::SSH connections through firewalls
+
+WWW: https://github.com/net-ssh/net-scp