aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-p2p/twister/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net-p2p/twister/Makefile b/net-p2p/twister/Makefile
index d1635785bb9b..04e61dcd7161 100644
--- a/net-p2p/twister/Makefile
+++ b/net-p2p/twister/Makefile
@@ -27,7 +27,7 @@ GH_TAGNAME= v${PORTVERSION}
USE_BDB= yes
WANT_BDB_VER= 48
USE_OPENSSL= yes
-USES= autoreconf gmake iconv libtool
+USES= autoreconf:build gmake iconv libtool
GNU_CONFIGURE= yes
CONFIGURE_WRKSRC=${WRKSRC}/libtorrent
@@ -55,6 +55,9 @@ post-patch:
@${REINPLACE_CMD} 's|%%PORTVERSION%%|${PORTVERSION}|' \
${WRKSRC}/share/genbuild.sh
+pre-configure:
+ (cd ${WRKSRC} && ./autotool.sh)
+
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/twisterd ${STAGEDIR}${PREFIX}/bin
.if ${PORT_OPTIONS:MDOCS}