aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--accessibility/accerciser/Makefile3
-rw-r--r--accessibility/at-spi/Makefile3
-rw-r--r--accessibility/orca/Makefile3
-rw-r--r--accessibility/py-atspi/Makefile3
-rw-r--r--archivers/py-liblzma/Makefile6
-rw-r--r--archivers/py-lzma/Makefile8
-rw-r--r--archivers/rox-archive/Makefile3
-rw-r--r--astro/astrometry/Makefile3
-rw-r--r--astro/py-aipy/Makefile5
-rw-r--r--astro/pyephem/Makefile5
-rw-r--r--astro/pyweather/Makefile2
11 files changed, 16 insertions, 28 deletions
diff --git a/accessibility/accerciser/Makefile b/accessibility/accerciser/Makefile
index 61d39ddc9455..408e4443d68c 100644
--- a/accessibility/accerciser/Makefile
+++ b/accessibility/accerciser/Makefile
@@ -13,8 +13,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Interactive Python accessibility explorer for GNOME
USE_GNOME= pygnomedesktop atspi intlhack
-USE_PYTHON= 2
-USES= display:configure gettext gmake pkgconfig tar:bzip2
+USES= display:configure gettext gmake pkgconfig python:2 tar:bzip2
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
diff --git a/accessibility/at-spi/Makefile b/accessibility/at-spi/Makefile
index c96a5932b7c2..50fbbf5f8739 100644
--- a/accessibility/at-spi/Makefile
+++ b/accessibility/at-spi/Makefile
@@ -18,10 +18,9 @@ USES+= tar:bzip2
RUN_DEPENDS= at-spi2-atk>2.6.0:${PORTSDIR}/accessibility/at-spi2-atk
-USES+= gmake gettext libtool:oldver pathfix pkgconfig
+USES+= gmake gettext libtool:oldver pathfix pkgconfig python:2
USE_GNOME= gnomehier intlhack gtk20 gconf2 libbonobo
USE_XORG= x11 xtst
-USE_PYTHON= 2
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static
diff --git a/accessibility/orca/Makefile b/accessibility/orca/Makefile
index 36c60b0dd2bc..45ab9fcf8587 100644
--- a/accessibility/orca/Makefile
+++ b/accessibility/orca/Makefile
@@ -20,8 +20,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_dbus_bindings.so:${PORTSDIR}/devel/py-dbus \
${PYTHON_SITELIBDIR}/pyatspi/__init__.py:${PORTSDIR}/accessibility/at-spi \
${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
-USES= gmake gettext pkgconfig tar:bzip2
-USE_PYTHON= 2
+USES= gmake gettext pkgconfig python:2 tar:bzip2
USE_GNOME= gnomeprefix libgnomeui gnomespeech pygnome2 \
pygnomedesktop
INSTALLS_ICONS= yes
diff --git a/accessibility/py-atspi/Makefile b/accessibility/py-atspi/Makefile
index b656bb1087d1..350af03b88ff 100644
--- a/accessibility/py-atspi/Makefile
+++ b/accessibility/py-atspi/Makefile
@@ -18,10 +18,9 @@ RUN_DEPENDS= ${LOCALBASE}/libexec/at-spi2-registryd:${PORTSDIR}/accessibility/at
CONFLICTS= at-spi-1.[0-9]*
-USES= gettext gmake pathfix pkgconfig tar:xz
+USES= gettext gmake pathfix pkgconfig python:2 tar:xz
USE_GNOME= gnomehier intlhack pygobject3
GNU_CONFIGURE= yes
-USE_PYTHON= 2
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/archivers/py-liblzma/Makefile b/archivers/py-liblzma/Makefile
index 58a374e12591..0dd30918e58a 100644
--- a/archivers/py-liblzma/Makefile
+++ b/archivers/py-liblzma/Makefile
@@ -15,10 +15,8 @@ COMMENT= Python binding for the LZMA compression library
LICENSE= LGPL3
-USES= pkgconfig tar:bzip2
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= pkgconfig python tar:bzip2
+USE_PYTHON= distutils autoplist
post-patch:
@${REINPLACE_CMD} -e 's/pc_cflags = .*/pc_cflags = ""/' \
diff --git a/archivers/py-lzma/Makefile b/archivers/py-lzma/Makefile
index 1db404ce5a1f..72488c31b8d2 100644
--- a/archivers/py-lzma/Makefile
+++ b/archivers/py-lzma/Makefile
@@ -16,12 +16,10 @@ LICENSE= LGPL21
ONLY_FOR_ARCHS= i386
-USES= dos2unix
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= dos2unix python
+USE_PYTHON= distutils autoplist
-DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/${PYTHON_PKGNAMEPREFIX}${PORTNAME}
PORTDOCS= usage.txt
diff --git a/archivers/rox-archive/Makefile b/archivers/rox-archive/Makefile
index 6d33baaedbb2..c6ea456d2b26 100644
--- a/archivers/rox-archive/Makefile
+++ b/archivers/rox-archive/Makefile
@@ -12,8 +12,7 @@ COMMENT= Archive management tool for the ROX desktop
RUN_DEPENDS= ${LOCALBASE}/bin/rox:${PORTSDIR}/x11-fm/rox-filer \
${LOCALBASE}/lib/ROX-Lib2/python/rox/__init__.py:${PORTSDIR}/devel/py-roxlib
-USES= tar:bzip2
-USE_PYTHON= yes
+USES= python tar:bzip2
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index 7eaf91e8b6b4..16b39b7291aa 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -19,8 +19,7 @@ LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
libnetpbm.so:${PORTSDIR}/graphics/netpbm
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= gmake pkgconfig tar:bzip2
-USE_PYTHON= yes
+USES= gmake pkgconfig python tar:bzip2
ALL_TARGET= all extra
MAKE_ENV= INSTALL_DIR=${STAGEDIR}${PREFIX}/${PORTNAME}
MAKE_JOBS_UNSAFE= yes
diff --git a/astro/py-aipy/Makefile b/astro/py-aipy/Makefile
index ae51ffd1e672..d63e2d0b02f6 100644
--- a/astro/py-aipy/Makefile
+++ b/astro/py-aipy/Makefile
@@ -17,8 +17,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PKGNAMEPREFIX}matplotlib>=0.98:${PORTSDIR}/math/py-matplotlib
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/astro/pyephem/Makefile b/astro/pyephem/Makefile
index 5f56990264e2..a8597dac0d9b 100644
--- a/astro/pyephem/Makefile
+++ b/astro/pyephem/Makefile
@@ -10,8 +10,7 @@ MASTER_SITES= CHEESESHOP
MAINTAINER= wen@FreeBSD.org
COMMENT= Scientific-grade astronomical computations for Python
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/astro/pyweather/Makefile b/astro/pyweather/Makefile
index eef19bd45080..2d2997585767 100644
--- a/astro/pyweather/Makefile
+++ b/astro/pyweather/Makefile
@@ -10,7 +10,7 @@ DISTNAME= pyWeather
MAINTAINER= ports@FreeBSD.org
COMMENT= Python script that downloads weather data and can be cronned
-USE_PYTHON= yes
+USES= python
NO_BUILD= yes
PLIST_FILES= bin/pyWeather