aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-pywatchman/Makefile23
-rw-r--r--sysutils/py-pywatchman/distinfo2
-rw-r--r--sysutils/py-pywatchman/pkg-descr3
4 files changed, 29 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 9f41610f5346..6b7e810f4704 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -798,6 +798,7 @@
SUBDIR += py-psutil121
SUBDIR += py-ptyprocess
SUBDIR += py-pytsk
+ SUBDIR += py-pywatchman
SUBDIR += py-queuelib
SUBDIR += py-ranger
SUBDIR += py-salt
diff --git a/sysutils/py-pywatchman/Makefile b/sysutils/py-pywatchman/Makefile
new file mode 100644
index 000000000000..35519dfa0dc6
--- /dev/null
+++ b/sysutils/py-pywatchman/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= pywatchman
+PORTVERSION= 1.3.0
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= linpct@gmail.com
+COMMENT= Watchman client for Python
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= watchman>=4:${PORTSDIR}/sysutils/watchman
+
+USES= python:2
+USE_PYTHON= autoplist distutils
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} \
+ -name '*.so' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-pywatchman/distinfo b/sysutils/py-pywatchman/distinfo
new file mode 100644
index 000000000000..9a08befc5e63
--- /dev/null
+++ b/sysutils/py-pywatchman/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pywatchman-1.3.0.tar.gz) = c3d5be183b5b04f6ad575fc71b06dd196185dea1558d9f4d0598ba9beaab8245
+SIZE (pywatchman-1.3.0.tar.gz) = 16873
diff --git a/sysutils/py-pywatchman/pkg-descr b/sysutils/py-pywatchman/pkg-descr
new file mode 100644
index 000000000000..6f9a6175164c
--- /dev/null
+++ b/sysutils/py-pywatchman/pkg-descr
@@ -0,0 +1,3 @@
+Connect and query Watchman to discover file changes.
+
+WWW: https://pypi.python.org/pypi/pywatchman