aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Geometry-Planar/Makefile32
-rw-r--r--math/p5-Math-Geometry-Planar/distinfo3
-rw-r--r--math/p5-Math-Geometry-Planar/pkg-descr4
-rw-r--r--math/p5-Math-Geometry-Planar/pkg-plist7
5 files changed, 47 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index a1b7f0559881..e92ba20a5dbf 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -179,6 +179,7 @@
SUBDIR += p5-Math-FixedPrecision
SUBDIR += p5-Math-GMP
SUBDIR += p5-Math-GSL
+ SUBDIR += p5-Math-Geometry-Planar
SUBDIR += p5-Math-Geometry-Planar-GPC
SUBDIR += p5-Math-Geometry-Planar-Offset
SUBDIR += p5-Math-Interpolate
diff --git a/math/p5-Math-Geometry-Planar/Makefile b/math/p5-Math-Geometry-Planar/Makefile
new file mode 100644
index 000000000000..db11b38e03ed
--- /dev/null
+++ b/math/p5-Math-Geometry-Planar/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Math-Geometry-Planar
+# Date created: 21 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Geometry-Planar
+PORTVERSION= 1.16
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A collection of planar geometry functions
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Math/Geometry/Planar/GPC.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-GPC \
+ ${SITE_PERL}/Math/Geometry/Planar/Offset.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-Offset
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::Geometry::Planar.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Geometry-Planar/distinfo b/math/p5-Math-Geometry-Planar/distinfo
new file mode 100644
index 000000000000..2ca7d1532225
--- /dev/null
+++ b/math/p5-Math-Geometry-Planar/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Geometry-Planar-1.16.tar.gz) = cc83a49359c4ec7ca6136257282cf668
+SHA256 (Math-Geometry-Planar-1.16.tar.gz) = 7aed1b456d4fb4fc9315031e2fdb2913afd720d6bc69fa295892573eaacad673
+SIZE (Math-Geometry-Planar-1.16.tar.gz) = 32304
diff --git a/math/p5-Math-Geometry-Planar/pkg-descr b/math/p5-Math-Geometry-Planar/pkg-descr
new file mode 100644
index 000000000000..0cd63c35dc6d
--- /dev/null
+++ b/math/p5-Math-Geometry-Planar/pkg-descr
@@ -0,0 +1,4 @@
+A collection of planar geometry functions
+
+WWW: http://search.cpan.org/dist/Math-Geometry-Planar
+Author: Danny Van de Pol <daniel.van_de_pol@alcatel.be>
diff --git a/math/p5-Math-Geometry-Planar/pkg-plist b/math/p5-Math-Geometry-Planar/pkg-plist
new file mode 100644
index 000000000000..2cd62773c6b5
--- /dev/null
+++ b/math/p5-Math-Geometry-Planar/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Math/Geometry/Planar.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Geometry/Planar/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Geometry/Planar
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Geometry
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math/Geometry
+@dirrmtry %%SITE_PERL%%/Math