aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/png/Makefile7
-rw-r--r--print/ghostscript-gnu/Makefile2
-rw-r--r--print/ghostscript5/Makefile2
-rw-r--r--print/ghostscript55/Makefile2
-rw-r--r--print/ghostscript7/Makefile2
5 files changed, 8 insertions, 7 deletions
diff --git a/graphics/png/Makefile b/graphics/png/Makefile
index 0e3a9046f332..367e46fe9e16 100644
--- a/graphics/png/Makefile
+++ b/graphics/png/Makefile
@@ -5,8 +5,6 @@
#
# $FreeBSD$
#
-# PLEASE update print/ghostscript5 (there's a symlink that uses a hardwired
-# png version number) when updating this port. Thank you.
PORTNAME= png
PORTVERSION= 1.0.8
@@ -36,8 +34,11 @@ MAN5= png.5
MAKE_ENV+= USE_MMX=yes
.endif
-.if !defined(WITH_MMX) && (${ARCH} == "i386")
post-extract:
+# Please don't delete the following line - this link used by ghostscript* ports
+ @${LN} -sf ${WRKSRC} ${WRKDIR}/libpng
+#
+.if !defined(WITH_MMX) && (${ARCH} == "i386")
@${ECHO_MSG}
@${ECHO_MSG} " If you have a CPU with MMX instruction set (Pentium/P55C and higher) you can"
@${ECHO_MSG} " try to add \"-DWITH_MMX\" to build libpng with MMX-optimized assembler routines."
diff --git a/print/ghostscript-gnu/Makefile b/print/ghostscript-gnu/Makefile
index 3b009132e9fc..016ebd6893d5 100644
--- a/print/ghostscript-gnu/Makefile
+++ b/print/ghostscript-gnu/Makefile
@@ -55,7 +55,7 @@ pre-fetch:
post-extract:
${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/jpeg/work/jpeg-6b ${WRKSRC}/jpeg
- ${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/png/work/libpng-* ${WRKSRC}/libpng
+ ${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/png/work/libpng ${WRKSRC}/libpng
${MV} ${WRKSRC}/devs.mak ${WRKSRC}/devs.mak.bak
cd ${WRKSRC} && unzip -Lao ${DISTDIR}/${HP850_DRV}
${MV} ${WRKSRC}/devs.mak.bak ${WRKSRC}/devs.mak
diff --git a/print/ghostscript5/Makefile b/print/ghostscript5/Makefile
index 92e6e52b858b..234a2e97175e 100644
--- a/print/ghostscript5/Makefile
+++ b/print/ghostscript5/Makefile
@@ -36,7 +36,7 @@ PCL3_DRV= hpdj-2.6.tar.gz
post-extract:
${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/jpeg/work/jpeg-6b ${WRKSRC}/jpeg
- ${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/png/work/libpng-1.0.7 ${WRKSRC}/libpng
+ ${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/png/work/libpng ${WRKSRC}/libpng
# additional PCL3 driver
@${TAR} -xf ${WRKDIR}/hpdj-2.6/hpdj.tar -C ${WRKSRC}
@${CAT} ${WRKSRC}/devs.mak-5.10.add >> ${WRKSRC}/devs.mak
diff --git a/print/ghostscript55/Makefile b/print/ghostscript55/Makefile
index 3b009132e9fc..016ebd6893d5 100644
--- a/print/ghostscript55/Makefile
+++ b/print/ghostscript55/Makefile
@@ -55,7 +55,7 @@ pre-fetch:
post-extract:
${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/jpeg/work/jpeg-6b ${WRKSRC}/jpeg
- ${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/png/work/libpng-* ${WRKSRC}/libpng
+ ${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/png/work/libpng ${WRKSRC}/libpng
${MV} ${WRKSRC}/devs.mak ${WRKSRC}/devs.mak.bak
cd ${WRKSRC} && unzip -Lao ${DISTDIR}/${HP850_DRV}
${MV} ${WRKSRC}/devs.mak.bak ${WRKSRC}/devs.mak
diff --git a/print/ghostscript7/Makefile b/print/ghostscript7/Makefile
index 3b009132e9fc..016ebd6893d5 100644
--- a/print/ghostscript7/Makefile
+++ b/print/ghostscript7/Makefile
@@ -55,7 +55,7 @@ pre-fetch:
post-extract:
${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/jpeg/work/jpeg-6b ${WRKSRC}/jpeg
- ${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/png/work/libpng-* ${WRKSRC}/libpng
+ ${LN} -s ${WRKDIRPREFIX}${.CURDIR}/../../graphics/png/work/libpng ${WRKSRC}/libpng
${MV} ${WRKSRC}/devs.mak ${WRKSRC}/devs.mak.bak
cd ${WRKSRC} && unzip -Lao ${DISTDIR}/${HP850_DRV}
${MV} ${WRKSRC}/devs.mak.bak ${WRKSRC}/devs.mak
3_9_90&id=99d492b8284fa467f2b8ad3e6b637e10258d1cc2'>Adapt to CamelSession and e-passwords changes.Matthew Barnes2011-07-043-8/+8 * Do not use deprecated EBook/ECal APIMilan Crha2011-06-142-42/+63 * Including <glib.h> directly is rarely needed.Matthew Barnes2011-05-281-1/+0 * Bug #646109 - Fix use of include <config.h> to make sure translations workMilan Crha2011-05-274-0/+16 * Coding style cleanups.Matthew Barnes2011-05-091-11/+11 * Bug #641939 - [publish-calendar] Doesn't read online state on startMilan Crha2011-03-093-2/+34 * Drop backward-compatibility cruft.Matthew Barnes2011-01-251-6/+0 * Bug 632903 - Support libnotify-0.7Flo Gravo2010-10-231-2/+6 * Bug 632641 - Handle combo box text API going awayMatthias Clasen2010-10-211-1/+4 * Bug #629737 - [publish-calendar] Could not find widget 'file_label'Milan Crha2010-09-221-1/+1 * Coding style cleanups.Matthew Barnes2010-09-132-31/+31 * Re-work my GtkDialog:has-separator workaround.Matthew Barnes2010-09-111-2/+2 * Work around deprecation of gtk_dialog_set_has_separator()Matthew Barnes2010-09-111-0/+2 * Coding style and whitespace cleanup.Matthew Barnes2010-07-121-3/+8 * Giant leap towards GSEAL compliance.Matthew Barnes2010-04-081-5/+3 * Generate ChangeLog files for tarball releases.Matthew Barnes2010-04-031-316/+0 * Work around recent GTK+ deprecations.Matthew Barnes2010-03-051-0/+4 * Make authentication functionality availableGustavo Noronha Silva2010-01-272-2/+2 * Remove dead assignments found by clang.Matthew Barnes2010-01-161-2/+0 * Compiler and linker flag cleanups.Matthew Barnes2009-12-281-1/+5 * Bug #604512 - Calendar publishing tab misses button labelMilan Crha2009-12-151-4/+6 * Bug #604182 - Hide variable used only with HAVE_LIBNOTIFYMilan Crha2009-12-111-0/+2 * Bug #591938 - Update translator's commentsMilan Crha2009-12-101-1/+5 * Bug #604182 - Do not block UI with publish-calendar messagesMilan Crha2009-12-101-6/+113 * Remove markup from translatable strings in ui filesClaude Paroz2009-11-171-8/+16 * Bug 589153 - Use GtkBuilder instead of libgladeMatthew Barnes2009-11-176-1305/+847 * Bug #329710 - [PublishCal] 'Enable' button should update on changeMilan Crha2009-10-151-13/+19 * Bug 596848 - Use per-target CPPFLAGS in automake filesH.Habighorst2009-10-011-9/+10 * Bug 594284 - FTBFS: missing linksDiego Escalante Urrelo2009-09-061-0/+1 * Get the publish-calendar plugin working.Milan Crha2009-09-024-50/+67 * Bug #317290 - [Publish-Calendar] Cancel setup should cancelMilan Crha2009-07-303-21/+27 * Compiler warning fixes (as part of bug #424078)Milan Crha2009-07-281-1/+1 * More whitespace cleanup.Matthew Barnes2009-07-191-3/+3 * Version check for the deprecation workaround was off by one.Matthew Barnes2009-07-141-2/+2 * Work around deprecation of g_mount_unmount().Matthew Barnes2009-07-141-0/+8 * Fix excessive whitespace.Matthew Barnes2009-07-131-1/+0 * Use AM_CPPFLAGS instead of INCLUDE in all Makefile.am.Matthew Barnes2009-07-011-1/+1 * Stop abusing forward declarations.Matthew Barnes2009-06-191-0/+1 * Leak a bit less. Use proper function prototype.Milan Crha2009-06-151-1/+3 * More code cleanup.Matthew Barnes2009-06-021-1/+1 * Whitespace cleanup.Matthew Barnes2009-05-291-3/+3 * Prefer GLib basic types over C types.Matthew Barnes2009-05-296-75/+75 * Remove trailing whitespace, again.Matthew Barnes2009-05-299-15/+15 * Fix compiler warnings in plugins.Matthew Barnes2009-05-271-1/+2 * Bug 523216 – User-oriented plugin descriptionsMatthew Barnes2009-05-221-1/+1 * Fix several types of pedantic compiler warnings.Matthew Barnes2009-05-172-9/+5 * BUGFIX: 547414 - Publish Free/Busy calendar for configurable timeMilan Crha2009-05-046-17/+171 * ** BUGFIX: 573830 - g_timeout_add_seconds should be preferred to g_timeout_addMarcel Stimberg2009-05-041-4/+4 * Use Behdad's brilliant git.mk to generate .gitignore files.Matthew Barnes2009-05-021-0/+2 * Show error or success to user with publish-calendar pluginMilan Crha2009-04-256-72/+169 * ** Fix for bug #541209Suman Manjunath2009-01-213-2/+45 * ** Fix for bug #359010Milan Crha2008-12-162-0/+13 * Change licese from GPL to LGPL.Sankarasivasubramanian Pasupathilingam2008-10-033-25/+33 * ** Fix for bug #553461 and bug #553389Philip Withnall2008-09-265-7/+19 * Change License from GPL to LGPL. 2nd batch.Sankarasivasubramanian Pasupathilingam2008-09-036-65/+77 * License ChangesSankarasivasubramanian Pasupathilingam2008-08-273-22/+33 * updated novell copyright notices (left others alone)Jeffrey Stedfast2008-06-219-9/+9 * ** Fix for bug #526741 (gnome-vfs to gio/gvfs port)Milan Crha2008-04-188-109/+302 * Patch by <nickspoon0@gmail.com>Tobias Mueller2007-12-142-1/+9 * ** Remove trailing whitespace from source code.Matthew Barnes2007-11-155-23/+23 * use EVOLUTION_GLADEDIR instead of EVOLUTION_PLUGINDIR.Pedro Villavicencio Garrido2007-09-272-1/+8 * fix chen's string freeze break.Andre Klapper2007-09-112-2/+7 * Fixes #274047 (bnc)Chenthill Palanisamy2007-09-103-6/+17 * Fixes #277159 (bnc)Chenthill Palanisamy2007-09-102-0/+19 * Fixes #274048 (bnc)Chenthill Palanisamy2007-09-102-0/+23 * Update FSF address in header comments (#469886). Patch from TobiasMatthew Barnes2007-09-029-9/+9 * Fix some distcheck errors.Matthew Barnes2007-08-201-0/+1 * ** Fix for bug #455799Hiroyuki Ikezoe2007-08-041-3/+0 * calendar/gui/dialogs/memo-page.glade:Andre Klapper2007-07-312-1/+6 * Fix for bug #437584Srinivasa Ragavan2007-06-182-37/+43 * ** Fixes part of bug #337616Matthew Barnes2007-05-132-0/+6 * Bug 437584 – Compilation warning in evolution's plugins folderSankarasivasubramanian Pasupathilingam2007-05-112-5/+10 * ** Fixes bug #419524Matthew Barnes2007-03-212-1/+7 * Add the timezone information while publishing the calendars.Chenthill Palanisamy2007-02-212-0/+52 * Fixes some string to int conversion.Sankar P2007-02-192-2/+11 * Fixes #343991.Chenthill Palanisamy2006-08-022-0/+7 * Fixes #329740.Chenthill Palanisamy2006-07-312-1/+23 * Fixes #347973Chenthill Palanisamy2006-07-312-38/+21 * Fixes #328389Chenthill Palanisamy2006-03-032-2/+26 * fix mnemonicKarsten Bräckelmann2006-02-132-1/+6 * fixes #328413Chenthill Palanisamy2006-01-302-2/+99 * Make this place a bit more quietKjartan Maraas2006-01-283-0/+8 * removed string "dialog1" from translation. Fixes bug 306118.Andre Klapper2006-01-272-1/+5 * Fixes #328224, 328408, 328389Chenthill Palanisamy2006-01-253-27/+81 * added the bug id 325926`Chenthill Palanisamy2006-01-111-0/+1 * fixes appearance of the empty menu item in mail.Chenthill Palanisamy2006-01-112-2/+7 * Use EVOLUTION_PLUGINDIR as the macro name for the plugindir, to match whatTor Lillqvist2006-01-044-3/+25 * Mark vairous plugins as translatable (bug#301149).Funda Wang2005-12-253-5/+9 * Use -no-undefined on Windows. Link with used libraries.Tor Lillqvist2005-12-222-1/+9 * Use SOEXT.Tor Lillqvist2005-12-222-1/+5 * added the missing file.Chenthill Palanisamy2005-12-202-1/+7 * Committing the intial patch for calendar publishing.Chenthill Palanisamy2005-12-19