aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/allegro-devel/files/patch-CMakeLists.txt4
-rw-r--r--devel/allegro-devel/files/patch-loadpng.c10
2 files changed, 2 insertions, 12 deletions
diff --git a/devel/allegro-devel/files/patch-CMakeLists.txt b/devel/allegro-devel/files/patch-CMakeLists.txt
index 65e540d826d0..b23660677402 100644
--- a/devel/allegro-devel/files/patch-CMakeLists.txt
+++ b/devel/allegro-devel/files/patch-CMakeLists.txt
@@ -3,13 +3,13 @@
@@ -66,7 +66,7 @@
endif(WIN32)
- set(ALLEGRO_VERSION 4.4.1)
+ set(ALLEGRO_VERSION 4.4.2)
-string(REGEX MATCH "^[0-9]+[.][0-9]+" ALLEGRO_SOVERSION ${ALLEGRO_VERSION})
+string(REGEX MATCH "^[0-9]" ALLEGRO_SOVERSION ${ALLEGRO_VERSION})
# Mac OS X -compatibility_version.
# XXX doesn't seem to work
-@@ -884,7 +884,7 @@
+@@ -961,7 +961,7 @@
@ONLY
)
install(FILES ${LIBRARY_OUTPUT_PATH}/pkgconfig/${name}${lib_type}.pc
diff --git a/devel/allegro-devel/files/patch-loadpng.c b/devel/allegro-devel/files/patch-loadpng.c
deleted file mode 100644
index 6243d8e18ac1..000000000000
--- a/devel/allegro-devel/files/patch-loadpng.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- addons/loadpng/loadpng.c.orig 2010-03-03 04:18:36.000000000 +0100
-+++ addons/loadpng/loadpng.c 2012-04-25 19:36:29.000000000 +0200
-@@ -6,6 +6,7 @@
-
-
- #include <png.h>
-+#include <zlib.h>
- #include <allegro.h>
- #include <allegro/internal/aintern.h>
- #include "loadpng.h"