aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/libdca/Makefile10
-rw-r--r--multimedia/libdts/Makefile10
2 files changed, 18 insertions, 2 deletions
diff --git a/multimedia/libdca/Makefile b/multimedia/libdca/Makefile
index 1e171157b788..4df7e8c6b801 100644
--- a/multimedia/libdca/Makefile
+++ b/multimedia/libdca/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libdts
PORTVERSION= 0.0.2
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://debian.unnet.nl/pub/videolan/libdts/${PORTVERSION}/ \
http://download.videolan.org/pub/videolan/libdts/${PORTVERSION}/
@@ -19,4 +20,11 @@ USE_GNOME= pkgconfig gnomehack
MAN1= dtsdec.1 extract_dts.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldts|ldts_pic|' ${WRKSRC}/libdts/libdts.pc.in
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/libdts/Makefile b/multimedia/libdts/Makefile
index 1e171157b788..4df7e8c6b801 100644
--- a/multimedia/libdts/Makefile
+++ b/multimedia/libdts/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libdts
PORTVERSION= 0.0.2
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= http://debian.unnet.nl/pub/videolan/libdts/${PORTVERSION}/ \
http://download.videolan.org/pub/videolan/libdts/${PORTVERSION}/
@@ -19,4 +20,11 @@ USE_GNOME= pkgconfig gnomehack
MAN1= dtsdec.1 extract_dts.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+post-patch:
+ @${REINPLACE_CMD} -e 's|-ldts|ldts_pic|' ${WRKSRC}/libdts/libdts.pc.in
+.endif
+
+.include <bsd.port.post.mk>