aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/firefox-devel/Makefile4
-rw-r--r--www/firefox3-devel/Makefile4
-rw-r--r--www/firefox35/Makefile4
3 files changed, 12 insertions, 0 deletions
diff --git a/www/firefox-devel/Makefile b/www/firefox-devel/Makefile
index f1608d7100ab..916dc1d0bca2 100644
--- a/www/firefox-devel/Makefile
+++ b/www/firefox-devel/Makefile
@@ -52,6 +52,10 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= Does not compile on !i386
+.endif
+
GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
MOZ_OPTIONS+= --disable-svg
diff --git a/www/firefox3-devel/Makefile b/www/firefox3-devel/Makefile
index f1608d7100ab..916dc1d0bca2 100644
--- a/www/firefox3-devel/Makefile
+++ b/www/firefox3-devel/Makefile
@@ -52,6 +52,10 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= Does not compile on !i386
+.endif
+
GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
MOZ_OPTIONS+= --disable-svg
diff --git a/www/firefox35/Makefile b/www/firefox35/Makefile
index f1608d7100ab..916dc1d0bca2 100644
--- a/www/firefox35/Makefile
+++ b/www/firefox35/Makefile
@@ -52,6 +52,10 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
.include <bsd.port.pre.mk>
+.if ${ARCH} != "i386"
+BROKEN= Does not compile on !i386
+.endif
+
GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
MOZ_OPTIONS+= --disable-svg