aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--irc/keitairc/Makefile12
-rw-r--r--japanese/eijiro-fpw/Makefile9
-rw-r--r--japanese/kcode/Makefile2
-rw-r--r--japanese/mypaedia-fpw/Makefile12
-rw-r--r--japanese/otojiro-fpw/Makefile9
-rw-r--r--japanese/srd-fpw/Makefile12
-rw-r--r--japanese/waeijiro-fpw/Makefile9
-rw-r--r--www/raqdevil/Makefile8
8 files changed, 63 insertions, 10 deletions
diff --git a/irc/keitairc/Makefile b/irc/keitairc/Makefile
index 5553fe690e6c..962bc897ca94 100644
--- a/irc/keitairc/Makefile
+++ b/irc/keitairc/Makefile
@@ -15,7 +15,7 @@ EXTRACT_SUFX= #empty
MAINTAINER= matusita@FreeBSD.org
COMMENT=IRC proxy for mobilephone that have a web interface
-RUN_DEPENDS= ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
+RUN_DEPENDS= ${JCODE}:${PORTSDIR}/japanese/p5-Jcode \
${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
${SITE_PERL}/HTTP/Response.pm:${PORTSDIR}/www/p5-libwww \
@@ -36,4 +36,12 @@ do-patch:
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/keitairc ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/eijiro-fpw/Makefile b/japanese/eijiro-fpw/Makefile
index fb35842a3f47..c22b2c45381f 100644
--- a/japanese/eijiro-fpw/Makefile
+++ b/japanese/eijiro-fpw/Makefile
@@ -17,7 +17,7 @@ COMMENT= EIJIRO English - Japanese Dictionary (EPWING V1 format)
EXTRACT_DEPENDS=${LOCALBASE}/share/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing
BUILD_DEPENDS= ${LOCALBASE}/libexec/freepwing/catdump:${PORTSDIR}/japanese/freepwing \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
RESTRICTED= "The original dictionary is not free"
NO_PACKAGE= "The original dictionary is not free"
@@ -29,6 +29,13 @@ SRCFILE?= eijiro52.txt
# For eijiro included in a book sold by ALC Inc.
# (http://www.alc.co.jp/alcshop/eng/eijiro/)
.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
DICT_ARCHIVE!= ${ECHO_CMD} ${DICT_PATH}/eijiro-original/*.exe || ${TRUE}
.if exists(${DICT_ARCHIVE})
EXTRACT_DEPENDS+= lha:${PORTSDIR}/archivers/lha
diff --git a/japanese/kcode/Makefile b/japanese/kcode/Makefile
index 84c6219d2a07..612b6528f699 100644
--- a/japanese/kcode/Makefile
+++ b/japanese/kcode/Makefile
@@ -32,6 +32,8 @@ MANCOMPRESSED= no
IGNORE= This port requires perl 5.6.0 or later
.elif ${PERL_LEVEL} < 500800
_RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+else
+_RUN_DEPENDS= ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
.endif
do-extract:
diff --git a/japanese/mypaedia-fpw/Makefile b/japanese/mypaedia-fpw/Makefile
index 50e45af07e96..7ca91d3b1fe2 100644
--- a/japanese/mypaedia-fpw/Makefile
+++ b/japanese/mypaedia-fpw/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An encyclopedia "Mypaedia" (EPWING V1 format)
BUILD_DEPENDS= fpwmake:${PORTSDIR}/japanese/freepwing \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
IS_INTERACTIVE= YES
RESTRICTED= "The original dictionary is not free"
@@ -55,4 +55,12 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/otojiro-fpw/Makefile b/japanese/otojiro-fpw/Makefile
index 93303b4dd3fc..f05c86c3dd00 100644
--- a/japanese/otojiro-fpw/Makefile
+++ b/japanese/otojiro-fpw/Makefile
@@ -18,7 +18,7 @@ COMMENT= OTOJIRO English - Japanese Dictionary (EPWING V1 format)
EXTRACT_DEPENDS=${LOCALBASE}/share/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing
BUILD_DEPENDS= ${LOCALBASE}/libexec/freepwing/catdump:${PORTSDIR}/japanese/freepwing \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
RESTRICTED= "The original dictionary is not free"
NO_PACKAGE= "The original dictionary is not free"
@@ -31,6 +31,13 @@ SRCFILE?= otojiro.txt
# For eijiro included in a book sold by ALC Inc.
# (http://www.alc.co.jp/alcshop/eng/eijiro/)
.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
DICT_ARCHIVE!= ${ECHO_CMD} ${DICT_PATH}/eijiro-original/*.exe || ${TRUE}
.if exists(${DICT_ARCHIVE})
EXTRACT_DEPENDS+= lha:${PORTSDIR}/archivers/lha
diff --git a/japanese/srd-fpw/Makefile b/japanese/srd-fpw/Makefile
index 8ba4d468a858..9ef4313fe34f 100644
--- a/japanese/srd-fpw/Makefile
+++ b/japanese/srd-fpw/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A English - Japanese Dictionary "Random House" (EPWING V1 format)
BUILD_DEPENDS= fpwmake:${PORTSDIR}/japanese/freepwing \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
IS_INTERACTIVE= YES
RESTRICTED= "The original dictionary is not free"
@@ -59,4 +59,12 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/waeijiro-fpw/Makefile b/japanese/waeijiro-fpw/Makefile
index 91159a5d684a..1994b70fa7e6 100644
--- a/japanese/waeijiro-fpw/Makefile
+++ b/japanese/waeijiro-fpw/Makefile
@@ -18,7 +18,7 @@ COMMENT= WAEIJIRO English - Japanese Dictionary (EPWING V1 format)
EXTRACT_DEPENDS=${LOCALBASE}/share/freepwing/fpwutils.mk:${PORTSDIR}/japanese/freepwing
BUILD_DEPENDS= ${LOCALBASE}/libexec/freepwing/catdump:${PORTSDIR}/japanese/freepwing \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
RESTRICTED= "The original dictionary is not free"
NO_PACKAGE= "The original dictionary is not free"
@@ -29,6 +29,13 @@ SRCFILE?= waeiji52.txt
# For eijiro included in a book sold by ALC Inc.
# (http://www.alc.co.jp/alcshop/eng/eijiro/)
.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
DICT_ARCHIVE!= ${ECHO_CMD} ${DICT_PATH}/eijiro-original/*.exe || ${TRUE}
.if exists(${DICT_ARCHIVE})
EXTRACT_DEPENDS+= lha:${PORTSDIR}/archivers/lha
diff --git a/www/raqdevil/Makefile b/www/raqdevil/Makefile
index b4570d51408e..a44eaa47d270 100644
--- a/www/raqdevil/Makefile
+++ b/www/raqdevil/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= dodell@offmyserver.com
COMMENT= A port of the Sun Cobalt RaQ550 software to FreeBSD
RUN_DEPENDS= ${LOCALBASE}/sbin/sendmail:${PORTSDIR}/mail/${SENDMAIL_MILTER_PORT} \
- ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode \
${SITE_PERL}/mach/Quota.pm:${PORTSDIR}/sysutils/p5-Quota \
${SITE_PERL}/mach/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
@@ -47,6 +47,12 @@ LDCONFIG_DIRS= ${PREFIX}/raqdevil/lib
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
.if !defined(SENDMAIL_MILTER_PORT)
SENDMAIL_MILTER_PORT?= sendmail-sasl
.else