aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/openssl-beta/Makefile10
-rw-r--r--security/openssl/Makefile10
2 files changed, 20 insertions, 0 deletions
diff --git a/security/openssl-beta/Makefile b/security/openssl-beta/Makefile
index aa128d762118..3db3c2173dfa 100644
--- a/security/openssl-beta/Makefile
+++ b/security/openssl-beta/Makefile
@@ -850,6 +850,16 @@ INSTALLS_SHLIB= yes
.endif
.if defined(OPENSSL_OVERWRITE_BASE)
+.if exists(/lib/libcrypto.so)
+pre-everything::
+ @${ECHO_CMD} "#"
+ @${ECHO_CMD} "# this ports does not support the dynamic root"
+ @${ECHO_CMD} "# please undefine OPENSSL_OVERWRITE_BASE"
+ @${ECHO_CMD} "# and use WITH_OPENSSL_PORT=yes instead."
+ @${ECHO_CMD} "#"
+ @${FALSE}
+
+.endif
PKGNAMESUFFIX= -beta-overwrite-base
PREFIX= /usr
OPENSSLDIR= /etc/ssl
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 402e7d85fa3b..b502e22bab66 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -834,6 +834,16 @@ INSTALLS_SHLIB= yes
.endif
.if defined(OPENSSL_OVERWRITE_BASE)
+.if exists(/lib/libcrypto.so)
+pre-everything::
+ @${ECHO_CMD} "#"
+ @${ECHO_CMD} "# this ports does not support the dynamic root"
+ @${ECHO_CMD} "# please undefine OPENSSL_OVERWRITE_BASE"
+ @${ECHO_CMD} "# and use WITH_OPENSSL_PORT=yes instead."
+ @${ECHO_CMD} "#"
+ @${FALSE}
+
+.endif
PKGNAMESUFFIX= -overwrite-base
PREFIX= /usr
OPENSSLDIR= /etc/ssl