aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/pike72/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
index 6aee9746e5e5..2fa99dabd4b4 100644
--- a/lang/pike72/Makefile
+++ b/lang/pike72/Makefile
@@ -28,8 +28,6 @@ USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --without-debug \
- --with-double-precision \
- --with-long-double-precision \
--disable-rpath \
--without-rtldebug \
--without-cdebug \
@@ -54,8 +52,8 @@ CONFIGURE_ARGS+= --without-debug \
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Build fails on !i386"
+.if ${ARCH} == "i386"
+CONFIGURE_ARGS+= --with-long-double-precision
.endif
PLIST_SUB+= PORTVERSION=${PORTVERSION}