aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/shmux/Makefile41
-rw-r--r--net/shmux/distinfo2
-rw-r--r--net/shmux/pkg-descr11
-rw-r--r--net/shmux/pkg-plist3
5 files changed, 58 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index aba6f1cdf3c9..35a796713d06 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -693,6 +693,7 @@
SUBDIR += ser
SUBDIR += serveez
SUBDIR += sharity-light
+ SUBDIR += shmux
SUBDIR += silc-client
SUBDIR += silc-server
SUBDIR += silky
diff --git a/net/shmux/Makefile b/net/shmux/Makefile
new file mode 100644
index 000000000000..8125aebdfcca
--- /dev/null
+++ b/net/shmux/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: shmux
+# Date created: 2 September 2004
+# Whom: jamundsen
+#
+# $FreeBSD$
+#
+
+PORTNAME= shmux
+DISTVERSION= 1.0b4
+CATEGORIES= net
+MASTER_SITES= http://web.taranis.org/shmux/dist/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= online@jamundsen.dyndns.org
+COMMENT= Utility to run commands on multiple hosts using shell commands
+
+OPTIONS= FPING "Use fping utility" on \
+ PCRE "Use perl regular expressions library" off
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --datadir=${PREFIX}/share/examples
+
+ALL_TARGET= ${PORTNAME}
+
+MAN1= shmux.1
+MANCOMPRESSED= no
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_FPING)
+RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
+.endif
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}/lib
+.else
+CONFIGURE_ARGS+= --with-pcre=no
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/shmux/distinfo b/net/shmux/distinfo
new file mode 100644
index 000000000000..b06897871618
--- /dev/null
+++ b/net/shmux/distinfo
@@ -0,0 +1,2 @@
+MD5 (shmux-1.0b4.tgz) = 969bb5ee3799dd9c804a77ca143c5fd8
+SIZE (shmux-1.0b4.tgz) = 76727
diff --git a/net/shmux/pkg-descr b/net/shmux/pkg-descr
new file mode 100644
index 000000000000..3df5beb723f9
--- /dev/null
+++ b/net/shmux/pkg-descr
@@ -0,0 +1,11 @@
+Shmux is program for executing the same command on many hosts in parallel. For
+each target, a child process is spawned by shmux, and a shell on the target
+obtained one of the supported methods: rsh, ssh, or sh. The output produced by
+the children is received by shmux and either (optionally) output in turn to the
+user using an easy to read format, or written to files for later processing
+making it well suited for use in scripts.
+
+WWW: http://web.taranis.org/shmux/
+
+- Jon Amundsen
+online@jamundsen.dyndns.org
diff --git a/net/shmux/pkg-plist b/net/shmux/pkg-plist
new file mode 100644
index 000000000000..96f23e70665c
--- /dev/null
+++ b/net/shmux/pkg-plist
@@ -0,0 +1,3 @@
+bin/shmux
+%%EXAMPLESDIR%%/mcmd.sh
+@dirrm %%EXAMPLESDIR%%