aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/xstow/Makefile27
-rw-r--r--sysutils/xstow/distinfo4
-rw-r--r--sysutils/xstow/files/manpages.mk2
-rw-r--r--sysutils/xstow/files/patch-src-format.h26
-rw-r--r--sysutils/xstow/pkg-plist7
5 files changed, 20 insertions, 46 deletions
diff --git a/sysutils/xstow/Makefile b/sysutils/xstow/Makefile
index 274dc9f5ba0a..d20bf499eaaf 100644
--- a/sysutils/xstow/Makefile
+++ b/sysutils/xstow/Makefile
@@ -1,5 +1,3 @@
-# ex:ts=8 -*-mode: makefile-*-
-#
# New ports collection makefile for: xstow
# Date created: 2002-12-31
# Whom: Alan Eldridge <alane@geeksrus.net>
@@ -8,19 +6,30 @@
#
PORTNAME= xstow
-PORTVERSION= 0.5.1
-PORTREVISION= 1
-PORTEPOCH= 0
+PORTVERSION= 1.0.0
CATEGORIES= sysutils
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rakuco@FreeBSD.org
COMMENT= Enhanced replacement for GNU stow written in C++
-USE_GMAKE= yes
+USE_BZIP2= yes
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
-MAN1= xstow.1
+PLIST_FILES= bin/merge-info bin/xstow bin/xstow-static bin/xstow-stow
+MAN1= merge-info.1 xstow.1
MAN5= xstow.ini.5
+# This port always installs documentation, so we cannot respect NOPORTDOCS
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS README TODO xstow.html xstow.ini xstow.ini.html
+
+post-install:
+ (cd ${WRKSRC} && \
+ ${INSTALL_MAN} AUTHORS COPYING ChangeLog NEWS README TODO ${DOCSDIR})
+
.include <bsd.port.mk>
diff --git a/sysutils/xstow/distinfo b/sysutils/xstow/distinfo
index 6d9f328a09b1..ca2ee5a3567b 100644
--- a/sysutils/xstow/distinfo
+++ b/sysutils/xstow/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xstow-0.5.1.tar.gz) = 7543a46dd61a352647c74d60080d8a2c50db0c0b178316b6a367d7e60e2b38cf
-SIZE (xstow-0.5.1.tar.gz) = 138091
+SHA256 (xstow-1.0.0.tar.bz2) = 0109f10fb25a474803ec357a38c17d806dd9a21eac39b21d79b48c2af571c0fe
+SIZE (xstow-1.0.0.tar.bz2) = 153206
diff --git a/sysutils/xstow/files/manpages.mk b/sysutils/xstow/files/manpages.mk
deleted file mode 100644
index 1f8eeebdc954..000000000000
--- a/sysutils/xstow/files/manpages.mk
+++ /dev/null
@@ -1,2 +0,0 @@
-MAN1+= xstow.1
-MAN5+= xstow.ini.5
diff --git a/sysutils/xstow/files/patch-src-format.h b/sysutils/xstow/files/patch-src-format.h
deleted file mode 100644
index 166252e2e9f8..000000000000
--- a/sysutils/xstow/files/patch-src-format.h
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/format.h.orig Wed Dec 20 16:46:15 2006
-+++ src/format.h Wed Dec 20 16:46:55 2006
-@@ -648,17 +648,17 @@
-
- switch( num_of_args )
- {
-- case 1: n = std::snprintf( buffer, buffer_size, format.c_str(),
-+ case 1: n = snprintf( buffer, buffer_size, format.c_str(),
- D( a ) ); break;
-- case 2: n = std::snprintf( buffer, buffer_size, format.c_str(),
-+ case 2: n = snprintf( buffer, buffer_size, format.c_str(),
- D( a ), D( b ) ); break;
-- case 3: n = std::snprintf( buffer, buffer_size, format.c_str(),
-+ case 3: n = snprintf( buffer, buffer_size, format.c_str(),
- D( a ), D( b ), D( c ) ); break;
-- case 4: n = std::snprintf( buffer, buffer_size, format.c_str(),
-+ case 4: n = snprintf( buffer, buffer_size, format.c_str(),
- D( a ), D( b ), D( c ), D( d ) ); break;
-- case 5: n = std::snprintf( buffer, buffer_size, format.c_str(),
-+ case 5: n = snprintf( buffer, buffer_size, format.c_str(),
- D( a ), D( b ), D( c ), D( d ), D( e ) ); break;
-- case 6: n = std::snprintf( buffer, buffer_size, format.c_str(),
-+ case 6: n = snprintf( buffer, buffer_size, format.c_str(),
- D( a ), D( b ), D( c ), D( d ), D( e ), D( f ) ); break;
- }
-
diff --git a/sysutils/xstow/pkg-plist b/sysutils/xstow/pkg-plist
deleted file mode 100644
index 58f1aa61c61c..000000000000
--- a/sysutils/xstow/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-bin/xstow
-bin/xstow-static
-bin/xstow-stow
-share/doc/xstow/xstow.html
-share/doc/xstow/xstow.ini
-share/doc/xstow/xstow.ini.html
-@dirrm share/doc/xstow