aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/ez-ipupdate/Makefile2
-rw-r--r--dns/ez-ipupdate/files/patch-ez-ipupdate.c14
-rw-r--r--security/vuxml/vuln.xml27
3 files changed, 42 insertions, 1 deletions
diff --git a/dns/ez-ipupdate/Makefile b/dns/ez-ipupdate/Makefile
index 2665221b7f04..dee462673926 100644
--- a/dns/ez-ipupdate/Makefile
+++ b/dns/ez-ipupdate/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ez-ipupdate
PORTVERSION= 3.0.11b8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= http://www.gusnet.cx:8080/proj/ez-ipupdate/dist/
diff --git a/dns/ez-ipupdate/files/patch-ez-ipupdate.c b/dns/ez-ipupdate/files/patch-ez-ipupdate.c
new file mode 100644
index 000000000000..6ba272b0ec99
--- /dev/null
+++ b/dns/ez-ipupdate/files/patch-ez-ipupdate.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- ez-ipupdate.c.orig
++++ ez-ipupdate.c
+@@ -798,7 +798,7 @@
+ sprintf(buf, "message incomplete because your OS sucks: %s\n", fmt);
+ #endif
+
+- syslog(LOG_NOTICE, buf);
++ syslog(LOG_NOTICE, "%s", buf);
+ }
+ else
+ {
diff --git a/security/vuxml/vuln.xml b/security/vuxml/vuln.xml
index c6a87287a098..c95ee725e290 100644
--- a/security/vuxml/vuln.xml
+++ b/security/vuxml/vuln.xml
@@ -32,6 +32,33 @@ EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-->
<vuxml xmlns="http://www.vuxml.org/apps/vuxml-1">
+ <vuln vid="e69ba632-326f-11d9-b5b7-000854d03344">
+ <topic>ez-ipupdate -- format string vulnerability</topic>
+ <affects>
+ <package>
+ <name>ez-ipupdate</name>
+ <range><lt>3.0.11b8_2</lt></range>
+ </package>
+ </affects>
+ <description>
+ <body xmlns="http://www.w3.org/1999/xhtml">
+ <p>Data supplied by a remote server is used as the format string
+ instead of as parameters in a syslog() call. This may lead
+ to crashes or potential running of arbitrary code. It is
+ only a problem when running in daemon mode (very common) and
+ when using some service types.</p>
+ </body>
+ </description>
+ <references>
+ <cvename>CAN-2004-0980</cvename>
+ <mlist>http://lists.netsys.com/pipermail/full-disclosure/2004-November/028590.html</mlist>
+ </references>
+ <dates>
+ <discovery>2004-11-11</discovery>
+ <entry>2004-11-11</entry>
+ </dates>
+ </vuln>
+
<vuln vid="eeb1c128-33e7-11d9-a9e7-0001020eed82">
<topic>ImageMagick -- EXIF parser buffer overflow</topic>
<affects>