aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/boinc-astropulse/Makefile2
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile2
-rw-r--r--astro/boinc-setiathome-v7/Makefile2
-rw-r--r--emulators/fuse-utils/Makefile6
-rw-r--r--emulators/fuse/Makefile10
-rw-r--r--emulators/libspectrum/Makefile2
-rw-r--r--games/torcs/Makefile4
7 files changed, 14 insertions, 14 deletions
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index 4a9afe6048ca..ea469a46aba6 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3 \
${NONEXISTENT}:${PORTSDIR}/astro/boinc-setiathome-v7:patch
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
-LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float
+LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float
NO_STAGE= yes
USES= gmake pkgconfig
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index 6e9c49fca46b..141fd589627f 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -18,7 +18,7 @@ DEPRECATED= Project is switching, use astro/boinc-setiathome-v7 instead
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
-LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float
+LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float
NO_STAGE= yes
USES= gmake pkgconfig
diff --git a/astro/boinc-setiathome-v7/Makefile b/astro/boinc-setiathome-v7/Makefile
index 0994bac0dfc5..93a1fc1d7553 100644
--- a/astro/boinc-setiathome-v7/Makefile
+++ b/astro/boinc-setiathome-v7/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
-LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float
+LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float
NO_STAGE= yes
USES= gmake pkgconfig
diff --git a/emulators/fuse-utils/Makefile b/emulators/fuse-utils/Makefile
index a14e97cfe774..94a18954325e 100644
--- a/emulators/fuse-utils/Makefile
+++ b/emulators/fuse-utils/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= pkgconfig
-LIB_DEPENDS= spectrum:${PORTSDIR}/emulators/libspectrum
+LIB_DEPENDS= libspectrum.so:${PORTSDIR}/emulators/libspectrum
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libspectrum-prefix=${LOCALBASE} \
--with-local-prefix=${LOCALBASE}
@@ -33,7 +33,7 @@ NO_STAGE= yes
.if ${PORT_OPTIONS:MAUDIOTOOLS}
CONFIGURE_ARGS+=--with-audiofile
-LIB_DEPENDS+= audiofile:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS+= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
PLIST_SUB= AUDIOTOOLS=""
MAN1+= audio2tape.1 tape2wav.1
.else
@@ -43,7 +43,7 @@ PLIST_SUB= AUDIOTOOLS="@comment "
# FIXME no way to specify ffmpeg1 paths to configure script
#.if ${PORT_OPTIONS:MFFMPEG}
-#LIB_DEPENDS+= avformat1:${PORTSDIR}/multimedia/ffmpeg1
+#LIB_DEPENDS+= libavformat1.so:${PORTSDIR}/multimedia/ffmpeg1
#CONFIGURE_ARGS+=--with-ffmpeg
#.else
CONFIGURE_ARGS+=--without-ffmpeg
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index 33bf066b3d32..f4a51e4f535f 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -11,9 +11,9 @@ COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
LICENSE= GPLv2
-LIB_DEPENDS= spectrum:${PORTSDIR}/emulators/libspectrum \
- png15:${PORTSDIR}/graphics/png \
- gcrypt:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= libspectrum.so:${PORTSDIR}/emulators/libspectrum \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
USES= pkgconfig
@@ -35,13 +35,13 @@ NO_STAGE= yes
.if ${PORT_OPTIONS:MAO}
CONFIGURE_ARGS+=--with-libao
-LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
+LIB_DEPENDS+= libao.so:${PORTSDIR}/audio/libao
.else
CONFIGURE_ARGS+=--without-libao
.endif
.if ${PORT_OPTIONS:MSAMPLERATE}
-LIB_DEPENDS+= samplerate:${PORTSDIR}/audio/libsamplerate
+LIB_DEPENDS+= libsamplerate.so:${PORTSDIR}/audio/libsamplerate
.else
CONFIGURE_ARGS+=--without-libsamplerate
.endif
diff --git a/emulators/libspectrum/Makefile b/emulators/libspectrum/Makefile
index 60839cb04afe..ed3a9999988a 100644
--- a/emulators/libspectrum/Makefile
+++ b/emulators/libspectrum/Makefile
@@ -11,7 +11,7 @@ COMMENT= Handling of ZX-Spectrum emulator files formats
LICENSE= GPLv2
-LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
USE_GNOME= glib20
diff --git a/games/torcs/Makefile b/games/torcs/Makefile
index dfbbda4a7be3..94fe1b4749b8 100644
--- a/games/torcs/Makefile
+++ b/games/torcs/Makefile
@@ -15,8 +15,8 @@ LICENSE= GPLv2
MAKE_JOBS_UNSAFE= yes
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USES= gmake shebangfix