aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/uds/Makefile25
-rw-r--r--devel/uds/distinfo1
-rw-r--r--devel/uds/files/patch-Makefile.in15
-rw-r--r--devel/uds/files/patch-uds::procstream.cc12
-rw-r--r--devel/uds/files/patch-uds::socket.cc10
-rw-r--r--devel/uds/files/patch-uds::sys_util.hh10
-rw-r--r--devel/uds/pkg-comment1
-rw-r--r--devel/uds/pkg-descr23
-rw-r--r--devel/uds/pkg-plist41
10 files changed, 139 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index da026fcda133..409241584c69 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -409,6 +409,7 @@
SUBDIR += tvision
SUBDIR += uclmmbase
SUBDIR += ucpp
+ SUBDIR += uds
SUBDIR += ups-debug
SUBDIR += veepee
SUBDIR += viewcvs
diff --git a/devel/uds/Makefile b/devel/uds/Makefile
new file mode 100644
index 000000000000..400f5a33dfdb
--- /dev/null
+++ b/devel/uds/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: uds
+# Date created: Feb 27, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uds
+PORTVERSION= 0.9.3
+CATEGORIES= devel
+MASTER_SITES= http://frost.flewid.de/dist/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-debug
+
+USE_GMAKE= yes
+USE_NEWGCC= yes
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/devel/uds/distinfo b/devel/uds/distinfo
new file mode 100644
index 000000000000..3269555cb7f6
--- /dev/null
+++ b/devel/uds/distinfo
@@ -0,0 +1 @@
+MD5 (uds-0.9.3.tar.gz) = 5ea0959de10314da31e8cf35d2001849
diff --git a/devel/uds/files/patch-Makefile.in b/devel/uds/files/patch-Makefile.in
new file mode 100644
index 000000000000..3b2bedadf1bb
--- /dev/null
+++ b/devel/uds/files/patch-Makefile.in
@@ -0,0 +1,15 @@
+--- Makefile.in.orig Tue Feb 27 14:29:36 2001
++++ Makefile.in Tue Feb 27 14:30:46 2001
+@@ -377,9 +377,9 @@
+ cp `find $(srcdir)/test/ -type f -maxdepth 1` $(top_distdir)/test
+
+ install-data-hook:
+- rm -Rf $(prefix)/doc/uds
+- mkdir -p $(prefix)/doc/uds
+- cp $(srcdir)/doc/*.html $(prefix)/doc/uds
++ rm -Rf $(prefix)/share/uds/doc
++ mkdir -p $(prefix)/share/uds/doc
++ cp $(srcdir)/doc/*.html $(prefix)/share/uds/doc
+
+ uninstall-local:
+ rm -Rf /usr/doc/uds
diff --git a/devel/uds/files/patch-uds::procstream.cc b/devel/uds/files/patch-uds::procstream.cc
new file mode 100644
index 000000000000..1b0d68eb0c76
--- /dev/null
+++ b/devel/uds/files/patch-uds::procstream.cc
@@ -0,0 +1,12 @@
+--- uds/procstream.cc.orig Tue Feb 27 13:50:01 2001
++++ uds/procstream.cc Tue Feb 27 13:50:08 2001
+@@ -22,8 +22,8 @@
+
+ // includes
+
+-#include <sys/socket.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <sys/wait.h>
+ #include <uds/procstream.hh>
+ #include <uds/sys_util.hh>
diff --git a/devel/uds/files/patch-uds::socket.cc b/devel/uds/files/patch-uds::socket.cc
new file mode 100644
index 000000000000..a0bae732531f
--- /dev/null
+++ b/devel/uds/files/patch-uds::socket.cc
@@ -0,0 +1,10 @@
+--- uds/socket.cc.orig Tue Feb 27 13:59:39 2001
++++ uds/socket.cc Tue Feb 27 14:00:40 2001
+@@ -25,6 +25,7 @@
+ #include "config.h"
+ #ifdef HAVE_SOCKET
+
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
diff --git a/devel/uds/files/patch-uds::sys_util.hh b/devel/uds/files/patch-uds::sys_util.hh
new file mode 100644
index 000000000000..7791ea54448c
--- /dev/null
+++ b/devel/uds/files/patch-uds::sys_util.hh
@@ -0,0 +1,10 @@
+--- uds/sys_util.hh.orig Tue Feb 27 13:54:05 2001
++++ uds/sys_util.hh Tue Feb 27 13:57:50 2001
+@@ -25,6 +25,7 @@
+
+ // includes
+
++#include <sys/types.h>
+ #include <uds/stdexcpt.hh>
+
+ using namespace std;
diff --git a/devel/uds/pkg-comment b/devel/uds/pkg-comment
new file mode 100644
index 000000000000..df8bd7c9785d
--- /dev/null
+++ b/devel/uds/pkg-comment
@@ -0,0 +1 @@
+UDS (Useful Development Stuff) Collection
diff --git a/devel/uds/pkg-descr b/devel/uds/pkg-descr
new file mode 100644
index 000000000000..5e7aa7c8556c
--- /dev/null
+++ b/devel/uds/pkg-descr
@@ -0,0 +1,23 @@
+The UDS (Useful Development Stuff) Collection is a C++ library that
+assists you while developing and debugging programs. It was developed
+as part of Frost. Features were only added when needed, but it
+provides already a nice bunch of features.
+
+Features:
+ - Automatic search for memory leaks
+ - Logging of memory [de]allocations
+ - Zombie objects
+ - Exception system for (almost) fatal errors. A core can be dumped
+ when the exception is thrown.
+ - Action, FinalAction, and VRemember
+ - Function objects that are more flexible than STL function objects
+ - Threads, Mutexes, Semaphores Posix Threads wrapper classes
+ - Socket Stream class
+ - ProcStream class (new)
+ - Classes for reference counting that make it easy to implement
+ copy-on-write and garbage collection.
+ - Simple pseudo-random number generators
+ - Several "convenience functions" to create temporary file names;
+ open files, fork, wait etc. and throw an exception if something goes wrong
+
+WWW: http://frost.flewid.de/uds/
diff --git a/devel/uds/pkg-plist b/devel/uds/pkg-plist
new file mode 100644
index 000000000000..7c1198cf550d
--- /dev/null
+++ b/devel/uds/pkg-plist
@@ -0,0 +1,41 @@
+include/uds/action.hh
+include/uds/alloc.hh
+include/uds/auto_ptr.hh
+include/uds/check_ptr.hh
+include/uds/childdiag.hh
+include/uds/collector.hh
+include/uds/dcast.hh
+include/uds/diagnose.hh
+include/uds/errnodiag.hh
+include/uds/exception.hh
+include/uds/exit.hh
+include/uds/flex_func.hh
+include/uds/functional.hh
+include/uds/log.hh
+include/uds/md5.h
+include/uds/procstream.hh
+include/uds/random.hh
+include/uds/refcounter.hh
+include/uds/sentinel.hh
+include/uds/socket.hh
+include/uds/stdexcpt.hh
+include/uds/stl_ext.hh
+include/uds/stl_util.hh
+include/uds/strstream.hh
+include/uds/sys_util.hh
+include/uds/thread.hh
+include/uds/time.hh
+include/uds/uds.hh
+@dirrm include/uds
+lib/libuds.a
+lib/libuds.so
+lib/libuds.so.0
+share/uds/doc/relnotes.html
+share/uds/doc/index.html
+share/uds/doc/features.html
+share/uds/doc/download.html
+share/uds/doc/contributing.html
+share/uds/doc/config.html
+share/uds/udsdeff.cc
+@dirrm share/uds/doc
+@dirrm share/uds